指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 趋势 操盘控盘 
微信截图_20190304094519.png

微信截图_20190304094538.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=(HHV(HIGH,8)-LLV(LOW,8));
VAR2:=(HHV(HIGH,8)-CLOSE);
VAR3:=(CLOSE-LLV(LOW,8));
VAR4:=VAR2/VAR1*100-70 ;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*C+H+L)/4;
VAR7:=SMA((VAR3/VAR1*100),3,1);
VAR8:=LLV(LOW,30);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:= IF(VAR9>100,VAR9-100,0);
VARA:=HHV(HIGH,30);
B:EMA((VAR6-VAR8)/(VARA-VAR8)*100,8),COLORRED;
B1:=EMA(B,5);
STICKLINE(B>0 AND B-B1>=0,79,80,6,0),COLORRED;
STICKLINE(B>0 AND B-B1<0,79,80,6,0),COLOR00FF00;
STICKLINE(B>0 AND B-B1>=0,49,50,6,0),COLORRED;
STICKLINE(B>0 AND B-B1<0,49,50,6,0),COLORFF8899;
STICKLINE(B>0 AND B-B1>=0,19,20,6,0),COLORRED;
STICKLINE(B>0 AND B-B1<0,19,20,6,0),COLOR00FF00;
STICKLINE(B-B1>0,B,B1,8,1),COLORRED;
STICKLINE(B-B1<0,B,B1,8,1),COLOR00FF00;[/lycode][lycode=tdx2,true]VAR1赋值:(8日内最高价的最高值-8日内最低价的最低值)
VAR2赋值:(8日内最高价的最高值-收盘价)
VAR3赋值:(收盘价-8日内最低价的最低值)
VAR4赋值:VAR2/VAR1*100-70
VAR5赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VAR6赋值:(2*收盘价+最高价+最低价)/4
VAR7赋值:(VAR3/VAR1*100)的3日[1日权重]移动平均
VAR8赋值:30日内最低价的最低值
VAR9赋值:VAR7的3日[1日权重]移动平均-VAR4的9日[1日权重]移动平均
VAR10赋值: 如果VAR9>100,返回VAR9-100,否则返回0
VARA赋值:30日内最高价的最高值
输出B:(VAR6-VAR8)/(VARA-VAR8)*100的8日指数移动平均,画红色
B1赋值:B的5日指数移动平均
当满足条件B>0ANDB-B1>=0时,在79和80位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色
当满足条件B>0ANDB-B1<0时,在79和80位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLOR00FF00
当满足条件B>0ANDB-B1>=0时,在49和50位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色
当满足条件B>0ANDB-B1<0时,在49和50位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF8899
当满足条件B>0ANDB-B1>=0时,在19和20位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色
当满足条件B>0ANDB-B1<0时,在19和20位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLOR00FF00
当满足条件B-B1>0时,在B和B1位置之间画柱状线,宽度为8,1不为0则画空心柱.,画红色
当满足条件B-B1<0时,在B和B1位置之间画柱状线,宽度为8,1不为0则画空心柱.,COLOR00FF00[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1RfXy-dUsuGqEsVGCQbpPNw

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复