指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
微信截图_20190304093549.png

微信截图_20190304093559.png

[lywrap=通达信主图指标公式][lycode=tdx,true]JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
卖:=IF(红色持股,JRL,DRAWNULL);
明卖价:=卖,COLORFF99FF,NODRAW;
今卖价:REF(卖,1)COLOR0000FF,NODRAW;
青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:REF(明进场价,1),COLORFF0000,NODRAW;
买:VAR19,COLOR33AACC,NODRAW;
品红卖:VAR1A,COLORFF99FF,NODRAW;
急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF;
辰星线: (20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)
+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF
(YTSL,20))/211,COLOR0000FF;
牵牛线:MA(CLOSE,26),COLORFF00FF;
等待:=IF(MA3>辰星线,辰星线,MA3);
IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF;
IF(辰星线>REF(辰星线,1),辰星线,DRAWNULL),LINETHICK2,COLOR0000FF;
IF(辰星线<REF(辰星线,1),辰星线,DRAWNULL),COLOR00FF00;
IF(牵牛线>REF(牵牛线,1),牵牛线,DRAWNULL),LINETHICK1,COLORFF00FF;
IF(牵牛线<REF(牵牛线,1),牵牛线,DRAWNULL),COLOR669933;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今卖价,今卖价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(买,O,O+CO/3,0,0),COLOR33EEEE;
DRAWTEXT(买,REF(CLOSE,1),'←买'),COLOR33FFCC;
STICKLINE(品红卖,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品红卖,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品红卖,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红卖,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品红卖,O,O+CO/3,0.5,0),COLOREE00EE;
DRAWTEXT(品红卖,REF(CLOSE,1)+0.1,'←卖'),COLORFF99FF;[/lycode][lycode=tdx2,true]JRH赋值:2日内收盘价的最高值
JRL赋值:2日内收盘价的最低值
MA3赋值:收盘价的3日简单移动平均
YTSL赋值:(3*收盘价+最低价+开盘价+最高价)/6
VAR1赋值:(收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价)
VAR2赋值:(1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR3赋值:(1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR4赋值:(1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR5赋值:(1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR6赋值:(1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR7赋值:(1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR8赋值:(1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR9赋值:(1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARA赋值:(1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARB赋值:(1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARC赋值:(1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARD赋值:(收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价)
VARE赋值:(1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARF赋值:(1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR10赋值:(1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR11赋值:(1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR12赋值:(1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR13赋值:(1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR14赋值:(1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR15赋值:(1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR16赋值:(1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR17赋值:(1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR18赋值:(1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR19赋值:((1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18) AND VAR1)
VAR1A赋值:((1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC) AND VARD)
输出 红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW
卖赋值:如果红色持股,返回JRL,否则返回无效数
明卖价赋值:卖,COLORFF99FF,NODRAW
输出 今卖价:1日前的卖COLOR0000FF,NODRAW
输出 青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW
进赋值:如果青色观望,返回JRH,否则返回无效数
明进场价赋值:进,COLOR33AACC,NODRAW
输出 今进场价:1日前的明进场价,COLORFF0000,NODRAW
输出 买:VAR19,COLOR33AACC,NODRAW
输出 品红卖:VAR1A,COLORFF99FF,NODRAW
输出 急速超跌:(收盘价-收盘价的34日简单移动平均)/收盘价的34日简单移动平均*100<-14,COLORFFFFFF,NODRAW
输出 上市日期年:收盘价的有效数据周期数-1日前的年份,NODRAW,COLOR0000FF
输出 月:收盘价的有效数据周期数-1日前的月份,NODRAW,COLORFF00FF
输出 日:收盘价的有效数据周期数-1日前的日,NODRAW,COLOR00FFFF
输出 辰星线: (20*YTSL+19*1日前的YTSL+18*2日前的YTSL+17*3日前的YTSL+16*4日前的YTSL+15*5日前的YTSL+14*6日前的YTSL+13*7日前的YTSL+12*8日前的YTSL+11*9日前的YTSL +10*10日前的YTSL+9*11日前的YTSL+8*12日前的YTSL+7*13日前的YTSL+6*14日前的YTSL+5*15日前的YTSL+4*16日前的YTSL+3*17日前的YTSL+2*18日前的YTSL+20日前的YTSL)/211,COLOR0000FF
输出 牵牛线:收盘价的26日简单移动平均,COLORFF00FF
等待赋值:如果MA3>辰星线,返回辰星线,否则返回MA3
如果等待>1日前的等待,返回等待,否则返回无效数,线宽为2,COLOR00FFFF
如果辰星线>1日前的辰星线,返回辰星线,否则返回无效数,线宽为2,COLOR0000FF
如果辰星线<1日前的辰星线,返回辰星线,否则返回无效数,COLOR00FF00
如果牵牛线>1日前的牵牛线,返回牵牛线,否则返回无效数,线宽为1,COLORFF00FF
如果牵牛线<1日前的牵牛线,返回牵牛线,否则返回无效数,COLOR669933
当满足条件ISLASTBARAND(红色持股ORREF(红色持股,1)=1)时,在今卖价和今卖价位置之间画柱状线,宽度为30,1不为0则画空心柱.,COLOR0000FF
当满足条件ISLASTBARAND(青色观望ORREF(青色观望,1)=1)时,在今进场价和今进场价位置之间画柱状线,宽度为30,1不为0则画空心柱.,COLOR00FF00
当满足条件收盘价>=开盘价时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000CC
当满足条件收阴线时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR999900
当满足条件1时,在收盘价和开盘价位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR858500
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR0000E5
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR000055
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000088
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000AA
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000CC
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000EE
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR555500
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR888800
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAAAA00
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCCCC00
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOREEEE00
CO赋值:(收盘价-开盘价)
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR555555
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR888888
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAAAAAA
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCCCCCC
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOREEEEEE
当满足条件买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR335555
当满足条件买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR338888
当满足条件买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR33AAAA
当满足条件买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR33CCCC
当满足条件买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR33EEEE
当满足条件买时,在1日前的收盘价位置书写文字,COLOR33FFCC
当满足条件品红卖时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR550055
当满足条件品红卖时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR880088
当满足条件品红卖时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAA00AA
当满足条件品红卖时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCC00CC
当满足条件品红卖时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOREE00EE
当满足条件品红卖时,在1日前的收盘价+0.1位置书写文字,COLORFF99FF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/12F9YdMVdZwHvY6zCPUMFIg

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复