指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 买卖点 操盘控盘 庄家主力 
微信截图_20190304093250.png

微信截图_20190304093303.png

[lywrap=通达信副图指标公式][lycode=tdx,true]DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'1',0);
锁定因子:MA(LFS,1),COLORWHITE;
换手:100*VOL/CAPITAL,NODRAW,COLORLIGREEN;
主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORRED,LINETHICK2;
非主流资金:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORGREEN,LINETHICK1;
收盘价获利比例:WINNER(C)*100,LINETHICK0;
VARF:=TROUGHBARS(3,15,1)<4;
DRAWTEXT( FILTER(VARF=1,5),主流资金*0.90,'★底'),COLORYELLOW;
明天见底:FILTER(VARF=1,5) ,COLORFF00FF,LINETHICK0;
主力筹码估算:=EMA(WINNER(CLOSE)*70,3),NODRAW;
散户筹码估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;
散户套牢比率:散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
主力控盘比率:主力筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
市场总量:MA(主力筹码估算+散户筹码估算,13),COLORGREEN,LINETHICK2;
散户警戒:=EMA(散户套牢比率,89),NODRAW;
主力警戒:=EMA(主力控盘比率,89),NODRAW;
{散户坑}
STICKLINE(REF(散户套牢比率,1)>90 AND 散户套牢比率<90,30,0,1,0),COLOR0000FF;
{筹码总量}
筹码总量:IF(市场总量>REF(市场总量,1),市场总量,DRAWNULL),COLOR0066FF,LINETHICK2;
DRAWRECTREL(0,60,240,950,RGB(80,00,100));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.10,0,'■ 主力筹码估算:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.10,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.10,0,主力筹码估算),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.20,0,'■ 主力控盘比率:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.20,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.20,0,主力控盘比率),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.30,0,'■ 散户套牢比率:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.30,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.30,0,散户套牢比率),COLORRED;
DRAWTEXT_FIX(收盘价获利比例>=0,0.0,1-0.61,0,STRCAT(' ■ 收盘价获利比 : ',CON2STR(收盘价获利比例,2))),COLORLIGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.45,0,'■ 锁定因子: 锁定筹码和解锁筹码的相对速度'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.50,0,' 不直接监测锁定筹码多少,但可监测筹码。'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.55,0,'■主流资金:可监控筹码资金的背离,做决策'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.86,0,'■《股金道中》股道股灵子编辑'),COLORLIMAGENTA;
{换手}
F:=MOD(SUM(100*VOL/CAPITAL,0),100);
M:=(SUM(100*VOL/CAPITAL,0)-F)/100,LINETHICK0;
TJ:=F<REF(F,1),LINETHICK0;
FD:=REF(BARSLAST(TJ),1)+1,LINETHICK0;
DRAWTEXT(TJ,主流资金*0.96,'▲换!'),COLORYELLOW,LINETHICK3;
STICKLINE(TJ,主流资金,主流资金*0.98,0.08,0),COLOR0000FF,LINETHICK1;
HSL:100*VOL/CAPITAL,NODRAW,COLORLIGREEN;
TZHSLJL:=SUM(HSL,FD);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.68,0,'■上次到目前换手率:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.68,0,' %'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.11,0.68,0,TZHSLJL),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.75,0,'■一次换手率 天数:'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.75,0,' 天'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.11,0.75,0,FD),COLORYELLOW;
20,POINTDOT,COLORF00FF0;
50,POINTDOT,COLORGREEN;
80,POINTDOT,COLORWHITE;[/lycode][lycode=tdx2,true]填充背景
输出锁定因子:锁定因子的1日简单移动平均,画白色
输出换手:100*成交量(手)/当前流通股本(手),NODRAW,画淡绿色
输出主流资金:100*(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的3日指数移动平均, 画红色,线宽为2
输出非主流资金:100*(大盘的收盘价-34日内大盘的最低价的最低值)/(34日内大盘的最高价的最高值-34日内大盘的最低价的最低值)的3日指数移动平均,画绿色,线宽为1
输出收盘价获利比例:以收盘价计算的获利盘比例*100,线宽为0
VARF赋值:收盘价15%之字转向的前1个波谷位置<4
当满足条件VARF=1的5日过滤时,在主流资金*0.90位置书写文字,画黄色
输出明天见底:VARF=1的5日过滤 ,COLORFF00FF,线宽为0
主力筹码估算赋值:以收盘价计算的获利盘比例*70的3日指数移动平均,NODRAW
散户筹码估算赋值:(以收盘价*1.1计算的获利盘比例-以收盘价*0.9计算的获利盘比例)*80的3日指数移动平均,NODRAW
输出散户套牢比率:散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW
输出主力控盘比率:主力筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW
输出市场总量:主力筹码估算+散户筹码估算的13日简单移动平均,画绿色,线宽为2
散户警戒赋值:散户套牢比率的89日指数移动平均,NODRAW
主力警戒赋值:主力控盘比率的89日指数移动平均,NODRAW
当满足条件1日前的散户套牢比率>90AND散户套牢比率<90时,在30和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000FF
输出筹码总量:如果市场总量>1日前的市场总量,返回市场总量,否则返回无效数,COLOR0066FF,线宽为2
相对位置上画矩形
当满足条件到最后交易的周期=1时,在横轴0.01纵轴0.10位置书写文字,画黄色
当满足条件到最后交易的周期=1时,在横轴0.14纵轴0.10位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.10纵轴0.10位置书写数字,画红色
当满足条件到最后交易的周期=1时,在横轴0.01纵轴0.20位置书写文字,画黄色
当满足条件到最后交易的周期=1时,在横轴0.14纵轴0.20位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.10纵轴0.20位置书写数字,画红色
当满足条件到最后交易的周期=1时,在横轴0.01纵轴0.30位置书写文字,画黄色
当满足条件到最后交易的周期=1时,在横轴0.14纵轴0.30位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.10纵轴0.30位置书写数字,画红色
当满足条件收盘价获利比例>=0时,在横轴0.0纵轴1-0.61位置书写文字,画淡绿色
当满足条件到最后交易的周期=1时,在横轴0.00纵轴0.45位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.00纵轴0.50位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.00纵轴0.55位置书写文字,画黄色
当满足条件到最后交易的周期=1时,在横轴0.00纵轴0.86位置书写文字,画淡洋红色
F赋值:100*成交量(手)/当前流通股本(手)的历史累和关于100的模
M赋值:(100*成交量(手)/当前流通股本(手)的历史累和-F)/100,线宽为0
TJ赋值:F<1日前的F,线宽为0
FD赋值:1日前的上次TJ距今天数+1,线宽为0
当满足条件TJ时,在主流资金*0.96位置书写文字,画黄色,线宽为3
当满足条件TJ时,在主流资金和主流资金*0.98位置之间画柱状线,宽度为0.08,0不为0则画空心柱.,COLOR0000FF,线宽为1
输出换手线:100*成交量(手)/当前流通股本(手),NODRAW,画淡绿色
TZHSLJL赋值:HSL的FD日累和
当满足条件到最后交易的周期=1时,在横轴0.01纵轴0.68位置书写文字,画红色
当满足条件到最后交易的周期=1时,在横轴0.14纵轴0.68位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.11纵轴0.68位置书写数字,画黄色
当满足条件到最后交易的周期=1时,在横轴0.01纵轴0.75位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.14纵轴0.75位置书写文字,COLORFFCC99
当满足条件到最后交易的周期=1时,在横轴0.11纵轴0.75位置书写数字,画黄色
20,POINTDOT,COLORF00FF0
50,POINTDOT,画绿色
80,POINTDOT,画白色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1FsNZn8mtiZGbIZtm_BwGrA

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复