指标公式
软件: 通达信 
公式类型: 副图 选股 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
微信截图_20190228093006.png

微信截图_20190228093019.png

[lywrap=通达信副图指标公式][lycode=tdx,true]STICKLINE(C>0,90,95,10,0),COLOR408000;
STICKLINE(C>0,10,5,10,0),COLOR408000;
HDY:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWBAND(HDY,RGB(255,000,139),10,RGB(255,255,71));
STICKLINE(C>0,90,10,10,0),COLOR000000;
风险:HDY,COLORMAGENTA,LINETHICK2;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),8,0),COLORFF5D00;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),7,0),COLORFF5D10;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),6,0),COLORFF7710;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),5,0),COLORFF8810;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),4,0),COLORFF9910;
VA1:=HHV(HIGH,9)-LLV(LOW,9);
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(CLOSE+HIGH+LOW)/3;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
DRAWKLINE(EMA(B1,5),EMA(B1,5),B1+1,B1);
操作:EMA(B1,5),COLORRED;
生命:EMA(VARD,1),COLORYELLOW;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1<EMA(CLOSE,120);
STICKLINE((A3 AND A4)OR(V1 AND V2 AND V3 AND V4),B1*1.03,B1*1.120,1,0),COLORYELLOW;
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1),CIRCLEDOT ,COLORFF9900 ;
安全:=20;
转强:IF(CROSS(A5,安全),9,0),STICK,COLORLIRED,LINETHICK2;
拉升:IF(CROSS(VARC,生命) AND VARC>VARD AND VARC<55 AND C>O,9,0),STICK,COLORRED,LINETHICK2;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10,COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(5,NL),4,'★做底'),COLORRED;
VAR44:=REF(CLOSE,1);
VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;
STICKLINE(CROSS(84,VAR45),0,9,0.8,1),COLORGREEN;
DRAWTEXT(CROSS(84,VAR45),4,'空警'),COLORGREEN;[/lycode][lycode=tdx2,true]当满足条件收盘价>0时,在90和95位置之间画柱状线,宽度为10,0不为0则画空心柱.,COLOR408000
当满足条件收盘价>0时,在10和5位置之间画柱状线,宽度为10,0不为0则画空心柱.,COLOR408000
HDY赋值:100*(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的3日指数移动平均
画带状线
当满足条件收盘价>0时,在90和10位置之间画柱状线,宽度为10,0不为0则画空心柱.,COLOR000000
输出风险:HDY,画洋红色,线宽为2
RSV1赋值:(收盘价-35日内最低价的最低值)/(35日内最高价的最高值-35日内最低价的最低值)*100
K1赋值:RSV1的13日[1日权重]移动平均
D1赋值:K1的13日[1日权重]移动平均
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLORFF5D00
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLORFF5D10
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF7710
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF8810
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF9910
VA1赋值:9日内最高价的最高值-9日内最低价的最低值
VA2赋值:9日内最高价的最高值-收盘价
VA3赋值:收盘价-9日内最低价的最低值
VA4赋值:VA2/VA1*100-70
VA5赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VA6赋值:(收盘价+最高价+最低价)/3
VA7赋值:VA3/VA1*100的3日[1日权重]移动平均
VA8赋值:34日内最低价的最低值
VA9赋值:VA7的3日[1日权重]移动平均-VA4的9日[1日权重]移动平均
VARA赋值:如果VA9>100,返回VA9-100,否则返回0
VARB赋值:34日内最高价的最高值
VARC赋值:(VA6-VA8)/(VARB-VA8)*100的13日指数移动平均
VARD赋值:0.667*1日前的VARC+0.333*VARC的2日指数移动平均
VARE赋值:收盘价-1日前的收盘价和0的较大值/收盘价的8日[1日权重]移动平均/大盘的收盘价-1日前的大盘的收盘价的绝对值/大盘的收盘价的8日[1日权重]移动平均*100-25
VARF赋值:VARE的3日简单移动平均
VAR1赋值:9日内最高价的最高值-9日内最低价的最低值
VAR2赋值:9日内最高价的最高值-收盘价
VAR3赋值:收盘价-9日内最低价的最低值
VAR4赋值:((VAR2)/(VAR1))*(100)-70
VAR5赋值:((收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值))*(100)
VAR6赋值:((2)*(收盘价)+最高价+最低价)/(4)
VAR7赋值:((VAR3)/(VAR1))*(100)的3日[1日权重]移动平均
VAR8赋值:34日内最低价的最低值
VAR9赋值:VAR7的3日[1日权重]移动平均-VAR4的9日[1日权重]移动平均
VAR10赋值:如果(VAR9>100),返回VAR9-100,否则返回0
VAR11赋值:34日内最高价的最高值
B1赋值:((VAR6-VAR8)/(VAR11-VAR8))*(100)的8日指数移动平均
K线
输出操作:B1的5日指数移动平均,画红色
输出生命:VARD的1日指数移动平均,画黄色
V1赋值:收盘价的5日简单移动平均=20日内收盘价的5日简单移动平均的最高值
V2赋值:收盘价的5日简单移动平均>收盘价的10日简单移动平均
V3赋值:成交量(手)的5日简单移动平均>成交量(手)的40日简单移动平均*1.01
V4赋值:统计2日中满足收盘价的1日简单移动平均>1日前的收盘价的天数=2
VV赋值:V1 AND V2 AND V3 AND V4
A1赋值:收盘价的8日指数移动平均
A2赋值:A1的20日指数移动平均
A3赋值:A1上穿A2
A4赋值:A1<收盘价的120日指数移动平均
当满足条件(A3ANDA4)OR(V1ANDV2ANDV3ANDV4)时,在B1*1.03和B1*1.120位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
A5赋值:3*(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100的21日[1日权重]移动平均-2*(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100的20日[1日权重]移动平均的8日[1日权重]移动平均,CIRCLEDOT ,COLORFF9900
安全赋值:20
输出转强:如果A5上穿安全,返回9,否则返回0,STICK,画淡红色,线宽为2
输出拉升:如果VARC上穿生命ANDVARC>VARDANDVARC<55ANDC>开盘价,返回9,否则返回0,STICK,画红色,线宽为2
VAR18赋值:30日内最高价的最高值
VAR19赋值:30日内最低价的最低值
NL赋值:(收盘价-VAR19)/(VAR18-VAR19)*100的5日指数移动平均/8*10,画黄色,线宽为2
当满足条件5上穿NL时,在4位置书写文字,画红色
VAR44赋值:1日前的收盘价
VAR45赋值:收盘价-VAR44和0的较大值的6日[1日权重]移动平均/收盘价-VAR44的绝对值的6日[1日权重]移动平均*100
当满足条件84上穿VAR45时,在0和9位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,画绿色
当满足条件84上穿VAR45时,在4位置书写文字,画绿色[/lycode][/lywrap]
[lywrap=通达信选股公式指标][lycode=tdx,true]VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10,COLORYELLOW,LINETHICK2;
做底:CROSS(5,NL);[/lycode][lycode=tdx2,true]VAR18赋值:30日内最高价的最高值
VAR19赋值:30日内最低价的最低值
NL赋值:(收盘价-VAR19)/(VAR18-VAR19)*100的5日指数移动平均/8*10,画黄色,线宽为2
输出做底:5上穿NL[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/19AFN2ncNxU6dXmmXzQNPLQ

看了该指标的人还看了:
主力买卖指标    底部拉升指标    股海拾贝指标
敢死队操作线指标    抄底趋势线指标    短线黑马指标

使用道具 举报

回复