指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
微信截图_20190226095200.png

微信截图_20190226095223.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=LLV(LOW,5);
VAR2:=HHV(HIGH,5);
买:EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,4), COLORWHITE;
卖:EMA(0.667*REF(买,1)+0.333*买,2),COLORMAGENTA;
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,34);
VARA:=HHV(HIGH,34);
方:EMA((VAR3-VAR4)/(VARA-VAR4)*100,12),COLORRED;
向:EMA(0.667*REF(方,1)+0.333*方,2), COLORGREEN;
DRAWTEXT(CROSS(78.89, 7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1)) AND 买>35,方,'跑'),COLOR00FF00;
VAR01:=EMA(((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25)))*100,5);
VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
VAR03:=CROSS(VAR02,VAR01);
VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);
VAR05:=COUNT(VAR03,7)>0 AND VAR04;
VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
VAR08:=EMA(VAR07,10);
VAR09:=EMA(C,5);
VAR10:=LLV(LOW,33);
VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
VAR13:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR14:=SMA(VAR13,3,1);
VAR15:=SMA(VAR13,3,1);
VAR16:=3*VAR14-2*VAR15;
VAR17:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR19:=REF(CLOSE,1);
VAR20:=SMA(MAX(CLOSE-VAR19,0),6,1)/SMA(ABS(CLOSE-VAR19),6,1)*100;
VAR21:=CROSS(VAR20,11);DRAWTEXT(VAR21,5,'★'),COLORYELLOW;
VAR22:=REF(LOW,1);
VAR23:=SMA(ABS(LOW-VAR22),3,1)/SMA(MAX(LOW-VAR22,0),3,1)*100;
VAR24:=EMA(IF(CLOSE*1.3,VAR23*10,VAR23/10),3);
VAR25:=LLV(LOW,30);
VAR26:=HHV(VAR24,30);
VAR27:=IF(MA(CLOSE,58),1,0);
VAR28:=EMA(IF(LOW<=VAR25,(VAR24+VAR26*2)/2,0),3)/618*VAR27;
VAR29:=IF(VAR28>100,100,VAR28);
VAR30:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR31:=(20*VAR30+19*REF(VAR30,1)+18*REF(VAR30,2)+17*REF(VAR30,3)+16*REF(VAR30,4)+15*REF(VAR30,5)+14*REF(VAR30,6)
+13*REF(VAR30,7)+12*REF(VAR30,8)+11*REF(VAR30,9)+10*REF(VAR30,10)+9*REF(VAR30,11)+8*REF(VAR30,12)
+7*REF(VAR30,13)+6*REF(VAR30,14)+5*REF(VAR30,15)+4*REF(VAR30,16)+3*REF(VAR30,17)+2*REF(VAR30,18)+
REF(VAR30,20))/211;
VAR32:= EMA(EMA(EMA(VAR31,2),2),2);
STICKLINE(VAR05 AND COUNT(VAR05,5)=1 AND VAR16<80 ,0,20,2,0),COLORRED;
短线搞:IF(CROSS(VAR17,8) ,30,0),STICK,COLORYELLOW;
吸货:STICKLINE(VAR29>-120,0,VAR29/2,0,0),COLORAA9728;
DRAWTEXT(CROSS(VAR31, VAR32),10,'▲'),COLOR0099FF;
VARA5:=IF(( (SMA(SMA(((C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100),3,1),3,1)+100)-(SMA(((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70),9,1)+100))>60, ( (SMA(SMA(((C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100),3,1),3,1)+100)-(SMA(((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70),9,1)+100))-60,0);
波段机会:VARA5*0.1819,COLORRED;
机会大于0参与:MA(波段机会,3),COLOR196829;
平衡位:50,COLORGRAY,POINTDOT;

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
0,COLORFF00FF;
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
STICKLINE((阶段底部 < 0),0,-10,0.8,1),LINETHICK6,COLORYELLOW;
趋势线:=LLV(阶段底部,1),COLORWHITE,LINETHICK0;
STICKLINE(CROSS(阶段底部,0),0,-10,0.8,1),LINETHICK6,COLORRED;
STICKLINE((趋势线 >230 ),100,90,0.3,1),LINETHICK6,COLORGREEN;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:EMA(RSV,3);
D:MA(K,3);
STICKLINE(K>D , K,D ,2.5,0),COLORRED,LINETHICK2;
STICKLINE(D>K,K,D,2.5,0),COLORGREEN,LINETHICK2;
逃顶线:90,COLORGREEN;
中轴线: 50,COLORRED;
抄底线:10,COLORGREEN;
DRAWICON(CROSS(K,D),12,1)COLORRED;
DRAWICON(CROSS(D,K),88,2)COLORGREEN;
警戒:阶段底部 < 0,LINETHICK0,COLORYELLOW;
出击:CROSS(阶段底部,0),LINETHICK0,COLORRED;[/lycode][lycode=tdx2,true]VAR1赋值:5日内最低价的最低值
VAR2赋值:5日内最高价的最高值
输出买:(收盘价-VAR1)/(VAR2-VAR1)*100的4日指数移动平均, 画白色
输出卖:0.667*1日前的买+0.333*买的2日指数移动平均,画洋红色
VAR3赋值:(2*收盘价+最高价+最低价)/4
VAR4赋值:34日内最低价的最低值
VARA赋值:34日内最高价的最高值
输出方:(VAR3-VAR4)/(VARA-VAR4)*100的12日指数移动平均,画红色
输出向:0.667*1日前的方+0.333*方的2日指数移动平均, 画绿色
当满足条件78.89上穿7*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均-3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均的3日[1日权重]移动平均-(CLO的?日[?日权重]移动平均的?日[?日权重]移动平均的?日[?日权重]移动平均时,在E-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30,4,1),3,1),2,1))AND买>35位置书写文字,COLOR00FF00
VAR01赋值:((收盘价-25日内最低价的最低值)/(25日内最高价的最高值-25日内最低价的最低值))*100的5日指数移动平均
VAR02赋值:(25日内最高价的最高值-25日内最低价的最低值)/(收盘价-25日内最低价的最低值)的5日指数移动平均
VAR03赋值:VAR02上穿VAR01
VAR04赋值:2日前的VAR02<1日前的VAR02 AND VAR02<1日前的VAR02
VAR05赋值:统计7日中满足VAR03的天数>0 AND VAR04
VAR06赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
VAR07赋值:最低价-VAR06的绝对值的13日[1日权重]移动平均/最低价-VAR06和0的较大值的10日[1日权重]移动平均
VAR08赋值:VAR07的10日指数移动平均
VAR09赋值:收盘价的5日指数移动平均
VAR10赋值:33日内最低价的最低值
VAR11赋值:如果最低价<=VAR10,返回VAR09,否则返回0的3日指数移动平均*40
VAR12赋值:如果VAR11>100,返回VAR11*0.312,否则返回VAR11
VAR13赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR14赋值:VAR13的3日[1日权重]移动平均
VAR15赋值:VAR13的3日[1日权重]移动平均
VAR16赋值:3*VAR14-2*VAR15
VAR17赋值:4*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均-3*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均的3.2日[1日权重]移动平均
VAR19赋值:1日前的收盘价
VAR20赋值:收盘价-VAR19和0的较大值的6日[1日权重]移动平均/收盘价-VAR19的绝对值的6日[1日权重]移动平均*100
VAR21赋值:VAR20上穿11
当满足条件VAR21时,在5位置书写文字,画黄色
VAR22赋值:1日前的最低价
VAR23赋值:最低价-VAR22的绝对值的3日[1日权重]移动平均/最低价-VAR22和0的较大值的3日[1日权重]移动平均*100
VAR24赋值:如果收盘价*1.3,返回VAR23*10,否则返回VAR23/10的3日指数移动平均
VAR25赋值:30日内最低价的最低值
VAR26赋值:30日内VAR24的最高值
VAR27赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR28赋值:如果最低价<=VAR25,返回(VAR24+VAR26*2)/2,否则返回0的3日指数移动平均/618*VAR27
VAR29赋值:如果VAR28>100,返回100,否则返回VAR28
VAR30赋值:(3*收盘价+最低价+开盘价+最高价)/6
VAR31赋值:(20*VAR30+19*1日前的VAR30+18*2日前的VAR30+17*3日前的VAR30+16*4日前的VAR30+15*5日前的VAR30+14*6日前的VAR30+13*7日前的VAR30+12*8日前的VAR30+11*9日前的VAR30+10*10日前的VAR30+9*11日前的VAR30+8*12日前的VAR30+7*13日前的VAR30+6*14日前的VAR30+5*15日前的VAR30+4*16日前的VAR30+3*17日前的VAR30+2*18日前的VAR30+20日前的VAR30)/211
VAR32赋值: VAR31的2日指数移动平均的2日指数移动平均的2日指数移动平均
当满足条件VAR05ANDCOUNT(VAR05,5)=1ANDVAR16<80时,在0和20位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
输出短线搞:如果VAR17上穿8,返回30,否则返回0,STICK,画黄色
输出吸货:当满足条件VAR29>-120时,在0和VAR29/2位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORAA9728
当满足条件VAR31上穿VAR32时,在10位置书写文字,COLOR0099FF
VARA5赋值:如果((((收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100)的3日[1日权重]移动平均的3日[1日权重]移动平均+100)-(((9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)*100-70)的9日[1日权重]移动平均+100))>60,返回((((收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100)的3日[1日权重]移动平均的3日[1日权重]移动平均+100)-(((9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)*100-70)的9日[1日权重]移动平均+100))-60,否则返回0
输出波段机会:VARA5*0.1819,画红色
输出机会大于0参与:波段机会的3日简单移动平均,COLOR196829
输出平衡位:50,画深灰色,POINTDOT
LC赋值:1日前的收盘价
RSI5赋值:(((收盘价-LC)和0的较大值的5日[1日权重]移动平均 / (收盘价-LC)的绝对值的5日[1日权重]移动平均) * 100)
TR1赋值:(最高价-最低价)和(最高价-1日前的收盘价)的绝对值的较大值和(最低价-1日前的收盘价)的绝对值的较大值的10日累和
HD赋值:(最高价 - 1日前的最高价)
LD赋值:(1日前的最低价 - 最低价)
DMP赋值:如果((HD>0)AND(HD>LD)),返回HD,否则返回0的10日累和
DMM赋值:如果((LD>0)AND(LD>HD)),返回LD,否则返回0的10日累和
PDI赋值:((DMP * 100) / TR1)
MDI赋值:((DMM * 100) / TR1)
ADX赋值:(((MDI-PDI)的绝对值/(MDI+PDI))*100)的5日简单移动平均
AV赋值:(RSI5 + ADX)
DXR赋值:(((ADX + 5日前的ADX) / 2) + RSI5)
0,COLORFF00FF
WR10赋值:((100 * (10日内最高价的最高值 - 收盘价)) / (10日内最高价的最高值 - 10日内最低价的最低值))
NEWVOL赋值:(RSI5 - WR10)
阶段底部赋值:(AV + NEWVOL)
当满足条件(阶段底部<0)时,在0和-10位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,线宽为6,画黄色
趋势线赋值:1日内阶段底部的最低值,画白色,线宽为0
当满足条件阶段底部上穿0时,在0和-10位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,线宽为6,画红色
当满足条件(趋势线>230)时,在100和90位置之间画柱状线,宽度为0.3,1不为0则画空心柱.,线宽为6,画绿色
LOWV赋值:9日内最低价的最低值
HIGHV赋值:9日内最高价的最高值
RSV赋值:(收盘价-LOWV)/(HIGHV-LOWV)*100的3日指数移动平均
输出K:RSV的3日指数移动平均
输出D:K的3日简单移动平均
当满足条件K>D时,在K和D位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画红色,线宽为2
当满足条件D>K时,在K和D位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画绿色,线宽为2
输出逃顶线:90,画绿色
输出中轴线: 50,画红色
输出抄底线:10,画绿色
当满足条件K上穿D时,在12位置画1号图标画红色
当满足条件D上穿K时,在88位置画2号图标画绿色
输出警戒:阶段底部 < 0,线宽为0,画黄色
输出出击:阶段底部上穿0,线宽为0,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/19dgJbu1J6IEvhDZ7XmvbbQ

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复