指标公式
软件: 通达信 
公式类型: 主图 副图 选股 预警 
二级分类: 波段 无未来函数 短线 买卖点 起爆点 
微信截图_20190220105718.png

微信截图_20190220105740.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWGBK(O>C,RGB(48,41,124),RGB(0,0,0),0,'1',0);
A1:=EMA(CLOSE,13)-EMA(CLOSE,55);
A2:=EMA((0.618*REF(A1,1)+0.382*A1),3);
STICKLINE(A1>=A2,H,L,0,0),COLOR00FFFF;
STICKLINE(A1>=A2,O,C,-1,0),COLOR0099DD;
STICKLINE(A1>=A2,O,C,2,0),COLOR00ABEE;
STICKLINE(A1>=A2,O,C,1,0),COLOR00DDFF;
STICKLINE(A1>=A2,O,C,0.1,0),COLOR00FFFF;
STICKLINE(A1<A2,H,L,0,0),COLOR00FF00;
STICKLINE(A1<A2,O,C,-1,0),COLOR009900;
STICKLINE(A1<A2,O,C,2,0),COLOR00AB00;
STICKLINE(A1<A2,O,C,1,0),COLOR00DD00;
STICKLINE(A1<A2,O,C,0.1,0),COLOR00FF00;

P1:=EMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5);
P2:=(HHV(HIGH,55)-LLV(LOW,55))/EMA((CLOSE-LLV(LOW,55)),5);
P3:=CROSS(P2,P1);
P4:=REF(P2,2)<REF(P2,1) AND P2<REF(P2,1);
P5:=COUNT(P3,7)>0 AND P4;
P6:=3*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1)-2*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1);
P7:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
MW:= EMA(P6,5);

NU:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
NU0:=SMA(NU,3,1);
NU00:=SMA(NU0,3,1);
NU10:=3*NU0-2*NU00;
NU1:=EMA(3*NU0-2*NU00,4);
NU2:=SMA(NU1,5,1);
NW:=MA(3*SMA(P7,6,1)-2*SMA(SMA(P7,5,1),5,1),2);
HW:=CROSS(NW,0) AND MW<56;
DP:=IF(P5 AND COUNT(P5,5)=1,1,0);
TP:=(HW AND DP) OR ((CROSS(IF(P6<3 AND NU2<5 AND NW<4,1,0),0.5))AND LLV(L,34)/HHV(H,144)<0.78),NODRAW;
STICKLINE(TP,H,L,0,0),COLOR0000FF;
STICKLINE(TP,O,C,-1,0),COLOR000099;
STICKLINE(TP,O,C,2,0),COLOR0000AB;
STICKLINE(TP,O,C,1,0),COLOR0000DD;
STICKLINE(TP,O,C,0.1,0),COLOR0000FF;
DRAWTEXT(TP,C*0.96,'TURNING POINT'),COLORRED;[/lycode][lycode=tdx2,true]填充背景
A1赋值:收盘价的13日指数移动平均-收盘价的55日指数移动平均
A2赋值:(0.618*1日前的A1+0.382*A1)的3日指数移动平均
当满足条件A1>=A2时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FFFF
当满足条件A1>=A2时,在开盘价和收盘价位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLOR0099DD
当满足条件A1>=A2时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00ABEE
当满足条件A1>=A2时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00DDFF
当满足条件A1>=A2时,在开盘价和收盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00FFFF
当满足条件A1<A2时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00
当满足条件A1<A2时,在开盘价和收盘价位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLOR009900
当满足条件A1<A2时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00AB00
当满足条件A1<A2时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00DD00
当满足条件A1<A2时,在开盘价和收盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00FF00
P1赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日指数移动平均
P2赋值:(55日内最高价的最高值-55日内最低价的最低值)/(收盘价-55日内最低价的最低值)的5日指数移动平均
P3赋值:P2上穿P1
P4赋值:2日前的P2<1日前的P2 AND P2<1日前的P2
P5赋值:统计7日中满足P3的天数>0 AND P4
P6赋值:3*(收盘价-89日内最低价的最低值)/(89日内最高价的最高值-89日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-89日内最低价的最低值)/(89日内最高价的最高值-89日内最低价的最低值)*100的5日[1日权重]移动平均
P7赋值: (收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100
MW赋值: P6的5日指数移动平均
NU赋值:(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100
NU0赋值:NU的3日[1日权重]移动平均
NU00赋值:NU0的3日[1日权重]移动平均
NU10赋值:3*NU0-2*NU00
NU1赋值:3*NU0-2*NU00的4日指数移动平均
NU2赋值:NU1的5日[1日权重]移动平均
NW赋值:3*P7的6日[1日权重]移动平均-2*P7的5日[1日权重]移动平均的5日[1日权重]移动平均的2日简单移动平均
HW赋值:NW上穿0 AND MW<56
DP赋值:如果P5ANDCOUNT(P5,5)=1,返回1,否则返回0
TP赋值:(HW AND DP) OR ((如果P6<3ANDNU2<5ANDNW<4,返回1,否则返回0上穿0.5)AND 34日内最低价的最低值/144日内最高价的最高值<0.78),NODRAW
当满足条件TP时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000FF
当满足条件TP时,在开盘价和收盘价位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLOR000099
当满足条件TP时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0000AB
当满足条件TP时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000DD
当满足条件TP时,在开盘价和收盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR0000FF
当满足条件TP时,在收盘价*0.96位置书写文字,画红色[/lycode][/lywrap]

[lywrap=通达信主图选股公式指标][lycode=tdx,true]A1:=EMA(CLOSE,13)-EMA(CLOSE,55);
A2:=EMA((0.618*REF(A1,1)+0.382*A1),3);


P1:=EMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5);
P2:=(HHV(HIGH,55)-LLV(LOW,55))/EMA((CLOSE-LLV(LOW,55)),5);
P3:=CROSS(P2,P1);
P4:=REF(P2,2)<REF(P2,1) AND P2<REF(P2,1);
P5:=COUNT(P3,7)>0 AND P4;
P6:=3*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1)-2*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1);
P7:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
MW:= EMA(P6,5);

NU:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
NU0:=SMA(NU,3,1);
NU00:=SMA(NU0,3,1);
NU10:=3*NU0-2*NU00;
NU1:=EMA(3*NU0-2*NU00,4);
NU2:=SMA(NU1,5,1);
NW:=MA(3*SMA(P7,6,1)-2*SMA(SMA(P7,5,1),5,1),2);
HW:=CROSS(NW,0) AND MW<56;
DP:=IF(P5 AND COUNT(P5,5)=1,1,0);
TP:(HW AND DP) OR ((CROSS(IF(P6<3 AND NU2<5 AND NW<4,1,0),0.5))AND LLV(L,34)/HHV(H,144)<0.78);[/lycode][lycode=tdx2,true]A1赋值:收盘价的13日指数移动平均-收盘价的55日指数移动平均
A2赋值:(0.618*1日前的A1+0.382*A1)的3日指数移动平均
P1赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日指数移动平均
P2赋值:(55日内最高价的最高值-55日内最低价的最低值)/(收盘价-55日内最低价的最低值)的5日指数移动平均
P3赋值:P2上穿P1
P4赋值:2日前的P2<1日前的P2 AND P2<1日前的P2
P5赋值:统计7日中满足P3的天数>0 AND P4
P6赋值:3*(收盘价-89日内最低价的最低值)/(89日内最高价的最高值-89日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-89日内最低价的最低值)/(89日内最高价的最高值-89日内最低价的最低值)*100的5日[1日权重]移动平均
P7赋值: (收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100
MW赋值: P6的5日指数移动平均
NU赋值:(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100
NU0赋值:NU的3日[1日权重]移动平均
NU00赋值:NU0的3日[1日权重]移动平均
NU10赋值:3*NU0-2*NU00
NU1赋值:3*NU0-2*NU00的4日指数移动平均
NU2赋值:NU1的5日[1日权重]移动平均
NW赋值:3*P7的6日[1日权重]移动平均-2*P7的5日[1日权重]移动平均的5日[1日权重]移动平均的2日简单移动平均
HW赋值:NW上穿0 AND MW<56
DP赋值:如果P5ANDCOUNT(P5,5)=1,返回1,否则返回0
输出TP:(HW AND DP) OR ((如果P6<3ANDNU2<5ANDNW<4,返回1,否则返回0上穿0.5)AND 34日内最低价的最低值/144日内最高价的最高值<0.78)[/lycode][/lywrap]

[lywrap=通达信副图指标公式][lycode=tdx,true]DRAWGBK(O>C,RGB(48,41,124),RGB(0,0,0),0,'1',0);
DIFF :=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;
DEA  :=EMA(DIFF,9);
MACD :=2*(DIFF-DEA);

抄底:=ABS((CROSS("MACD.DIF","MACD.DEA")
&&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.09,COLORLIMAGENTA,LINETHICK2;

STICKLINE(抄底,0,50,4,0),COLOR770077;
STICKLINE(抄底,0,50,3,0),COLOR990099;
STICKLINE(抄底,0,50,2,0),COLORBB00BB;
STICKLINE(抄底,0,50,1,0),COLORDD00DD;
STICKLINE(抄底,0,50,0.3,0),COLORFF00FF;[/lycode][lycode=tdx2,true]填充背景
赋值:( 收盘价的12日指数移动平均 - 收盘价的26日指数移动平均)*100
赋值:DIFF的9日指数移动平均
赋值:2*(DIFF-DEA)
抄底赋值:("平滑异同平均的DIF"上穿"平滑异同平均的DEA"并且"平滑异同平均的DEA"<=-0.07)*"平滑异同平均的DIF"的绝对值*1.09,画淡洋红色,线宽为2
当满足条件抄底时,在0和50位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR770077
当满足条件抄底时,在0和50位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR990099
当满足条件抄底时,在0和50位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORBB00BB
当满足条件抄底时,在0和50位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORDD00DD
当满足条件抄底时,在0和50位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFF00FF[/lycode][/lywrap]

[lywrap=通达信选股公式指标][lycode=tdx,true]DIFF :=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;
DEA  :=EMA(DIFF,9);
MACD :=2*(DIFF-DEA);
抄底:ABS((CROSS("MACD.DIF","MACD.DEA")
&&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.09;[/lycode][lycode=tdx2,true]赋值:( 收盘价的12日指数移动平均 - 收盘价的26日指数移动平均)*100
赋值:DIFF的9日指数移动平均
赋值:2*(DIFF-DEA)
输出抄底:("平滑异同平均的DIF"上穿"平滑异同平均的DEA"并且"平滑异同平均的DEA"<=-0.07)*"平滑异同平均的DIF"的绝对值*1.09[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1XqRmwOgB0s7bm69828Hsfg

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复