指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
该指标长短结合,波段操作,波段其实很清楚,红色持有,绿色抛出,
如果红色从20起步,可一跟持有,当中可根据C1\C2红箭头及绿箭头做一起短红操作,
当红色超出80后,结合C1下穿C2的绿箭头进行抛出。

微信截图_20190219101515.png

微信截图_20190219101522.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORFF00FF;
C2:(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORFFFFFF;
DRAWICON(CROSS(C1,C2) AND C2>0,C2,1);
DRAWICON(CROSS(C2,C1) AND C2<-100,C1,2);
DRAWICON(CROSS(C1,C2) AND C2<0,C2,1);
DRAWICON(CROSS(C2,C1) AND C2>-100,C1,2);
条件:=CROSS(C1,C2) AND C1<40;
条件0:=CROSS(C2,C1) AND C1>90;
TJ1:=CROSS(C1,C2);
TJ2:=CROSS(C2,C1);
TJ3:=CROSS(C1,C2) AND REF(C1,1)<20;
TJ4:=CROSS(C2,C1) AND REF(C1,1)>80;
DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2)) OR (REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),50,'止'),COLORGREEN;
DRAWTEXT(TJ3,65,'安全'),COLORRED;

P1:=LLV(LOW,34);
P2:=HHV(HIGH,34);
P3:=EMA((C-P1)/(P2-P1)*100,8);
P4:=EMA(P3,5);
STICKLINE(P3>=P4,P3,P4,6,1),COLORRED;
STICKLINE(P3<P4,P3,P4,6,1),COLORGREEN;

VAR22:=(2*CLOSE+HIGH+LOW)/4;
VAR33:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR44:=LLV(LOW,5);
VAR55:=HHV(HIGH,4);
散户: EMA((VAR22-VAR44)/(VAR55-VAR44)*100,4)*VAR33;
庄家: EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR33;
DRAWICON(CROSS(散户,庄家) AND 散户<30,10,23);[/lycode][lycode=tdx2,true]VAR1赋值:1
VAR2赋值:((((2*收盘价)+最高价)+最低价) / 4)
VAR4赋值:5日内最低价的最低值
VAR5赋值:4日内最高价的最高值
输出C1:((((VAR2-VAR4)/(VAR5-VAR4))*100)的4日指数移动平均*VAR1),COLORFF00FF
输出C2:(((0.667*1日前的C1)+(0.333*C1))的2日指数移动平均*VAR1),COLORFFFFFF
当满足条件C1上穿C2ANDC2>0时,在C2位置画1号图标
当满足条件C2上穿C1ANDC2<-100时,在C1位置画2号图标
当满足条件C1上穿C2ANDC2<0时,在C2位置画1号图标
当满足条件C2上穿C1ANDC2>-100时,在C1位置画2号图标
条件赋值:C1上穿C2 AND C1<40
条件0赋值:C2上穿C1 AND C1>90
TJ1赋值:C1上穿C2
TJ2赋值:C2上穿C1
TJ3赋值:C1上穿C2 AND 1日前的C1<20
TJ4赋值:C2上穿C1 AND 1日前的C1>80
当满足条件(1日前的条件AND(1日前的最低价>LOWORTJ2))OR(2日前的条件AND(2日前的最低价>3日内最低价的最低值ORTJ2))OR(3日前的条件AND(3日前的最低价>4日内最低价的最低值ORTJ2))的4日过滤时,在50位置书写文字,画绿色
当满足条件TJ3时,在65位置书写文字,画红色
P1赋值:34日内最低价的最低值
P2赋值:34日内最高价的最高值
P3赋值:(收盘价-P1)/(P2-P1)*100的8日指数移动平均
P4赋值:P3的5日指数移动平均
当满足条件P3>=P4时,在P3和P4位置之间画柱状线,宽度为6,1不为0则画空心柱.,画红色
当满足条件P3<P4时,在P3和P4位置之间画柱状线,宽度为6,1不为0则画空心柱.,画绿色
VAR22赋值:(2*收盘价+最高价+最低价)/4
VAR33赋值:如果年份>=2099ANDMONTH>2,返回0,否则返回1
VAR44赋值:5日内最低价的最低值
VAR55赋值:4日内最高价的最高值
输出散户: (VAR22-VAR44)/(VAR55-VAR44)*100的4日指数移动平均*VAR33
输出庄家: 0.667*1日前的散户+0.333*散户的2日指数移动平均*VAR33
当满足条件散户上穿庄家AND散户<30时,在10位置画23号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/10AMiQuD9oeQZEWcHz1gaYQ

看了该指标的人还看了:
启爆抄底指标    趋势为王道指标    财神操盘指标
波段机会指标    提示操盘指标    只抓牛股指标

使用道具 举报

回复