指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 趋势 
微信截图_20190215113355.png

微信截图_20190215113428.png

[lywrap=通达信主图指标公式][lycode=tdx,true]个股涨跌:((C-REF(C,1))/REF(C,1))*100,NODRAW;
大盘涨跌:((INDEXC-REF(INDEXC,1))/REF(INDEXC,1))*100,NODRAW;A1:EMA((EMA(CLOSE,1)+EMA(CLOSE,3)+EMA(CLOSE,5))/3,3),COLORRED;
A2:EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA( CLOSE,7))/3,3),COLORRED;
A3:EMA((EMA(CLOSE,5)+EMA(CLOSE,7)+EMA( CLOSE,9))/3,3),COLORRED;
A4:EMA((EMA(CLOSE,7)+EMA(CLOSE,9)+EMA( CLOSE,11))/3,3),COLORRED;
A5:EMA((EMA(CLOSE,9)+EMA(CLOSE,11)+EMA( CLOSE,13))/3,3),COLORRED;
A6:EMA((EMA(CLOSE,11)+EMA(CLOSE,13)+EMA( CLOSE,15))/3,3),COLORRED;
A7:EMA((EMA(CLOSE,13)+EMA(CLOSE,15)+EMA( CLOSE,17))/3,3),COLORRED;
A8:EMA((EMA(CLOSE,15)+EMA(CLOSE,17)+EMA( CLOSE,19))/3,3),COLORRED;
A9:EMA((EMA(CLOSE,17)+EMA(CLOSE,19)+EMA( CLOSE,21))/3,3),COLORYELLOW;
A10:EMA((EMA(CLOSE,19)+EMA(CLOSE,21)+EMA( CLOSE,23))/3,3),COLORYELLOW;
A11:EMA((EMA(CLOSE,21)+EMA(CLOSE,23)+EMA( CLOSE,25))/3,3),COLORYELLOW;
A:=EMA((EMA(CLOSE,29)+EMA(CLOSE,31)+EMA(CLOSE,33))/3,3),COLORYELLOW;
B:=REF(A,1);
DRAWTEXT(A>B,(A+B)/2,'★'), COLORFF00FF;
DRAWTEXT(A<=B,(A+B)/2,'☆'), COLORGREEN;
STICKLINE(A>B,A,B,3,0),COLORFF00FF;
STICKLINE(A<=B,A,B,3,1),COLORFF0000;
A15:A-(A1-A*0.997),COLORFF1010;
A16:A-(A2-A),COLORFF2010;
A17:A-(A3-A),COLORFF3010;
A18:A-(A4-A),COLORFF4010;
A19:A-(A5-A),COLORFF5010;
A20:A-(A6-A),COLORFF6010;
A21:A-(A7-A),COLORFF7010;
A22:A-(A8-A),COLORFF8010;
A23:A-(A9-A),COLORFF9010;
A24:A-(A10-A),COLORFFC010;
A25:A-(A11-A*0.997),COLORFFE010;
STICKLINE(OPEN>=CLOSE ,O,C,3,0 ),COLORAAAAAA;
STICKLINE(OPEN>=CLOSE ,O,C,2,0 ),COLORBBBBBB;
STICKLINE(OPEN>=CLOSE ,O,C,1.4,0 ),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE ,O,C,0.5,0 ),COLORDDDDDD;
STICKLINE(CLOSE>OPEN,O,C,3,0 ),COLOR6666CC;
STICKLINE(CLOSE>OPEN,O,C,2 ,0 ),COLOR7777DD;
STICKLINE(CLOSE>OPEN,O,C,1.5 ,0 ),COLOR8888EE;
STICKLINE(CLOSE>OPEN,O,C,1 ,0 ),COLOR9999FF;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0,0 ),COLOR1199FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0,0 ),COLOR1199FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0 ,0 ),COLORCCCCCC;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0 ,0 ),COLORCCCCCC;[/lycode][lycode=tdx2,true]输出个股涨跌:((收盘价-1日前的收盘价)/1日前的收盘价)*100,NODRAW
输出大盘涨跌:((大盘的收盘价-1日前的大盘的收盘价)/1日前的大盘的收盘价)*100,NODRAW
输出A1:(收盘价的1日指数移动平均+收盘价的3日指数移动平均+收盘价的5日指数移动平均)/3的3日指数移动平均,画红色
输出A2:(收盘价的3日指数移动平均+收盘价的5日指数移动平均+收盘价的7日指数移动平均)/3的3日指数移动平均,画红色
输出A3:(收盘价的5日指数移动平均+收盘价的7日指数移动平均+收盘价的9日指数移动平均)/3的3日指数移动平均,画红色
输出A4:(收盘价的7日指数移动平均+收盘价的9日指数移动平均+收盘价的11日指数移动平均)/3的3日指数移动平均,画红色
输出A5:(收盘价的9日指数移动平均+收盘价的11日指数移动平均+收盘价的13日指数移动平均)/3的3日指数移动平均,画红色
输出A6:(收盘价的11日指数移动平均+收盘价的13日指数移动平均+收盘价的15日指数移动平均)/3的3日指数移动平均,画红色
输出A7:(收盘价的13日指数移动平均+收盘价的15日指数移动平均+收盘价的17日指数移动平均)/3的3日指数移动平均,画红色
输出A8:(收盘价的15日指数移动平均+收盘价的17日指数移动平均+收盘价的19日指数移动平均)/3的3日指数移动平均,画红色
输出A9:(收盘价的17日指数移动平均+收盘价的19日指数移动平均+收盘价的21日指数移动平均)/3的3日指数移动平均,画黄色
输出A10:(收盘价的19日指数移动平均+收盘价的21日指数移动平均+收盘价的23日指数移动平均)/3的3日指数移动平均,画黄色
输出A11:(收盘价的21日指数移动平均+收盘价的23日指数移动平均+收盘价的25日指数移动平均)/3的3日指数移动平均,画黄色
A赋值:(收盘价的29日指数移动平均+收盘价的31日指数移动平均+收盘价的33日指数移动平均)/3的3日指数移动平均,画黄色
B赋值:1日前的A
当满足条件A>B时,在(A+B)/2位置书写文字, COLORFF00FF
当满足条件A<=B时,在(A+B)/2位置书写文字, 画绿色
当满足条件A>B时,在A和B位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
当满足条件A<=B时,在A和B位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLORFF0000
输出A15:A-(A1-A*0.997),COLORFF1010
输出A16:A-(A2-A),COLORFF2010
输出A17:A-(A3-A),COLORFF3010
输出A18:A-(A4-A),COLORFF4010
输出A19:A-(A5-A),COLORFF5010
输出A20:A-(A6-A),COLORFF6010
输出A21:A-(A7-A),COLORFF7010
输出A22:A-(A8-A),COLORFF8010
输出A23:A-(A9-A),COLORFF9010
输出A24:A-(A10-A),COLORFFC010
输出A25:A-(A11-A*0.997),COLORFFE010
当满足条件开盘价>=收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORAAAAAA
当满足条件开盘价>=收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORBBBBBB
当满足条件开盘价>=收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.4,0不为0则画空心柱.,COLORCCCCCC
当满足条件开盘价>=收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORDDDDDD
当满足条件收阳线时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR6666CC
当满足条件收阳线时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR7777DD
当满足条件收阳线时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR8888EE
当满足条件收阳线时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR9999FF
当满足条件收阳线时,在开盘价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR1199FF
当满足条件收阳线时,在收盘价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR1199FF
当满足条件开盘价>=收盘价时,在收盘价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORCCCCCC
当满足条件开盘价>=收盘价时,在开盘价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORCCCCCC[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1otXPjBZpQaMtrfErTjqmvA

看了该指标的人还看了:
三间战法指标,84%的成功率    鼎牛短线出击指标    龙虎线指标
四线抓牛指标    鱼身战法指标    黑马决策辅助指标

使用道具 举报

回复