指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
微信截图_20190130103533.png

微信截图_20190130103543.png

[lywrap=通达信副图指标公式][lycode=tdx,true]陡峭度:=IF(BARSCOUNT(CLOSE) > 7,100*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=(-(100*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N)));
BB:=30*(CROSS(VAR1,-2));
MA1:=MA(V,5);
MA2:=MA(V,60);
NN:=CLOSE/REF(CLOSE,1)>=1.04;
DD:=VOL>MA1 AND VOL>MA2 AND NN;
A :=MA(CLOSE,26);
UP:=A + 2*STD(CLOSE,26);
LOWER:=A - 2*STD(CLOSE,26);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
EE:=IF(W4 AND COUNT(W4,5)=1,20,0);
XG: DD AND BB ;[/lycode][lycode=tdx2,true]陡峭度赋值:如果收盘价的有效数据周期数>7,返回100*((收盘价的7日简单移动平均)/(7日内收盘价的7日简单移动平均的最低值)-1),否则返回1
N赋值:如果(陡峭度>0.35),返回6,否则返回65
VAR1赋值:(-(100*(N日内最高价的最高值 - 收盘价))/(N日内最高价的最高值 - N日内最低价的最低值))
BB赋值:30*(VAR1上穿-2)
MA1赋值:成交量(手)的5日简单移动平均
MA2赋值:成交量(手)的60日简单移动平均
NN赋值:收盘价/1日前的收盘价>=1.04
DD赋值:成交量(手)>MA1 AND 成交量(手)>MA2 AND NN
赋值:收盘价的26日简单移动平均
UP赋值:A + 2*收盘价的26日估算标准差
LOWER赋值:A - 2*收盘价的26日估算标准差
W1赋值:收盘价=20日内收盘价的最高值
W2赋值:上次W1距今天数
W3赋值:如果W2>0,返回W2日前的收盘价,否则返回W2日前的收盘价
W4赋值:收盘价上穿1日前的W3
EE赋值:如果W4ANDCOUNT(W4,5)=1,返回20,否则返回0
输出XG: DD AND BB[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1yojihJVrIDKxTHmrmHmq0g

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复