指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 
微信截图_20190129114334.png

微信截图_20190129114348.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=(C-REF(C,1))/REF(C,1);
VAR2:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
个股:=EMA(SUM(VAR1,20),5);
大盘:=EMA(SUM(VAR2,20),5);
领涨:=(个股-大盘)>=0;
VAR3:=(C-LLV(L,125))/(HHV(H,125)-LLV(L,125))*100;
VAR4:=SMA(VAR3,72,1);
VAR5:=SMA(VAR4,34,1);
中线趋势:=3*VAR4-2*VAR5;
中线趋势升:=(中线趋势-REF(中线趋势,1))>=0;
均五升:=(MA(C,5)-REF(MA(C,5),1))>=0;
均十升:=(MA(C,10)-REF(MA(C,10),1))>=0;
STICKLINE(均五升 AND 均十升 AND 中线趋势升,0+0.5,0-0.5,6,1),COLORFFFF00,LINETHICK1;
强势:IF(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,0),COLORRED;
VAR6:=(2*C+H+L)/4;
VAR7:=LLV(L,27);
VAR8:=HHV(H,27);
操作:EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13)-50,LINETHICK1,COLORYELLOW;
趋势:EMA(0.618*REF(操作,1)+0.382*操作,3),COLORGREEN,LINETHICK1;
STICKLINE(操作>趋势 AND 操作>=REF(操作,1),操作+5,趋势-1,3.5,0),COLORRED,LINETHICK2;
STICKLINE(操作>=趋势,趋势,趋势,3.5,0),COLORYELLOW,LINETHICK2;
STICKLINE(操作<趋势,趋势+0.5,趋势-0.5,3.5,0),COLORFFFF00,LINETHICK2;
STICKLINE(强势=4,操作+6,趋势-1,4,0),COLORFF99FF;
强弱界:0,COLORWHITE;
STICKLINE(操作>=趋势 AND 均五升 AND 均十升 AND 中线趋势升,趋势-3,趋势-7,4,0),COLOR64A0E6;
运动:=IF(操作>=趋势 AND 均五升 AND 均十升 AND 中线趋势升 AND 趋势<0,1,0);
买进:IF(运动=1 AND COUNT(运动=1,5)=1,8,0),COLORGREEN,LINETHICK1;
DRAWTEXT(买进=8,操作,'买进'),COLORYELLOW;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
准备:STICKLINE(乖离<-6 AND 乖离>=-12,-6,0,6,1 ),COLOR33FFCC;
抄底一:IF(乖离<-12 AND 乖离>=-18,-12,0),
,STICK;
STICKLINE(乖离<-12 AND 乖离>=-18,-12,0,6,0) ,COLOR33CCCC;
抄底二:IF(乖离<-18,-18,0),
,STICK;
STICKLINE(乖离<-18,-18,0,6 ,0) ,COLOR3399CC;
抄底:IF(买进=8 AND COUNT(乖离<-12,10)>=1,10,0),LINETHICK0,COLORRED;
STICKLINE(抄底=10,10,0,10,1),COLORRED;
DRAWTEXT(抄底=10,10,'←抄底'),COLORYELLOW;
DRAWTEXT(CROSS(操作,趋势) AND (操作>-30),操作,'▲'),COLORRED;
DRAWTEXT(CROSS(趋势,操作) AND (操作>-20),操作,'▼' ),COLOR00FF00;[/lycode][lycode=tdx2,true]VAR1赋值:(收盘价-1日前的收盘价)/1日前的收盘价
VAR2赋值:(大盘的收盘价-1日前的大盘的收盘价)/1日前的大盘的收盘价
个股赋值:VAR1的20日累和的5日指数移动平均
大盘赋值:VAR2的20日累和的5日指数移动平均
领涨赋值:(个股-大盘)>=0
VAR3赋值:(收盘价-125日内最低价的最低值)/(125日内最高价的最高值-125日内最低价的最低值)*100
VAR4赋值:VAR3的72日[1日权重]移动平均
VAR5赋值:VAR4的34日[1日权重]移动平均
中线趋势赋值:3*VAR4-2*VAR5
中线趋势升赋值:(中线趋势-1日前的中线趋势)>=0
均五升赋值:(收盘价的5日简单移动平均-1日前的收盘价的5日简单移动平均)>=0
均十升赋值:(收盘价的10日简单移动平均-1日前的收盘价的10日简单移动平均)>=0
当满足条件均五升AND均十升AND中线趋势升时,在0+0.5和0-0.5位置之间画柱状线,宽度为6,1不为0则画空心柱.,COLORFFFF00,线宽为1
输出 强势:如果均五升AND均十升AND中线趋势升AND领涨,返回4,否则返回0,画红色
VAR6赋值:(2*收盘价+最高价+最低价)/4
VAR7赋值:27日内最低价的最低值
VAR8赋值:27日内最高价的最高值
输出 操作:(VAR6-VAR7)/(VAR8-VAR7)*100的13日指数移动平均-50,线宽为1,画黄色
输出趋势:0.618*1日前的操作+0.382*操作的3日指数移动平均,画绿色,线宽为1
当满足条件操作>趋势AND操作>=1日前的操作时,在操作+5和趋势-1位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,画红色,线宽为2
当满足条件操作>=趋势时,在趋势和趋势位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,画黄色,线宽为2
当满足条件操作<趋势时,在趋势+0.5和趋势-0.5位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLORFFFF00,线宽为2
当满足条件强势=4时,在操作+6和趋势-1位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF99FF
输出强弱界:0,画白色
当满足条件操作>=趋势AND均五升AND均十升AND中线趋势升时,在趋势-3和趋势-7位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR64A0E6
运动赋值:如果操作>=趋势AND均五升AND均十升AND中线趋势升AND趋势<0,返回1,否则返回0
输出买进:如果运动=1ANDCOUNT(运动=1,5)=1,返回8,否则返回0,画绿色,线宽为1
当满足条件买进=8时,在操作位置书写文字,画黄色
BIAS1赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
BIAS2赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100
BIAS3赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
BIAS赋值:(BIAS1+2*BIAS2+3*BIAS3)/6
乖离赋值:BIAS的3日简单移动平均
输出 准备:当满足条件乖离<-6AND乖离>=-12时,在-6和0位置之间画柱状线,宽度为6,1不为0则画空心柱.,COLOR33FFCC
输出 抄底一:如果乖离<-12AND乖离>=-18,返回-12,否则返回0,,STICK
当满足条件乖离<-12AND乖离>=-18时,在-12和0位置之间画柱状线,宽度为6,0不为0则画空心柱. ,COLOR33CCCC
输出 抄底二:如果乖离<-18,返回-18,否则返回0,,STICK
当满足条件乖离<-18时,在-18和0位置之间画柱状线,宽度为6,0不为0则画空心柱. ,COLOR3399CC
输出 抄底:如果买进=8ANDCOUNT(乖离<-12,10)>=1,返回10,否则返回0,线宽为0,画红色
当满足条件抄底=10时,在10和0位置之间画柱状线,宽度为10,1不为0则画空心柱.,画红色
当满足条件抄底=10时,在10位置书写文字,画黄色
当满足条件操作上穿趋势AND(操作>-30)时,在操作位置书写文字,画红色
当满足条件趋势上穿操作AND(操作>-20)时,在操作位置书写文字,COLOR00FF00[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1YDtBylhYV_u2pr40p22djQ

看了该指标的人还看了:
三间战法指标,84%的成功率    鼎牛短线出击指标    龙虎线指标
四线抓牛指标    鱼身战法指标    黑马决策辅助指标

使用道具 举报

回复