指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
微信截图_20190128105406.png

微信截图_20190128105418.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
波: VAR3;
段: VAR4;
VAR5:=CROSS(VAR3,VAR4) AND VAR3<20;
DRAWTEXT(FILTER(VAR5,10)=1,40,'逢低吸纳'),COLORYELLOW;
STICKLINE(FILTER(VAR5,10)=1,0,30,10,0),COLORRED;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(FILTER(VAR9,5)=1,80,100,10,0),COLORGREEN;
DRAWTEXT(FILTER(VAR9,5)=1,70,'减仓'),COLOR00FF00;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
STICKLINE(VAR8,85,100,10,0),COLOR0099FF;
100,COLORBBBBBB,LINETHICK3;
0,LINETHICK3;
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
风险:80,COLORFF00FF;
小心:87.5,COLOR00FF00;
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股神:DD,COLOR0000FF,LINETHICK2;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
目标出现B:IF(CROSS(股海,90) AND (股神<40),70,0),COLORFFFF00;
DRAWTEXT(CROSS(股海,90) AND (股神<40),75,'目标B出现'),COLORFFFF00;
跟踪:10,COLOR0000FF;
目标出现A:IF((COUNT((股神>REF(股神,1)),1)=1) AND (REF(股神,1)<REF(REF(股神,1),1)) AND (股神<跟踪),50,0),COLORF00FF0;
DRAWTEXT((COUNT((股神>REF(股神,1)),1)=1) AND (REF(股神,1)<REF(REF(股神,1),1)) AND (股神<跟踪),60,'目标A出现'),COLORF00FF0;[/lycode][lycode=tdx2,true]VAR1赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)*100
VAR2赋值:VAR1的3日[1日权重]移动平均
VAR3赋值:VAR2的3日[1日权重]移动平均
VAR4赋值:VAR3的3日[1日权重]移动平均
输出波: VAR3
输出段: VAR4
VAR5赋值:VAR3上穿VAR4 AND VAR3<20
当满足条件VAR5的10日过滤=1时,在40位置书写文字,画黄色
当满足条件VAR5的10日过滤=1时,在0和30位置之间画柱状线,宽度为10,0不为0则画空心柱.,画红色
VAR9赋值:VAR4上穿VAR3 AND VAR3>80
当满足条件VAR9的5日过滤=1时,在80和100位置之间画柱状线,宽度为10,0不为0则画空心柱.,画绿色
当满足条件VAR9的5日过滤=1时,在70位置书写文字,COLOR00FF00
VAR8赋值:VAR2上穿VAR3 AND VAR3>80 AND VAR3>VAR4
当满足条件VAR8时,在85和100位置之间画柱状线,宽度为10,0不为0则画空心柱.,COLOR0099FF
100,COLORBBBBBB,线宽为3
0,线宽为3
AA赋值:36日内最低价的最低值
BB赋值:30日内最高价的最高值
输出风险:80,COLORFF00FF
输出小心:87.5,COLOR00FF00
DD赋值:(((收盘价-AA)/(BB-AA))*(4)的4日指数移动平均)*(25)
输出股神:DD,COLOR0000FF,线宽为2
股海赋值:(((DD-21日内DD的最低值)/(21日内DD的最高值-21日内DD的最低值))*(4))*(25)
输出目标出现B:如果股海上穿90AND(股神<40),返回70,否则返回0,COLORFFFF00
当满足条件股海上穿90AND(股神<40)时,在75位置书写文字,COLORFFFF00
输出跟踪:10,COLOR0000FF
输出目标出现A:如果(统计1日中满足(股神>1日前的股神)的天数=1)AND(1日前的股神<1日前的1日前的股神)AND(股神<跟踪),返回50,否则返回0,COLORF00FF0
当满足条件(统计1日中满足(股神>1日前的股神)的天数=1)AND(1日前的股神<1日前的1日前的股神)AND(股神<跟踪)时,在60位置书写文字,COLORF00FF0[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1sEfQ7HZ4xxKI2zv1XuUm5A

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复