指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
微信截图_20190108104151.png

微信截图_20190108104202.png

[lywrap=通达信副图指标公式][lycode=tdx,true]REFLINE: -15, {0}, {20}, {40}, {60};
VAR1:=MA(WINNER(CLOSE),9)*100;
买!: CROSS(VAR1,2)*30,COLOR0000FF ,LINETHICK3 ;
VAR2:=(1-EMA((HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15)),15))*100;
VAR3:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,9,1);
VAR6:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
VAR7:=REF(VAR6,1)>13 AND REF(VAR6,1)/VAR6>1.23 AND CLOSE/REF(CLOSE,1)>1.03;
春笋: IF(VAR7 AND REF(CLOSE,1)<=COST(5),20,0),LINESTICK ,COLOR00FF00,LINETHICK2;
VAR8:=MA(CLOSE,27);
VAR9:=(CLOSE-VAR8)/VAR8*100;
VARA:=MA(VAR9,2);
VARB:=BARSLAST(CROSS(-10,VARA)=1);
VARC:=BARSLAST(CROSS(VARA,10)=1);
VARD:=VARA<-10 AND VARB>3;
VARE:=VARA>10 AND VARC>3;
黄金坑: IF(VARD,VARA,0),LINESTICK ,LINETHICK2, COLORYELLOW;
财神到: IF(VARE,VARA,0),LINESTICK , COLORGREEN;
贪嘴乐: IF(VARA>REF(VARA,1) AND VARD AND VARA<-15,30,0),LINETHICK2,LINESTICK,COLORFFA2AF;
DRAWICON(贪嘴乐>0,40,1);
VARF:=REF(LOW,1)*0.9;
VAR10:=LOW*0.9;
VAR11:=(VAR10*VOL+VARF*(CAPITAL-VOL))/CAPITAL;
VAR12:=EMA(VAR11,30);
VAR13:=CLOSE-REF(CLOSE,1);
VAR14:=MAX(VAR13,0);
VAR15:=ABS(VAR13);
VAR16:=SMA(VAR14,7,1)/SMA(VAR15,7,1)*100;
VAR17:=SMA(VAR14,13,1)/SMA(VAR15,13,1)*100;
VAR18:=BARSCOUNT(CLOSE);
VAR19:=SMA(MAX(VAR13,0),6,1)/SMA(ABS(VAR13),6,1)*100;
VAR1A:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1C:=SMA((SMA(VAR1B,4,1)-50)*2,3,1);
VAR1D:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1E:=SMA(VAR1D,4,1);
VAR1F:=SMA(VAR1E,3,1);
VAR20:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR21:=VAR19<=25 AND VAR1A<-95 AND VAR20>20 AND VAR1C<-30 AND VAR1F<30 AND VAR12-CLOSE>=-0.25 AND VAR16<22 AND VAR17<28 AND VAR18>50;
血战超跌: STICKLINE(VAR21,0,60,5,0);[/lycode][lycode=tdx2,true]输出REFLINE: -15, , , ,
VAR1赋值:以收盘价计算的获利盘比例的9日简单移动平均*100
输出买!: VAR1上穿2*30,COLOR0000FF ,线宽为3
VAR2赋值:(1-(15日内最高价的最高值-收盘价)/(15日内最高价的最高值-15日内最低价的最低值)的15日指数移动平均)*100
VAR3赋值:(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100
VAR4赋值:VAR3的9日[1日权重]移动平均
VAR5赋值:VAR4的9日[1日权重]移动平均
VAR6赋值:(收盘价-收盘价的13日[1日权重]移动平均)/收盘价的13日[1日权重]移动平均*(-100)
VAR7赋值:1日前的VAR6>13 AND 1日前的VAR6/VAR6>1.23 AND 收盘价/1日前的收盘价>1.03
输出春笋: 如果VAR7ANDREF(收盘价,1)<=获利盘为5%的成本分布,返回20,否则返回0,LINESTICK ,COLOR00FF00,线宽为2
VAR8赋值:收盘价的27日简单移动平均
VAR9赋值:(收盘价-VAR8)/VAR8*100
VARA赋值:VAR9的2日简单移动平均
VARB赋值:上次-10上穿VARA=1距今天数
VARC赋值:上次VARA上穿10=1距今天数
VARD赋值:VARA<-10 AND VARB>3
VARE赋值:VARA>10 AND VARC>3
输出黄金坑: 如果VARD,返回VARA,否则返回0,LINESTICK ,线宽为2, 画黄色
输出财神到: 如果VARE,返回VARA,否则返回0,LINESTICK , 画绿色
输出贪嘴乐: 如果VARA>1日前的VARAANDVARDANDVARA<-15,返回30,否则返回0,线宽为2,LINESTICK,COLORFFA2AF
当满足条件贪嘴乐>0时,在40位置画1号图标
VARF赋值:1日前的最低价*0.9
VAR10赋值:最低价*0.9
VAR11赋值:(VAR10*成交量(手)+VARF*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR12赋值:VAR11的30日指数移动平均
VAR13赋值:收盘价-1日前的收盘价
VAR14赋值:VAR13和0的较大值
VAR15赋值:VAR13的绝对值
VAR16赋值:VAR14的7日[1日权重]移动平均/VAR15的7日[1日权重]移动平均*100
VAR17赋值:VAR14的13日[1日权重]移动平均/VAR15的13日[1日权重]移动平均*100
VAR18赋值:收盘价的有效数据周期数
VAR19赋值:VAR13和0的较大值的6日[1日权重]移动平均/VAR13的绝对值的6日[1日权重]移动平均*100
VAR1A赋值:(-200)*(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)+100
VAR1B赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
VAR1C赋值:(VAR1B的4日[1日权重]移动平均-50)*2的3日[1日权重]移动平均
VAR1D赋值:(大盘的收盘价-14日内大盘的最低价的最低值)/(14日内大盘的最高价的最高值-14日内大盘的最低价的最低值)*100
VAR1E赋值:VAR1D的4日[1日权重]移动平均
VAR1F赋值:VAR1E的3日[1日权重]移动平均
VAR20赋值:(30日内最高价的最高值-收盘价)/收盘价*100
VAR21赋值:VAR19<=25 AND VAR1A<-95 AND VAR20>20 AND VAR1C<-30 AND VAR1F<30 AND VAR12-收盘价>=-0.25 AND VAR16<22 AND VAR17<28 AND VAR18>50
输出血战超跌: 当满足条件VAR21时,在0和60位置之间画柱状线,宽度为5,0不为0则画空心柱.[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1mpimdBBdd5Z7O3v4DBWBJg

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复