指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 操盘控盘 
微信截图_20181212110434.png

微信截图_20181212110444.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N:=2;
M:=3;
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,2,0),COLOR00FF00;
{顶部:(ZZLKP>75),COLORFFFFFF;}
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,2,0),COLORRED;
实心红柱:(ZZLJJ>REF(ZZLJJ,1))>0,COLORRED;
散筹因子:INTPART(ZSHTL),COLORCYAN,LINETHICK1;
主筹因子:INTPART(ZZLKP),COLORWHITE,LINETHICK1;
0,DOTLINE,COLORGRAY;
20,DOTLINE,COLORGRAY;
50,DOTLINE,COLORGRAY;
100,DOTLINE,COLORGRAY;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV4:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
短期B:=SMA(RSV1,3,1);
短期A:=SMA(短期B,3,1);
K4:=SMA(RSV4,8,1);
中期波段:SMA(K4,3,1),LINETHICK0,COLORWHITE;
VV1:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
VV2:=SMA(VV1,3,1);
VV3:=3*VV1-2*VV2;
趋势:=EMA(VV3,3);
VV4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
准备资金:IF(趋势<13,1,0),LINETHICK0,COLORCYAN;
开始建仓:IF(趋势<13 AND VV4>13,1,0),LINETHICK0,COLORYELLOW;
VA1:=(CLOSE*2+HIGH+LOW)/4*10;
VA2:=EMA(VA1,13);
VA3:=EMA(VA1,34);
VA4:=VA2-VA3;
VA5:=EMA(VA4,5);
VA6:=2*(VA4-VA5)*5.5;
主力进场:IF(VA6>=0 AND 趋势<13,1,0),LINETHICK0,COLORFF00FF;
转折:=IF(REF(中期波段,1)<REF(中期波段,2) AND 中期波段>REF(中期波段,1),1,0);
先机共振抄底:IF(开始建仓=1 AND 主力进场=1 AND 中期波段>REF(中期波段,1),1,0),COLORRED,LINETHICK0;
短线波段:IF((转折=1 AND 短期B>=短期A) OR (REF(短期B,1)<REF(短期A,1) AND 短期B>=短期A AND 中期波段>REF(中期波段,1)),1,0),LINETHICK0,COLOR0080EF;
STICKLINE(短期B>=短期A,短期A,REF(短期A,1),3,0),COLOR0080EF;
STICKLINE(短期B<短期A,短期A,REF(短期A,1),3,0),COLORFF6600;
DRAWICON(先机共振抄底=1,REF(短期A,1),1);
DRAWICON(短线波段=1 AND 先机共振抄底=0,REF(短期A,1),7);
SMA(K4,3,1),COLORGREEN,LINETHICK3; IF(中期波段>REF(中期波段,1),中期波段,DRAWNULL),LINETHICK3,COLORRED;
STICKLINE(准备资金=1,3,-2,5,0),COLORCYAN;
STICKLINE(开始建仓=1,10,-2,5,0),COLORYELLOW;
STICKLINE(主力进场=1 AND 开始建仓=1,6,-2,5,0),COLORFF00FF;[/lycode][lycode=tdx2,true]N赋值:2
M赋值:3
ZLCM赋值:以收盘价计算的获利盘比例*70的3日指数移动平均
SHCM赋值:(以收盘价*1.1计算的获利盘比例-以收盘价*0.9计算的获利盘比例)*80的3日指数移动平均
ZSHTL赋值:SHCM/(ZLCM+SHCM)*100
ZZLKP赋值:ZLCM/(ZLCM+SHCM)*100
ZCMZL赋值:ZLCM+SHCM的13日简单移动平均
ZZNTS赋值:上次ZSHTL<90ANDREF(ZSHTL,1)>90距今天数
ZSHJJ赋值:ZSHTL的89日指数移动平均
ZZLJJ赋值:ZZLKP的89日指数移动平均
ZJLRQD赋值:ZZLKP-ZZLJJ的整数部分
SH8赋值:ZSHTL的8日指数移动平均
DKB赋值:如果ZZLKP-1日前的ZZLKP>ZSHTL-1日前的ZSHTL,返回1,否则返回0
当满足条件ZSHJJ>1日前的ZSHJJ时,在ZSHTL和ZSHJJ位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00FF00
当满足条件ZZLJJ>1日前的ZZLJJ时,在ZZLKP和ZZLJJ位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
输出实心红柱:(ZZLJJ>1日前的ZZLJJ)>0,画红色
输出散筹因子:ZSHTL的整数部分,画青色,线宽为1
输出主筹因子:ZZLKP的整数部分,画白色,线宽为1
0,DOTLINE,画深灰色
20,DOTLINE,画深灰色
50,DOTLINE,画深灰色
100,DOTLINE,画深灰色
RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
RSV4赋值:(收盘价-89日内最低价的最低值)/(89日内最高价的最高值-89日内最低价的最低值)*100
短期B赋值:RSV1的3日[1日权重]移动平均
短期A赋值:短期B的3日[1日权重]移动平均
K4赋值:RSV4的8日[1日权重]移动平均
输出中期波段:K4的3日[1日权重]移动平均,线宽为0,画白色
VV1赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均
VV2赋值:VV1的3日[1日权重]移动平均
VV3赋值:3*VV1-2*VV2
趋势赋值:VV3的3日指数移动平均
VV4赋值:(趋势-1日前的趋势)/1日前的趋势*100
输出准备资金:如果趋势<13,返回1,否则返回0,线宽为0,画青色
输出开始建仓:如果趋势<13ANDVV4>13,返回1,否则返回0,线宽为0,画黄色
VA1赋值:(收盘价*2+最高价+最低价)/4*10
VA2赋值:VA1的13日指数移动平均
VA3赋值:VA1的34日指数移动平均
VA4赋值:VA2-VA3
VA5赋值:VA4的5日指数移动平均
VA6赋值:2*(VA4-VA5)*5.5
输出主力进场:如果VA6>=0AND趋势<13,返回1,否则返回0,线宽为0,COLORFF00FF
转折赋值:如果1日前的中期波段<2日前的中期波段AND中期波段>1日前的中期波段,返回1,否则返回0
输出先机共振抄底:如果开始建仓=1AND主力进场=1AND中期波段>1日前的中期波段,返回1,否则返回0,画红色,线宽为0
输出短线波段:如果(转折=1AND短期B>=短期A)OR(1日前的短期B<1日前的短期AAND短期B>=短期AAND中期波段>1日前的中期波段),返回1,否则返回0,线宽为0,COLOR0080EF
当满足条件短期B>=短期A时,在短期A和1日前的短期A位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0080EF
当满足条件短期B<短期A时,在短期A和1日前的短期A位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF6600
当满足条件先机共振抄底=1时,在1日前的短期A位置画1号图标
当满足条件短线波段=1AND先机共振抄底=0时,在1日前的短期A位置画7号图标
K4的3日[1日权重]移动平均,画绿色,线宽为3
如果中期波段>1日前的中期波段,返回中期波段,否则返回无效数,线宽为3,画红色
当满足条件准备资金=1时,在3和-2位置之间画柱状线,宽度为5,0不为0则画空心柱.,画青色
当满足条件开始建仓=1时,在10和-2位置之间画柱状线,宽度为5,0不为0则画空心柱.,画黄色
当满足条件主力进场=1AND开始建仓=1时,在6和-2位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF00FF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1PuWQ6_OLsMyml2AksVg2jA

看了该指标的人还看了:
短线王+短线无敌+底部吸筹    高抛低吸指标    决策指标
低进高出指标    沙里淘金指标    趋势买卖指标

使用道具 举报

回复