指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
微信截图_20181212110216.png

微信截图_20181212110241.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N1:=5;N2:=10;
LC:=REF(CLOSE,1);
A0:=(2*C+H+L)/4;
均线:=MA(A0,3)>REF(MA(A0,3),1);
安全线:2,COLORRED,POINTDOT,LINETHICK4;
A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
K:MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3),LINETHICK1,COLORF00FF0;
D:MA(K,3),COLORFF0000,LINETHICK1;
J:3*K-2*D,LINETHICK1,COLORF00FF0;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
底线:0,COLORFF00FF;
顶线:10,COLORFF0000;
STICKLINE(UP,0,0.2,3,0),COLOR0000FF;
STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;
STICKLINE(BT,0,3,2,0),COLOR000088;
STICKLINE(BT,0,3,1,0),COLOR0000CC;
STICKLINE(BT,0,3,0.22,0),COLOR0000FF;
DRAWTEXT(BT,3,'短牛'),COLOR0000FF;
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
STICKLINE(TJ1,0,2,3,0),COLOR880088;
STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;
STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;
DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ2,0,1,5,0),COLOR008888;
STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;
STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;
DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;
ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
STICKLINE(ST,10,9,5,0),COLOR008800;
STICKLINE(ST,10,9,2,0),COLOR00AA00;
STICKLINE(ST,10,9,1,0),COLOR00CC00;
STICKLINE(ST,10,9,0.2,0),COLOR00FF00;
DRAWTEXT(ST,9,'卖'),COLOR00FF00;
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:EMA(DIFF,9),COLORFFFF00;
A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);
DRAWTEXT(底背离,-0.6,'底背离'),COLORWHITE;
A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A22+1)<CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶背离,11,'顶背离'),COLORWHITE;[/lycode][lycode=tdx2,true]N1赋值:5
N2赋值:10
LC赋值:1日前的收盘价
A0赋值:(2*收盘价+最高价+最低价)/4
均线赋值:A0的3日简单移动平均>1日前的A0的3日简单移动平均
输出安全线:2,画红色,POINTDOT,线宽为4
A1赋值:(收盘价-7日内最低价的最低值)/(7日内最高价的最高值-7日内最低价的最低值)*10
输出K:3*A1的6日[1日权重]移动平均-2*A1的5日[1日权重]移动平均的5日[1日权重]移动平均的3日简单移动平均,线宽为1,COLORF00FF0
输出D:K的3日简单移动平均,COLORFF0000,线宽为1
输出J:3*K-2*D,线宽为1,COLORF00FF0
画带状线
VAR1赋值:收盘价-1日前的收盘价
VAR2赋值:100*VAR1的6日指数移动平均的6日指数移动平均/VAR1的绝对值的6日指数移动平均的6日指数移动平均
MA5赋值:收盘价的5日指数移动平均
MA13赋值:收盘价的13日指数移动平均
UP赋值:当满足条件最低价=上次MA13上穿MA5距今天数+1日内最低价的最低值时,在上次MA13上穿MA5距今天数+1日内最低价的最低值位置画直线起点,当满足条件最高价=上次MA5上穿MA13距今天数+1日内最高价的最高值时,在上次MA5上穿MA13距今天数+1日内最高价的最高值位置画直线终点,0表示是否延长.,COLOR0000FF
DOWN赋值:当满足条件最高价=上次MA5上穿MA13距今天数+1日内最高价的最高值时,在上次MA5上穿MA13距今天数+1日内最高价的最高值位置画直线起点,当满足条件最低价=上次MA13上穿MA5距今天数+1日内最低价的最低值时,在上次MA13上穿MA5距今天数+1日内最低价的最低值位置画直线终点,0表示是否延长.,COLOR00FF00
BT赋值:(2日内VAR2的最低值=7日内VAR2的最低值 AND 统计2日中满足VAR2<0的天数 AND VAR2上穿VAR2的2日简单移动平均) ANDREF(DOWN,1)<2日前的DOWN AND UP>1日前的DOWN
输出底线:0,COLORFF00FF
输出顶线:10,COLORFF0000
当满足条件UP时,在0和0.2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
当满足条件DOWN时,在0和0.2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
当满足条件BT时,在0和3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000088
当满足条件BT时,在0和3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000CC
当满足条件BT时,在0和3位置之间画柱状线,宽度为0.22,0不为0则画空心柱.,COLOR0000FF
当满足条件BT时,在3位置书写文字,COLOR0000FF
TJ1赋值:1日前的DOWN<2日前的DOWN AND UP>1日前的DOWN AND 收盘价<21日内最高价的最高值*0.82
当满足条件TJ1时,在0和2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR880088
当满足条件TJ1时,在0和2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAA00AA
当满足条件TJ1时,在0和2位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,COLORCC00CC
当满足条件TJ1时,在0和2位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLORFF00FF
当满足条件TJ1时,在2位置书写文字,COLORFF00FF
HR赋值:55日内最高价的最高值
HRY赋值:55日内最低价的最低值
HRY11赋值:HR*HRY
HRY33赋值:HRY11的开方
TJ2赋值:1日前的DOWN<2日前的DOWN AND UP>1日前的DOWN AND 收盘价<HRY33
当满足条件TJ2时,在0和1位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR008888
当满足条件TJ2时,在0和1位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00AAAA
当满足条件TJ2时,在0和1位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00CCCC
当满足条件TJ2时,在0和1位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR00FFFF
当满足条件TJ2时,在1位置书写文字,COLOR00FFFF
ST赋值:1日前的UP>2日前的UP AND DOWN<1日前的UP
当满足条件ST时,在10和9位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR008800
当满足条件ST时,在10和9位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00AA00
当满足条件ST时,在10和9位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00CC00
当满足条件ST时,在10和9位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR00FF00
当满足条件ST时,在9位置书写文字,COLOR00FF00
输出DIFF:不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均
输出DEA:DIFF的9日指数移动平均,COLORFFFF00
A11赋值:上次1日前的DIFF上穿DEA距今天数
底背离赋值:A11+1日前的收盘价>收盘价 AND DIFF>A11+1日前的DIFF AND DIFF上穿DEA
当满足条件底背离时,在-0.6位置书写文字,画白色
A22赋值:上次1日前的DEA上穿DIFF距今天数
顶背离赋值:A22+1日前的收盘价<收盘价 AND A22+1日前的DIFF>DIFF AND DEA上穿DIFF
当满足条件顶背离时,在11位置书写文字,画白色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1gQYGv1d-n1un-_pnqe7PnA

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复