指标公式
软件: 通达信 
公式类型: 副图 
二级分类: RSI指标 波段 短线 买卖点 操盘控盘 
微信截图_20181212110020.png

微信截图_20181212110033.png

[lywrap=通达信副图指标公式][lycode=tdx,true]LC := REF(CLOSE,1);
快速:SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100,COLORFFFFFF;
RSI2:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
慢速:RSI3,COLOR00FF00,LINETHICK1;
IF(快速>=慢速,慢速,DRAWNULL), COLORFF00FF,LINETHICK2;

DRAWLINE(慢速>=HHV(慢速,21),慢速,慢速<=LLV(慢速,21),慢速,1),COLORCYAN;

RSIX:SMA(快速,3,1),COLORRED;
RSIY:=SMA(RSI2,3,1);
启动1:=CROSS(快速,25) AND RSIX<=50 AND COUNT(REF(RSIX,1)<REF(RSIX,2),3)>=2 AND RSIX>REF(RSIX,1);
启动2:=CROSS(快速,REF(RSIY,1)) AND RSIX<=58 AND COUNT(REF(RSIX,1)<REF(RSIX,2),3)>=2 AND RSIX>REF(RSIX,1);

抄底:IF(启动1 OR 启动2,20,0),COLORRED;
STICKLINE(启动1,0,35,2,1),COLORYELLOW;
STICKLINE(启动2,0,25,3,1),COLORMAGENTA;

加仓:=RSIX>45 AND 启动2 AND 快速/REF(快速,1)>1.25;
DRAWTEXT(加仓,30,'△加'),COLORMAGENTA;

减仓0:=COUNT( REF(RSIX,1)>REF(RSIX,2),4 )>=3 AND RSIX<REF(RSIX,1) AND 快速/REF(快速,1)<0.8;
减仓1:=COUNT( CROSS(RSIX,快速),8)=3 AND RSIX<75 AND RSIX>50;
减仓:=FILTER(减仓0,2) OR  FILTER(减仓1,4);
DRAWTEXT(减仓,70,'减'),COLORGREEN;

结束1:=CROSS(RSIX,快速) AND RSIX>72;
结束2:=CROSS(80,RSIX);
结束_ALL:=(结束1 AND NOT(结束2) ) OR 结束2;
DRAWICON(结束_ALL,85,4);

A2:=BARSLAST(REF(CROSS(快速,78),1));
B2:= A2<=10 AND REF(C,A2+1)<C AND REF(快速,A2+1)>快速 AND CROSS(快速,78);
顶背离:=FILTER(B2>0,5);
DRAWTEXT(顶背离,90,'顶背离'),COLORBLUE;
DRAWTEXT(减仓0 AND 顶背离 ,90,'清'),COLORGREEN;

{//以下设置W底}
A3:=BARSLAST(REF(CROSS(快速,25),1));
B3:=REF(C,A3+1)>C AND REF(快速,A3+1)<快速 AND CROSS(快速,25);
W底背离:=FILTER(B3>0,5) AND 抄底=20;
W底1:=COUNT( CROSS(快速,25),15)>=2 AND 抄底=20;
W底2:=A3>=2 AND A3<10 AND CROSS(快速,RSIX) AND RSIX<50 AND RSIX>=25;
W底:=( FILTER(W底1,2) OR FILTER(W底2,2) )AND NOT (W底背离);
DRAWTEXT(W底背离,30,'W底背离'),COLORRED;
DRAWTEXT(W底,40,'●W底'),COLORYELLOW;

高:80,POINTDOT,COLORFFBB00 ;
中轴:50,POINTDOT,COLORFFBB00 ;
底:25,POINTDOT,COLORWHITE;[/lycode][lycode=tdx2,true]赋值: 1日前的收盘价
输出快速:收盘价-LC和0的较大值的5日[1日权重]移动平均/收盘价-LC的绝对值的5日[1日权重]移动平均*100,COLORFFFFFF
RSI2赋值:收盘价-LC和0的较大值的10日[1日权重]移动平均/收盘价-LC的绝对值的10日[1日权重]移动平均*100
RSI3赋值:收盘价-LC和0的较大值的20日[1日权重]移动平均/收盘价-LC的绝对值的20日[1日权重]移动平均*100
输出慢速:RSI3,COLOR00FF00,线宽为1
如果快速>=慢速,返回慢速,否则返回无效数, COLORFF00FF,线宽为2
当满足条件慢速>=21日内慢速的最高值时,在慢速位置画直线起点,当满足条件慢速<=21日内慢速的最低值时,在慢速位置画直线终点,1表示是否延长.,画青色
输出RSIX:快速的3日[1日权重]移动平均,画红色
RSIY赋值:RSI2的3日[1日权重]移动平均
启动1赋值:快速上穿25 AND RSIX<=50 AND 统计3日中满足1日前的RSIX<2日前的RSIX的天数>=2 AND RSIX>1日前的RSIX
启动2赋值:快速上穿1日前的RSIY AND RSIX<=58 AND 统计3日中满足1日前的RSIX<2日前的RSIX的天数>=2 AND RSIX>1日前的RSIX
输出抄底:如果启动1OR启动2,返回20,否则返回0,画红色
当满足条件启动1时,在0和35位置之间画柱状线,宽度为2,1不为0则画空心柱.,画黄色
当满足条件启动2时,在0和25位置之间画柱状线,宽度为3,1不为0则画空心柱.,画洋红色
加仓赋值:RSIX>45 AND 启动2 AND 快速/1日前的快速>1.25
当满足条件加仓时,在30位置书写文字,画洋红色
减仓0赋值:统计4日中满足1日前的RSIX>2日前的RSIX的天数>=3 AND RSIX<1日前的RSIX AND 快速/1日前的快速<0.8
减仓1赋值:统计8日中满足RSIX上穿快速的天数=3 AND RSIX<75 AND RSIX>50
减仓赋值:减仓0的2日过滤 OR  减仓1的4日过滤
当满足条件减仓时,在70位置书写文字,画绿色
结束1赋值:RSIX上穿快速 AND RSIX>72
结束2赋值:80上穿RSIX
结束_ALL赋值:(结束1 AND 取反 ) OR 结束2
当满足条件结束_ALL时,在85位置画4号图标
A2赋值:上次1日前的快速上穿78距今天数
B2赋值: A2<=10 AND A2+1日前的收盘价<收盘价 AND A2+1日前的快速>快速 AND 快速上穿78
顶背离赋值:B2>0的5日过滤
当满足条件顶背离时,在90位置书写文字,画蓝色
当满足条件减仓0AND顶背离时,在90位置书写文字,画绿色
A3赋值:上次1日前的快速上穿25距今天数
B3赋值:A3+1日前的收盘价>收盘价 AND A3+1日前的快速<快速 AND 快速上穿25
W底背离赋值:B3>0的5日过滤 AND 抄底=20
W底1赋值:统计15日中满足快速上穿25的天数>=2 AND 抄底=20
W底2赋值:A3>=2 AND A3<10 AND 快速上穿RSIX AND RSIX<50 AND RSIX>=25
W底赋值:( W底1的2日过滤 OR W底2的2日过滤 )AND 取反
当满足条件W底背离时,在30位置书写文字,画红色
当满足条件W底时,在40位置书写文字,画黄色
输出高:80,POINTDOT,COLORFFBB00
输出中轴:50,POINTDOT,COLORFFBB00
输出底:25,POINTDOT,画白色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1nNxJvCKG4xan9Ekuooynyg

看了该指标的人还看了:
三间战法指标,84%的成功率    鼎牛短线出击指标    龙虎线指标
四线抓牛指标    鱼身战法指标    黑马决策辅助指标

使用道具 举报

回复