指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 资金流向 无未来函数 操盘控盘 量能 
微信截图_20181212105824.png

微信截图_20181212105836.png

[lywrap=通达信副图指标公式][lycode=tdx,true]AMV:=SMA(VOL,10,1);
【最高】:=AMV*HIGH/10,LINETHICK0;
【最低】:=AMV*LOW/10,LINETHICK0;
【收盘】:=AMV*CLOSE/10,LINETHICK0;
【开盘】:=REF(【收盘】,1),LINETHICK0;
STICKLINE(【收盘】>【开盘】,【最高】,【最低】,0,0),COLOR0000FF;
STICKLINE(【收盘】>【开盘】,【收盘】,【开盘】,3,0),COLOR0000FF;
STICKLINE(【收盘】<【开盘】,【收盘】,【开盘】,3,0),COLOR00FF00;
STICKLINE(【收盘】<【开盘】,【最高】,【最低】,0,0),COLOR00FF00;
DRAWKLINE(【最高】,【开盘】,【最低】,【收盘】);{画K线}

MID:=(3*【收盘】+【最低】+【开盘】+【最高】)/6;
多空:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,LINETHICK1,COLORWHITE;
多空10MA:EMA(多空,10),COLORYELLOW,LINETHICK1;

{黄金分割}
高:=REF(HHV(【最高】,300),3);
低:=REF(LLV(【最低】,300),3);
【80.9%】:高-(高-低)*0.191,DOTLINE,COLORMAGENTA;
【61.8%】:高-(高-低)*0.382,DOTLINE,COLORGREEN;
【中50%】:=高-(高-低)*0.5,COLORBROWN;
【38.2%】:高-(高-低)*0.618,DOTLINE,COLORLIBLUE;
【19.8%】:高-(高-低)*0.809,DOTLINE,COLORBLUE;
顶点:=REFDATE(高,DATE),COLORWHITE,DOTLINE;
低点:=REFDATE(低,DATE),COLORWHITE,DOTLINE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,【19.8%】,'19.8%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,【38.2%】,'38.2%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,【中50%】,'中50%'),COLORRED;
DRAWTEXT(ISLASTBAR,【61.8%】,'61.8%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,【80.9%】,'80.9%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;
DRAWTEXT_FIX(C>0,0.85,0,0,'黄金分割需300根K线');[/lycode][lycode=tdx2,true]AMV赋值:成交量(手)的10日[1日权重]移动平均
【最高】赋值:AMV*最高价/10,线宽为0
【最低】赋值:AMV*最低价/10,线宽为0
【收盘】赋值:AMV*收盘价/10,线宽为0
【开盘】赋值:1日前的【收盘】,线宽为0
当满足条件【收盘】>【开盘】时,在【最高】和【最低】位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000FF
当满足条件【收盘】>【开盘】时,在【收盘】和【开盘】位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
当满足条件【收盘】<【开盘】时,在【收盘】和【开盘】位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
当满足条件【收盘】<【开盘】时,在【最高】和【最低】位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00
K线
MID赋值:(3*【收盘】+【最低】+【开盘】+【最高】)/6
输出多空:(20*MID+19*1日前的MID+18*2日前的MID+17*3日前的MID+16*4日前的MID+15*5日前的MID+14*6日前的MID+13*7日前的MID+12*8日前的MID+11*9日前的MID+10*10日前的MID+9*11日前的MID+8*12日前的MID+7*13日前的MID+6*14日前的MID+5*15日前的MID+4*16日前的MID+3*17日前的MID+2*18日前的MID+20日前的MID)/210,线宽为1,画白色
输出多空10MA:多空的10日指数移动平均,画黄色,线宽为1
高赋值:3日前的300日内【最高】的最高值
低赋值:3日前的300日内【最低】的最低值
输出【80.9%】:高-(高-低)*0.191,DOTLINE,画洋红色
输出【61.8%】:高-(高-低)*0.382,DOTLINE,画绿色
【中50%】赋值:高-(高-低)*0.5,画棕色
输出【38.2%】:高-(高-低)*0.618,DOTLINE,画淡蓝色
输出【19.8%】:高-(高-低)*0.809,DOTLINE,画蓝色
顶点赋值:日期日高,画白色,DOTLINE
低点赋值:日期日低,画白色,DOTLINE
当满足条件是否最后一个周期时,在顶点位置书写文字,画白色
当满足条件是否最后一个周期时,在【19.8%】位置书写文字,画黄色
当满足条件是否最后一个周期时,在【38.2%】位置书写文字,画洋红色
当满足条件是否最后一个周期时,在【中50%】位置书写文字,画红色
当满足条件是否最后一个周期时,在【61.8%】位置书写文字,画洋红色
当满足条件是否最后一个周期时,在【80.9%】位置书写文字,画黄色
当满足条件是否最后一个周期时,在低点位置书写文字,画白色
当满足条件收盘价>0时,在横轴0.85纵轴0位置书写文字[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1VjMBOkIochPgcIqa2YeTOg

看了该指标的人还看了:
做足波段指标    极品波段底指标    长短结合指标
抄底王指标    MK月金叉共振指标    600万指标 每一波赚钱

使用道具 举报

回复