指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
使用方法:
1、做短线:当出现笑脸时择机买入或趋势线上穿主力线时买入,出现哭脸时卖出或趋势线向下拐头时卖出。
2、做中线:当出现笑脸时择机买入或者趋势线上穿主力线时买入,只要是趋势线和主力线上涨的趋势不变,放心的一路持有,当趋势线和主力线都拐头向下时卖出。
3、结合其他指标使用效果更佳。

微信截图_20181212105603.png

微信截图_20181212105619.png

[lywrap=通达信副图指标公式][lycode=tdx,true]M:=60;{参数:M 1  100  60,  N 1  100  30}
N:=30;
散户线:100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)) COLOR00FF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
主力线:EMA(J,6),COLORYELLOW,LINETHICK2;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
吸筹:STICKLINE(VAR9>-120,0,VAR9,2,5),COLORMAGENTA;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
趋势线:CEILING(SMA(AA5,13,8)),COLORRED,LINETHICK4;
AA6:=SMA(AA3,21,8);
买观注: STICKLINE(趋势线-AA6<-65,0,7,15,1);
DRAWICON(FILTER(J>REF(J,1)AND 趋势线>=REF(趋势线,1)AND 趋势线<25 ,5),趋势线,5);
卖观注: STICKLINE(趋势线-AA6>85,98,90,15,1),COLORFFFF00;
DRAWICON(FILTER(J<=REF(趋势线,1)AND J>85 ,5),J,4);[/lycode][lycode=tdx2,true]M赋值:60
N赋值:30
输出散户线:100*(M日内最高价的最高值-收盘价)/(M日内最高价的最高值-M日内最低价的最低值) COLOR00FF00,线宽为2
RSV赋值:(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
K赋值:RSV的5日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
输出主力线:J的6日指数移动平均,画黄色,线宽为2
VAR2赋值:1日前的最低价
VAR3赋值:最低价-VAR2的绝对值的3日[1日权重]移动平均/最低价-VAR2和0的较大值的3日[1日权重]移动平均*100
VAR4赋值:如果收盘价*1.3,返回VAR3*10,否则返回VAR3/10的3日指数移动平均
VAR5赋值:30日内最低价的最低值
VAR6赋值:30日内VAR4的最高值
VAR7赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7
VAR9赋值:如果VAR8>100,返回100,否则返回VAR8
输出吸筹:当满足条件VAR9>-120时,在0和VAR9位置之间画柱状线,宽度为2,5不为0则画空心柱.,画洋红色
AA3赋值:(21日内最高价的最高值-收盘价)/(21日内最高价的最高值-21日内最低价的最低值)*100-10
AA4赋值:(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100
AA5赋值:AA4的13日[8日权重]移动平均
输出趋势线:AA5的13日[8日权重]移动平均的向上舍入,画红色,线宽为4
AA6赋值:AA3的21日[8日权重]移动平均
输出买观注: 当满足条件趋势线-AA6<-65时,在0和7位置之间画柱状线,宽度为15,1不为0则画空心柱.
当满足条件J>1日前的JAND趋势线>=1日前的趋势线AND趋势线<25的5日过滤时,在趋势线位置画5号图标
输出卖观注: 当满足条件趋势线-AA6>85时,在98和90位置之间画柱状线,宽度为15,1不为0则画空心柱.,COLORFFFF00
当满足条件J<=1日前的趋势线ANDJ>85的5日过滤时,在J位置画4号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1S2w-ewzh2NyJHJ4K5a-Uhw

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复