指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 无未来函数 趋势 操盘控盘 
微信截图_20181212105005.png

微信截图_20181212105021.png

[lywrap=通达信副图指标公式][lycode=tdx,true]SH:=12;LO:=24;MI:=9;

FIRST:=IF(PERIOD=3,1/6,1/4);
DIF0:=EMA(CLOSE,SH*FIRST)-EMA(CLOSE,LO*FIRST);
DEA0:=EMA(DIF0,MI*FIRST);
MACD0:=(DIF0-DEA0)*2;

DIF1:=EMA(CLOSE,SH)-EMA(CLOSE,LO);
DEA1:=EMA(DIF1,MI);
MACD1:=(DIF1-DEA1)*2;
STRONGER:=MACD1>0 AND MACD1-REF(MACD1,1)>REF((MACD1-REF(MACD1,1)),1);
WEAKER:=MACD1<=0 AND ABS(MACD1)-REF(ABS(MACD1),1)<REF((ABS(MACD1)-REF(ABS(MACD1),1)),1);

MID:=IF(PERIOD=1,3,4);
DIF2:=EMA(CLOSE,SH*MID)-EMA(CLOSE,LO*MID);
DEA2:=EMA(DIF2,MI*MID);
MACD2:=(DIF2-DEA2)*2;

LONG:=IF(PERIOD=6,24,IF(PERIOD=5,20,IF(PERIOD=4 OR PERIOD=3 OR PERIOD=2,16,IF(PERIOD=1,12,DRAWNULL))));
DIF3:=EMA(CLOSE,SH*LONG)-EMA(CLOSE,LO*LONG);
DEA3:=EMA(DIF3,MI*LONG);
MACD3:=(DIF3-DEA3)*2;

UP1:=REF(HHV(DEA1,MI*LONG),1);
DN1:=REF(LLV(DEA1,MI*LONG),1);
ZZ1:=(UP1+DN1)/2;
DRAWBAND(UP1,RGB(80,80,80),ZZ1,0);
DRAWBAND(ZZ1,RGB(45,45,45),DN1,0);
UP0:=REF(HHV(DEA0,IF(PERIOD=3,MI*MID/3*2,MI*MID)),1);
DN0:=REF(LLV(DEA0,IF(PERIOD=3,MI*MID/3*2,MI*MID)),1);
ZZ0:=(UP0+DN0)/2;
DRAWBAND(UP0,RGB(30,30,30),ZZ0,0);
DRAWBAND(ZZ0,RGB(15,15,15),DN0,0);
STICKLINE(1,0,0,0.5,0),COLORF580F5;
STICKLINE(UP0>=UP1,UP1,UP1,1,0),COLOR808080;
STICKLINE(DN0<=DN1,DN1,DN1,1,0),COLOR808080;
STICKLINE(UP0>=UP1,UP0,UP0,1,0),COLORAAAAAA;
STICKLINE(DN0<=DN1,DN0,DN0,1,0),COLORAAAAAA;

DRAWBAND(DEA0,RGB(100,100,100),DEA0,0);

STICKLINE(MACD1>0,DIF1,DEA1,3,1),COLORF580F5;
STICKLINE(MACD1<0,DIF1,DEA1,3,1),COLORCCDD33;
STICKLINE(MACD1>0 AND MACD1>REF(MACD1,1),DIF1,DEA1,1,0),COLORF580F5;
STICKLINE(MACD1<=0 AND MACD1<=REF(MACD1,1),DIF1,DEA1,1,0),COLORCCDD33;
STICKLINE(DIF1>0 AND MACD1>0 AND MACD1>REF(MACD1,1),DIF1,DEA1,1,0),COLORMAGENTA;
STICKLINE(DIF1<=0 AND MACD1<=0 AND MACD1<=REF(MACD1,1),DIF1,DEA1,1,0),COLORBLUE;
DRAWTEXT(REF(MACD1,1)>0 AND MACD1>REF(MACD1,1) AND STRONGER,DEA1,'^^'),COLORRED;
DRAWTEXT(REF(MACD1,1)<=0 AND MACD1<=REF(MACD1,1) AND WEAKER,DIF1,'^^'),COLORGREEN;

STICKLINE(DIF2>DEA2,DIF2,DEA2,2.5,-1),COLORRED;
STICKLINE(DIF2<=DEA2,DIF2,DEA2,2.5,-1),COLORGREEN;
STICKLINE(DIF2-DEA2>REF(DIF2-DEA2,1) AND DIF2>DEA2,DIF2,DEA2,2.5,1),COLORRED;
STICKLINE(DIF2-DEA2<=REF(DIF2-DEA2,1) AND DIF2<=DEA2,DIF2,DEA2,2.5,1),COLORGREEN;
STICKLINE(MACD1>0 AND MACD1>REF(MACD1,1) AND MACD2>0 AND MACD2>=REF(MACD2,1),DIF2,DEA2,0.5,1),COLORRED;
STICKLINE(MACD1<=0 AND MACD1<=REF(MACD1,1) AND MACD2<=0 AND MACD2<=REF(MACD2,1),DIF2,DEA2,0.5,1),COLORGREEN;

STICKLINE(DIF3>DEA3,DIF3,DEA3,1.5,-1),COLORRED;
STICKLINE(DIF3<=DEA3,DIF3,DEA3,1.5,-1),COLORGREEN;
STICKLINE(DIF3-DEA3>REF(DIF3-DEA3,1) AND DIF3>DEA3,DIF3,DEA3,1.5,0),COLORRED;
STICKLINE(DIF3-DEA3<=REF(DIF3-DEA3,1) AND DIF3<=DEA3,DIF3,DEA3,1.5,0),COLORGREEN;

DRAWTEXT(ISLASTBAR AND PERIOD=2,(DIF1+DEA1)/2,'←15M'),COLORWHITE;
DRAWTEXT(ISLASTBAR AND PERIOD=2,(DIF2+DEA2)/2,'←60M'),COLORYELLOW;
DRAWTEXT(ISLASTBAR AND PERIOD=2,(DIF3+DEA3)/2,'←DAY'),COLORMAGENTA;

DRAWTEXT(ISLASTBAR AND PERIOD=3,DEA0,'←5M'),COLORWHITE;
DRAWTEXT(ISLASTBAR AND PERIOD=3,(DIF1+DEA1)/2,'←30M'),COLORWHITE;
DRAWTEXT(ISLASTBAR AND PERIOD=3,(DIF2+DEA2)/2,'←2HOUR'),COLORYELLOW;
DRAWTEXT(ISLASTBAR AND PERIOD=3,(DIF3+DEA3)/2,'←2DAY'),COLORMAGENTA;

DRAWTEXT(ISLASTBAR AND PERIOD=4,DEA0,'←15M'),COLORRED;
DRAWTEXT(ISLASTBAR AND PERIOD=4,(DIF1+DEA1)/2,'←60M'),COLORWHITE;
DRAWTEXT(ISLASTBAR AND PERIOD=4,(DIF2+DEA2)/2,'←DAY'),COLORYELLOW;
DRAWTEXT(ISLASTBAR AND PERIOD=4,(DIF3+DEA3)/2,'←WEEK'),COLORMAGENTA;

DRAWTEXT(ISLASTBAR AND PERIOD=5,DEA0,'←60M'),COLORRED;
DRAWTEXT(ISLASTBAR AND PERIOD=5,(DIF1+DEA1)/2,'←DAY'),COLORWHITE;
DRAWTEXT(ISLASTBAR AND PERIOD=5,(DIF2+DEA2)/2,'←WEEK'),COLORYELLOW;
DRAWTEXT(ISLASTBAR AND PERIOD=5,(DIF3+DEA3)/2,'←MONTH'),COLORMAGENTA;

DRAWTEXT(ISLASTBAR AND PERIOD=6,DEA0,'←DAY'),COLORRED;
DRAWTEXT(ISLASTBAR AND PERIOD=6,(DIF1+DEA1)/2,'←WEEK'),COLORWHITE;
DRAWTEXT(ISLASTBAR AND PERIOD=6,(DIF2+DEA2)/2,'←MONTH'),COLORYELLOW;
DRAWTEXT(ISLASTBAR AND PERIOD=6,(DIF3+DEA3)/2,'←HALF_YEAR'),COLORMAGENTA;[/lycode][lycode=tdx2,true]SH赋值:12
LO赋值:24
MI赋值:9
FIRST赋值:如果周期类型=3,返回1/6,否则返回1/4
DIF0赋值:收盘价的SH*FIRST日指数移动平均-收盘价的LO*FIRST日指数移动平均
DEA0赋值:DIF0的MI*FIRST日指数移动平均
MACD0赋值:(DIF0-DEA0)*2
DIF1赋值:收盘价的SH日指数移动平均-收盘价的LO日指数移动平均
DEA1赋值:DIF1的MI日指数移动平均
MACD1赋值:(DIF1-DEA1)*2
STRONGER赋值:MACD1>0 AND MACD1-1日前的MACD1>1日前的(MACD1-1日前的MACD1)
WEAKER赋值:MACD1<=0 AND MACD1的绝对值-1日前的MACD1的绝对值<1日前的(MACD1的绝对值-1日前的MACD1的绝对值)
MID赋值:如果周期类型=1,返回3,否则返回4
DIF2赋值:收盘价的SH*MID日指数移动平均-收盘价的LO*MID日指数移动平均
DEA2赋值:DIF2的MI*MID日指数移动平均
MACD2赋值:(DIF2-DEA2)*2
LONG赋值:如果周期类型=6,返回24,否则返回如果周期类型=5,返回20,否则返回如果周期类型=4ORPERIOD=3ORPERIOD=2,返回16,否则返回如果周期类型=1,返回12,否则返回无效数
DIF3赋值:收盘价的SH*LONG日指数移动平均-收盘价的LO*LONG日指数移动平均
DEA3赋值:DIF3的MI*LONG日指数移动平均
MACD3赋值:(DIF3-DEA3)*2
UP1赋值:1日前的MI*LONG日内DEA1的最高值
DN1赋值:1日前的MI*LONG日内DEA1的最低值
ZZ1赋值:(UP1+DN1)/2
画带状线
画带状线
UP0赋值:1日前的如果周期类型=3,返回MI*MID/3*2,否则返回MI*MID日内DEA0的最高值
DN0赋值:1日前的如果周期类型=3,返回MI*MID/3*2,否则返回MI*MID日内DEA0的最低值
ZZ0赋值:(UP0+DN0)/2
画带状线
画带状线
当满足条件1时,在0和0位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORF580F5
当满足条件UP0>=UP1时,在UP1和UP1位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR808080
当满足条件DN0<=DN1时,在DN1和DN1位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR808080
当满足条件UP0>=UP1时,在UP0和UP0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORAAAAAA
当满足条件DN0<=DN1时,在DN0和DN0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORAAAAAA
画带状线
当满足条件MACD1>0时,在DIF1和DEA1位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLORF580F5
当满足条件MACD1<0时,在DIF1和DEA1位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLORCCDD33
当满足条件MACD1>0ANDMACD1>1日前的MACD1时,在DIF1和DEA1位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORF580F5
当满足条件MACD1<=0ANDMACD1<=1日前的MACD1时,在DIF1和DEA1位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCCDD33
当满足条件DIF1>0ANDMACD1>0ANDMACD1>1日前的MACD1时,在DIF1和DEA1位置之间画柱状线,宽度为1,0不为0则画空心柱.,画洋红色
当满足条件DIF1<=0ANDMACD1<=0ANDMACD1<=1日前的MACD1时,在DIF1和DEA1位置之间画柱状线,宽度为1,0不为0则画空心柱.,画蓝色
当满足条件1日前的MACD1>0ANDMACD1>1日前的MACD1ANDSTRONGER时,在DEA1位置书写文字,画红色
当满足条件1日前的MACD1<=0ANDMACD1<=1日前的MACD1ANDWEAKER时,在DIF1位置书写文字,画绿色
当满足条件DIF2>DEA2时,在DIF2和DEA2位置之间画柱状线,宽度为2.5,-1不为0则画空心柱.,画红色
当满足条件DIF2<=DEA2时,在DIF2和DEA2位置之间画柱状线,宽度为2.5,-1不为0则画空心柱.,画绿色
当满足条件DIF2-DEA2>1日前的DIF2-DEA2ANDDIF2>DEA2时,在DIF2和DEA2位置之间画柱状线,宽度为2.5,1不为0则画空心柱.,画红色
当满足条件DIF2-DEA2<=1日前的DIF2-DEA2ANDDIF2<=DEA2时,在DIF2和DEA2位置之间画柱状线,宽度为2.5,1不为0则画空心柱.,画绿色
当满足条件MACD1>0ANDMACD1>1日前的MACD1ANDMACD2>0ANDMACD2>=1日前的MACD2时,在DIF2和DEA2位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,画红色
当满足条件MACD1<=0ANDMACD1<=1日前的MACD1ANDMACD2<=0ANDMACD2<=1日前的MACD2时,在DIF2和DEA2位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,画绿色
当满足条件DIF3>DEA3时,在DIF3和DEA3位置之间画柱状线,宽度为1.5,-1不为0则画空心柱.,画红色
当满足条件DIF3<=DEA3时,在DIF3和DEA3位置之间画柱状线,宽度为1.5,-1不为0则画空心柱.,画绿色
当满足条件DIF3-DEA3>1日前的DIF3-DEA3ANDDIF3>DEA3时,在DIF3和DEA3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画红色
当满足条件DIF3-DEA3<=1日前的DIF3-DEA3ANDDIF3<=DEA3时,在DIF3和DEA3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画绿色
当满足条件ISLASTBARANDPERIOD=2时,在(DIF1+DEA1)/2位置书写文字,画白色
当满足条件ISLASTBARANDPERIOD=2时,在(DIF2+DEA2)/2位置书写文字,画黄色
当满足条件ISLASTBARANDPERIOD=2时,在(DIF3+DEA3)/2位置书写文字,画洋红色
当满足条件ISLASTBARANDPERIOD=3时,在DEA0位置书写文字,画白色
当满足条件ISLASTBARANDPERIOD=3时,在(DIF1+DEA1)/2位置书写文字,画白色
当满足条件ISLASTBARANDPERIOD=3时,在(DIF2+DEA2)/2位置书写文字,画黄色
当满足条件ISLASTBARANDPERIOD=3时,在(DIF3+DEA3)/2位置书写文字,画洋红色
当满足条件ISLASTBARANDPERIOD=4时,在DEA0位置书写文字,画红色
当满足条件ISLASTBARANDPERIOD=4时,在(DIF1+DEA1)/2位置书写文字,画白色
当满足条件ISLASTBARANDPERIOD=4时,在(DIF2+DEA2)/2位置书写文字,画黄色
当满足条件ISLASTBARANDPERIOD=4时,在(DIF3+DEA3)/2位置书写文字,画洋红色
当满足条件ISLASTBARANDPERIOD=5时,在DEA0位置书写文字,画红色
当满足条件ISLASTBARANDPERIOD=5时,在(DIF1+DEA1)/2位置书写文字,画白色
当满足条件ISLASTBARANDPERIOD=5时,在(DIF2+DEA2)/2位置书写文字,画黄色
当满足条件ISLASTBARANDPERIOD=5时,在(DIF3+DEA3)/2位置书写文字,画洋红色
当满足条件ISLASTBARANDPERIOD=6时,在DEA0位置书写文字,画红色
当满足条件ISLASTBARANDPERIOD=6时,在(DIF1+DEA1)/2位置书写文字,画白色
当满足条件ISLASTBARANDPERIOD=6时,在(DIF2+DEA2)/2位置书写文字,画黄色
当满足条件ISLASTBARANDPERIOD=6时,在(DIF3+DEA3)/2位置书写文字,画洋红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1hb88EWvHFXI3bo9SbzwesQ

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复