指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 筹码 操盘控盘 
微信截图_20181212104752.png

微信截图_20181212104811.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(H,O,L,C);

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWBMP(BU,L*0.99,'BUY1');
DRAWBMP(SEL,H*1.05,'SELL1');
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORLIRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,1),COLORLIRED;
MA5:MA(CLOSE,5),COLORFFFFFF;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA30:MA(CLOSE,30),COLORGREEN;
JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价:=SMA(JC,5,1),COLORCYAN;
价:=IF(C>=参考价,参考价,参考价*0.98 ), CIRCLEDOT,COLOR0000FF;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORCYAN;
STICKLINE(买线<卖线,CLOSE,OPEN,3,1),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=98,LOW*0.88,'☆ 暗 条 越 长 压 力 越 大, 暗 条 越 短 做 多 越 好 ☆'),COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
T6:=IF(FINDSTR(EXTERNSTR(0,1),','),STRCAT('千股千评:',EXTERNSTR(0,1)),'');
DRAWTEXT_FIX(1,0.00,0.17,0,T6),COLOR00FFFF;[/lycode][lycode=tdx2,true]DA1赋值:如果130>总的周期数,返回总的周期数,否则返回130
DA赋值:如果到最后交易的周期>DA1,返回0,否则返回DA1
HI赋值:日期日DA日内最高价的最高值
LO赋值:日期日DA日内最低价的最低值
C1赋值:如果到最后交易的周期<=DA,返回收盘价,否则返回无效数
GZ赋值:HI/LO的自然对数/10的指数
LH1赋值:如果C1>=(HI/GZ),返回成交量(手),否则返回0的DA日累和
LH2赋值:如果C1>=(HI/GZ的2乘幂)ANDC1<(HI/GZ),返回成交量(手),否则返回0的DA日累和
LH3赋值:如果C1>=(HI/GZ的3乘幂)ANDC1<(HI/GZ的2乘幂),返回成交量(手),否则返回0的DA日累和
LH4赋值:如果C1>=(HI/GZ的4乘幂)ANDC1<(HI/GZ的3乘幂),返回成交量(手),否则返回0的DA日累和
LH5赋值:如果C1>=(HI/GZ的5乘幂)ANDC1<(HI/GZ的4乘幂),返回成交量(手),否则返回0的DA日累和
LH6赋值:如果C1>=(HI/GZ的6乘幂)ANDC1<(HI/GZ的5乘幂),返回成交量(手),否则返回0的DA日累和
LH7赋值:如果C1>=(HI/GZ的7乘幂)ANDC1<(HI/GZ的6乘幂),返回成交量(手),否则返回0的DA日累和
LH8赋值:如果C1>=(HI/GZ的8乘幂)ANDC1<(HI/GZ的7乘幂),返回成交量(手),否则返回0的DA日累和
LH9赋值:如果C1>=(LO*GZ)ANDC1<LO*GZ的2乘幂,返回成交量(手),否则返回0的DA日累和
LH10赋值:如果C1>=LOANDC1<LO*GZ,返回成交量(手),否则返回0的DA日累和
L1赋值:日期日DA日内LH1的最高值,线宽为0
L2赋值:日期日DA日内LH2的最高值,线宽为0
L3赋值:日期日DA日内LH3的最高值,线宽为0
L4赋值:日期日DA日内LH4的最高值
L5赋值:日期日DA日内LH5的最高值
L6赋值:日期日DA日内LH6的最高值
L7赋值:日期日DA日内LH7的最高值
L8赋值:日期日DA日内LH8的最高值
L9赋值:日期日DA日内LH9的最高值
L10赋值:日期日DA日内LH10的最高值
SS赋值:(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10)
当满足条件DA*L1/SS的向上舍入*3>=到最后交易的周期时,在HI*99/100和HI/GZ位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L2/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的1乘幂*99/100和HI/GZ的2乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L3/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的2乘幂*99/100和HI/GZ的3乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L4/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的3乘幂*99/100和HI/GZ的4乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L5/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的4乘幂*99/100和HI/GZ的5乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L6/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的5乘幂*99/100和HI/GZ的6乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L7/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的6乘幂*99/100和HI/GZ的7乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L8/SS的向上舍入*3>=到最后交易的周期时,在LO*GZ的2乘幂和LO*GZ的3乘幂*99/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L9/SS的向上舍入*3>=到最后交易的周期时,在LO*GZ的1乘幂和LO*GZ的2乘幂*99/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L10/SS的向上舍入*3>=到最后交易的周期时,在LO和LO*GZ的1乘幂*99/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
K线
买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
BU赋值:买线上穿卖线
SEL赋值:卖线上穿买线
画图片
画图片
当满足条件买线>=卖线时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画淡红色
当满足条件买线>=卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画淡红色
输出MA5:收盘价的5日简单移动平均,COLORFFFFFF
输出MA10:收盘价的10日简单移动平均,画黄色
输出MA20:收盘价的20日简单移动平均,画洋红色
输出MA30:收盘价的30日简单移动平均,画绿色
JC赋值:(3日前的收盘价+5日前的收盘价+7日前的收盘价+8日前的收盘价+13日前的收盘价+21日前的收盘价)/6
参考价赋值:JC的5日[1日权重]移动平均,画青色
价赋值:如果收盘价>=参考价,返回参考价,否则返回参考价*0.98, CIRCLEDOT,COLOR0000FF
当满足条件买线<卖线时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画青色
当满足条件买线<卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画青色
当满足条件到最后交易的周期=98时,在最低价*0.88位置书写文字,画黄色
当满足条件1时,在横轴0.00纵轴0位置书写文字COLOR00FFFF
当满足条件1时,在横轴0.07纵轴0位置书写文字COLOR00FFFF
当满足条件1时,在横轴0.14纵轴0位置书写文字COLOR00FFFF
当满足条件1时,在横轴0.21纵轴0位置书写文字COLOR00FFFF
T6赋值:如果字符串查找,返回字符串相加,否则返回''
当满足条件1时,在横轴0.00纵轴0.17位置书写文字,COLOR00FFFF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1F1HZtpPYXy4PglIt_Q_WCw

看了该指标的人还看了:
做足波段指标    极品波段底指标    长短结合指标
抄底王指标    MK月金叉共振指标    600万指标 每一波赚钱

使用道具 举报

回复