指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
微信截图_20181211104653.png

微信截图_20181211104724.png

[lywrap=通达信主图指标公式][lycode=tdx,true]B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
止损下限:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK4;
SNAKEA:HHV(MA(B2,1),13),COLORYELLOW;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;
STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA,SMA2,0,0),COLORBLUE;
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;
A13:=EMA(CLOSE,55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,3);
A16:=EMA(A15,3);
A17:=(HIGH + LOW) / 5;
A18:=(MA(A17,4)) - (MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0,A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,1);
A24:=REF(A20,1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);
A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);
A30:=A28 AND ((COUNT(A28,A21)) = 1);
A31:=A29 AND ((COUNT(A29,A22)) = 1);
A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));
DRAWTEXT(A32,SMA2*0.99,'BBBB'),COLORYELLOW;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
BBC:=FORCAST(BBA,3);
L55188CYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
STICKLINE(L55188CYC>0,C,O,2,0),COLOR10ABFF;
DRAWTEXT(L55188CYC>0,LOW*0.99,'☆'),COLORDD00DD;[/lycode][lycode=tdx2,true]B1赋值:收盘价的1日简单移动平均
B2赋值:B1的2日[1日权重]移动平均的2日[1日权重]移动平均的2日[1日权重]移动平均
SMA2赋值:B2的3日简单移动平均
输出止损下限:如果3日内B2的8日简单移动平均的最低值<B2,返回3日内B2的8日简单移动平均的最低值,否则返回B2
如果B2>SMA2,返回B2,否则返回无效数,画红色,线宽为4
如果B2<SMA2,返回B2,否则返回无效数,画绿色,线宽为4
输出SNAKEA:13日内B2的1日简单移动平均的最高值,画黄色
VAR1A赋值:(2*收盘价+最高价+最低价)/4
VAR2A赋值:VAR1A的7日简单移动平均
VAR3A赋值:VAR2A-VAR1A的7/2日简单移动平均<0
VAR4A赋值:VAR2A-VAR1A的7/2日简单移动平均>0
VAR5A赋值:上次VAR3A距今天数
VAR6A赋值:0-上次VAR4A距今天数
VAR7A赋值:如果VAR3A<=0,返回VAR5A,否则返回VAR6A
当满足条件SNAKEA>B2ANDB2>SMA2时,在SNAKEA和B2位置之间画柱状线,宽度为0,0不为0则画空心柱.,画蓝色
当满足条件SNAKEA>SMA2ANDB2<SMA2时,在SNAKEA和SMA2位置之间画柱状线,宽度为0,0不为0则画空心柱.,画蓝色
VAR11A赋值:(收盘价*2+最高价+最低价)/4
VAR21A赋值:VAR11A的13日指数移动平均-VAR11A的34日指数移动平均
VAR31A赋值:VAR21A的5日指数移动平均
VAR2赋值:((收盘价 > 1日前的收盘价) AND (收盘价 > 2日前的收盘价))
VAR3赋值:((1日前的VAR2 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR4赋值:((1日前的VAR3 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR5赋值:((1日前的VAR4 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR6赋值:((1日前的VAR5 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR7赋值:((1日前的VAR6 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR8赋值:((1日前的VAR7 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR9赋值:((1日前的VAR8 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARA赋值:((1日前的VAR9 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VARB赋值:((1日前的VARA AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARC赋值:((1日前的VARB AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VARD赋值:((1日前的VARC AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARE赋值:((收盘价 < 1日前的收盘价) AND (收盘价 < 2日前的收盘价))
VARF赋值:((1日前的VARE AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR10赋值:((1日前的VARF AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR11赋值:((1日前的VAR10 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR12赋值:((1日前的VAR11 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR13赋值:((1日前的VAR12 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR14赋值:((1日前的VAR13 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR15赋值:((1日前的VAR14 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR16赋值:((1日前的VAR15 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR17赋值:((1日前的VAR16 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR18赋值:((1日前的VAR17 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR19赋值:((1日前的VAR18 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR1B赋值:(1日前的(((((((((((VAREORVARF)ORVAR10)ORVAR11)ORVAR12)ORVAR13)ORVAR14)ORVAR15)ORVAR16)ORVAR17)ORVAR18)ORVAR19) AND VAR2)
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR10FFFF
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FFFF
AA赋值:(1日前的(((((((((((VAR2ORVAR3)ORVAR4)ORVAR5)ORVAR6)ORVAR7)ORVAR8)ORVAR9)ORVARA)ORVARB)ORVARC)ORVARD) AND VARE)
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00EE00
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00
A13赋值:收盘价的55日指数移动平均
A14赋值:收盘价的75日简单移动平均
A15赋值:A14的3日指数移动平均
A16赋值:A15的3日指数移动平均
A17赋值:(最高价 + 最低价) / 5
A18赋值:(A17的4日简单移动平均) - (A17的34日简单移动平均)
A19赋值:A18上穿0
A20赋值:0上穿A18
A21赋值:上次A19距今天数
A22赋值:上次A20距今天数
A23赋值:1日前的A19
A24赋值:1日前的A20
A25赋值:上次A23距今天数
A26赋值:上次A24距今天数
A27赋值:如果(A25<A26),返回(A25日前的(2日内最高价的最高值)),否则返回(A26日前的(2日内最低价的最低值))
A28赋值:(((1日前的收盘价) <= (1日前的A27)) AND (收盘价 > A27)) AND (A21 < A22)
A29赋值:(((1日前的收盘价) >= (1日前的A27)) AND (收盘价 < A27)) AND (A22 < A21)
A30赋值:A28 AND ((统计A21日中满足A28的天数) = 1)
A31赋值:A29 AND ((统计A22日中满足A29的天数) = 1)
A32赋值:A30 AND ((1日前的上次A31距今天数) < (1日前的上次A30距今天数))
A33赋值:A31 AND ((1日前的上次A31距今天数) > (1日前的上次A30距今天数))
当满足条件A32时,在SMA2*0.99位置书写文字,画黄色
AC赋值:成交额(元)/(成交量(手))
YY赋值:AC的13日简单移动平均
LLL赋值:(收盘价-YY)/YY*100
赋值: 收盘价的22日简单移动平均
UPPERC赋值: MIDC + 2*收盘价的22日估算标准差
LOWERC赋值: MIDC - 2*收盘价的22日估算标准差
BBA赋值:(收盘价-LOWERC)/(UPPERC-LOWERC)
BBC赋值:BBA的3日线性回归预测值
L55188CYC赋值:(1日前的LLL<-15 AND 1日前的BBA<0 AND LLL>1日前的LLL)
当满足条件L55188CYC>0时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR10ABFF
当满足条件L55188CYC>0时,在最低价*0.99位置书写文字,COLORDD00DD[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1rXlzv-E25A0jvesllPhb4w

看了该指标的人还看了:
行情副图指标    做底指标    超级火箭推进指标
游龙剑指标    重上五线指标    波段机会指标

使用道具 举报

回复