指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
微信截图_20181211103310.png

微信截图_20181211103336.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N:=2;
M:=5;
K:=40;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+20*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
买线:EMA(C,N);
卖线:EMA(SLOPE(牛线,M)*18+牛线,K);
A1:REF(卖线,2);
BU:=CROSS(买线, A1);
SEL:=CROSS( A1,买线);
DRAWICON(BU AND FILTER(BU,3),L-0.1,1);
DRAWICON(SEL AND FILTER(SEL,3),H+0.1,2);
STICKLINE(买线>= A1,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>= A1,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<A1,LOW,HIGH,0.0,1),COLORCYAN;
STICKLINE(买线<A1,CLOSE,OPEN,2,1),COLORCYAN;
操盘线:=MA(CLOSE,9),COLORYELLOW;
界点线:=MA(CLOSE,20),COLORMAGENTA;[/lycode][lycode=tdx2,true]N赋值:2
M赋值:5
K赋值:40
MID赋值:(3*收盘价+最低价+开盘价+最高价)/6
输出牛线:(20*MID+19*1日前的MID+20*2日前的MID+17*3日前的MID+16*4日前的MID+15*5日前的MID+14*6日前的MID+13*7日前的MID+12*8日前的MID+11*9日前的MID+10*10日前的MID+9*11日前的MID+8*12日前的MID+7*13日前的MID+6*14日前的MID+5*15日前的MID+4*16日前的MID+3*17日前的MID+2*18日前的MID+20日前的MID)/210,画红色
输出买线:收盘价的N日指数移动平均
输出卖线:牛线的M日线性回归斜率*18+牛线的K日指数移动平均
输出A1:2日前的卖线
BU赋值:买线上穿A1
SEL赋值:A1上穿买线
当满足条件BUANDFILTER(BU,3)时,在最低价-0.1位置画1号图标
当满足条件SELANDFILTER(SEL,3)时,在最高价+0.1位置画2号图标
当满足条件买线>=A1时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画红色
当满足条件买线>=A1时,在收盘价和开盘价位置之间画柱状线,宽度为2,1不为0则画空心柱.,画红色
当满足条件买线<A1时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画青色
当满足条件买线<A1时,在收盘价和开盘价位置之间画柱状线,宽度为2,1不为0则画空心柱.,画青色
操盘线赋值:收盘价的9日简单移动平均,画黄色
界点线赋值:收盘价的20日简单移动平均,画洋红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/16_CBImsxU3AR_qDD2PVTBQ

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复