指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 趋势 操盘控盘 
微信截图_20181211102800.png

微信截图_20181211102815.png

[lywrap=通达信副图指标公式][lycode=tdx,true]80,COLOR996699;
20,COLORGREEN;
10,COLORCC6633,LINETHICK2;
90,COLOR9966FF,LINETHICK2;
{
50,COLORRED;
FILLRGN(1,20,80),COLOR222222;
FILLRGN(1,90,100),COLOR000068;
FILLRGN(1,79,90),COLOR663366;
FILLRGN(1,10,20),COLOR666600;
FILLRGN(1, 0,10),COLOR663300;
}
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;

长期线:A+100,COLOR9900FF;
短期线:B+100,COLOR888888;
中期线:D+100,COLORYELLOW,LINETHICK2;

{见顶:(长期线>85 OR REF(长期线,1)>85 ) AND (CROSS(中期线,短期线) OR CROSS(REF(中期线,1),REF(短期线,1)) )AND CROSS(长期线,短期线);
}
见顶:(REF(中期线,1)>85 AND  REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线) ;
顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4;
顶部:=FILTER(顶部区域,4);

{DRAWICON( 见顶, 108, 2 );}

底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ;

STICKLINE( {见顶 OR} 顶部,99,103,20,1 ),COLORRED,LINETHICK2;
STICKLINE( 底部区域,-4,0,22,0 ),COLORGREEN;

低位金叉:长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 )  AND (中期线>=长期线 OR REF( 短期线,1)<1 );

STICKLINE( 低位金叉,0,5,11,0 ),COLORRED;
低位买入:长期线<10 AND CROSS(短期线,长期线) AND (短期线-REF(短期线,1))>12 AND 短期线>15;
STICKLINE(低位买入 ,0,28,2,0 ),COLOR9966FF;
低位抄底:长期线<9 AND CROSS(中期线,长期线) AND 短期线>20;
STICKLINE(低位抄底 ,0,5,8,0 ),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(中期线,长期线),1));
底背:REF(CLOSE,A1+1)>CLOSE AND 长期线>REF(长期线,A1+1) AND CROSS(中期线,长期线) AND REF(长期线,A1+1)<11;
STICKLINE( 底背,0,48,3,0 ),COLORRED;
A2:=BARSLAST(REF(CROSS(长期线,中期线),1));
顶背:REF(CLOSE,A2+1)<CLOSE AND REF(长期线,A2+1)>长期线 AND CROSS(长期线,中期线) AND  REF(长期线,A2+1)>88;
STICKLINE( 顶背,80,103,2,1 ),COLORGREEN,LINETHICK2;[/lycode][lycode=tdx2,true]80,COLOR996699
20,画绿色
10,COLORCC6633,线宽为2
90,COLOR9966FF,线宽为2
A赋值:-100*(34日内最高价的最高值-收盘价)/(34日内最高价的最高值-34日内最低价的最低值)的19日简单移动平均,画红色
B赋值:-100*(14日内最高价的最高值-收盘价)/(14日内最高价的最高值-14日内最低价的最低值)
D赋值:-100*(34日内最高价的最高值-收盘价)/(34日内最高价的最高值-34日内最低价的最低值)的4日指数移动平均,线宽为2
输出长期线:A+100,COLOR9900FF
输出短期线:B+100,COLOR888888
输出中期线:D+100,画黄色,线宽为2
输出见顶:(1日前的中期线>85 AND  1日前的短期线>85 AND 1日前的长期线>65) AND 长期线上穿短期线
输出顶部区域:(中期线<1日前的中期线 AND 1日前的中期线>80) AND (1日前的短期线>95 OR 2日前的短期线>95 ) AND 长期线>60 AND 短期线<83.5AND 短期线<中期线 AND 短期线<长期线+4
顶部赋值:顶部区域的4日过滤
输出底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR 1日前的短期线<5) AND (中期线>1日前的中期线 OR 短期线>1日前的短期线))OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>1日前的短期线) OR (长期线<10 AND 中期线<7 AND 短期线<1)
当满足条件顶部时,在99和103位置之间画柱状线,宽度为20,1不为0则画空心柱.,画红色,线宽为2
当满足条件底部区域时,在-4和0位置之间画柱状线,宽度为22,0不为0则画空心柱.,画绿色
输出低位金叉:长期线<15 AND 1日前的长期线<15 AND 中期线<18 AND 短期线>1日前的短期线 AND 短期线上穿长期线 AND 短期线>中期线AND (1日前的短期线<5 OR 2日前的短期线<5 )  AND (中期线>=长期线 OR 1日前的短期线<1 )
当满足条件低位金叉时,在0和5位置之间画柱状线,宽度为11,0不为0则画空心柱.,画红色
输出低位买入:长期线<10 AND 短期线上穿长期线 AND (短期线-1日前的短期线)>12 AND 短期线>15
当满足条件低位买入时,在0和28位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR9966FF
输出低位抄底:长期线<9 AND 中期线上穿长期线 AND 短期线>20
当满足条件低位抄底时,在0和5位置之间画柱状线,宽度为8,0不为0则画空心柱.,画黄色
A1赋值:上次1日前的中期线上穿长期线距今天数
输出底背:A1+1日前的收盘价>收盘价 AND 长期线>A1+1日前的长期线 AND 中期线上穿长期线 AND A1+1日前的长期线<11
当满足条件底背时,在0和48位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
A2赋值:上次1日前的长期线上穿中期线距今天数
输出顶背:A2+1日前的收盘价<收盘价 AND A2+1日前的长期线>长期线 AND 长期线上穿中期线 AND  A2+1日前的长期线>88
当满足条件顶背时,在80和103位置之间画柱状线,宽度为2,1不为0则画空心柱.,画绿色,线宽为2[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1wDCGRfmks-k8N4HbNi1RaA

看了该指标的人还看了:
行情副图指标    做底指标    超级火箭推进指标
游龙剑指标    重上五线指标    波段机会指标

使用道具 举报

回复