指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
微信截图_20181211102320.png

微信截图_20181211102336.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*100;
VAR2:=SMA(VAR1,6,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=10-VAR2+2*VAR3;
VAR5:=(3*VAR2+2*VAR3)/4;
VAR6:=ABS(ABS(VAR5)-ABS(VAR4));
VAR7:=ABS(ABS(VAR5)-ABS(VAR6));
洗盘挖坑:VAR4-VAR7,LINETHICK2,COLORYELLOW;
见顶:STICKLINE(洗盘挖坑<0,洗盘挖坑,0,1,0),COLORBLUE;
冲动:VAR5-VAR7,COLORGREEN;
DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD2:=(2 * (DIFF - DEA));
DRAWICON(((((LLV(MACD2,4) > 0) AND (MACD2 < REF(MACD2,1))) AND (REF(MACD2,1) > REF(MACD2,2))) AND (REF(MACD2,2) > REF(MACD2,3))) AND CROSS(洗盘挖坑,冲动),MACD2,6);
DRAWICON(((((HHV(MACD2,4) < 0) AND (MACD2 > REF(MACD2,1))) AND (REF(MACD2,1) < REF(MACD2,2))) AND (REF(MACD2,2) < REF(MACD2,3))) AND CROSS(冲动,洗盘挖坑) AND DIFF>REF(DIFF,1),MACD2,1);
DRAWICON(CROSS(冲动,洗盘挖坑) ,冲动,1);

25, POINTDOT,LINETHICK3, COLOR88CC00;
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6,COLORYELLOW;
DRAWTEXT(CROSS(短线买点,1) AND (短线买点<30),30,1),COLOR0000FF;
A:=1.1*C;
B:=0.9*C;
B1:=100*(WINNER(A)-WINNER(B));
C1:=MA(C,13)<REF(MA(C,13),1);
锁定筹码:=100-B1,COLORF00FF0,LINETHICK2;
明天买:IF(CROSS(锁定筹码,90)AND C1,锁定筹码-50,0),STICK,COLORBLUE,LINETHICK3;[/lycode][lycode=tdx2,true]VAR1赋值:(收盘价-3日内最低价的最低值)/(3日内最高价的最高值-3日内最低价的最低值)*100
VAR2赋值:VAR1的6日[1日权重]移动平均
VAR3赋值:VAR2的3日[1日权重]移动平均
VAR4赋值:10-VAR2+2*VAR3
VAR5赋值:(3*VAR2+2*VAR3)/4
VAR6赋值:VAR5的绝对值-VAR4的绝对值的绝对值
VAR7赋值:VAR5的绝对值-VAR6的绝对值的绝对值
输出洗盘挖坑:VAR4-VAR7,线宽为2,画黄色
输出见顶:当满足条件洗盘挖坑<0时,在洗盘挖坑和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画蓝色
输出冲动:VAR5-VAR7,画绿色
DIFF赋值:(收盘价的12日指数移动平均 - 收盘价的26日指数移动平均)
DEA赋值:DIFF的9日指数移动平均
MACD2赋值:(2 * (DIFF - DEA))
当满足条件((((4日内MACD2的最低值>0)AND(MACD2<1日前的MACD2))AND(1日前的MACD2>2日前的MACD2))AND(2日前的MACD2>3日前的MACD2))ANDCROSS(洗盘挖坑,冲动)时,在MACD2位置画6号图标
当满足条件((((4日内MACD2的最高值<0)AND(MACD2>1日前的MACD2))AND(1日前的MACD2<2日前的MACD2))AND(2日前的MACD2<3日前的MACD2))ANDCROSS(冲动,洗盘挖坑)ANDDIFF>1日前的DIFF时,在MACD2位置画1号图标
当满足条件冲动上穿洗盘挖坑时,在冲动位置画1号图标
25, POINTDOT,线宽为3, COLOR88CC00
AA赋值:1日前的收盘价
BBB赋值:收盘价-AA和0的较大值的5日[1日权重]移动平均/收盘价-AA的绝对值的5日[1日权重]移动平均*1000
HHH赋值:BBB-10日内BBB的最低值
SS赋值:(HHH的2日简单移动平均*3+HHH*13)/16
短线买点赋值:如果SS>13,返回SS的2日简单移动平均,否则返回SS/6,画黄色
当满足条件短线买点上穿1AND(短线买点<30)时,在30位置书写文字,COLOR0000FF
A赋值:1.1*收盘价
B赋值:0.9*收盘价
B1赋值:100*(以A计算的获利盘比例-以B计算的获利盘比例)
C1赋值:收盘价的13日简单移动平均<1日前的收盘价的13日简单移动平均
锁定筹码赋值:100-B1,COLORF00FF0,线宽为2
输出明天买:如果锁定筹码上穿90ANDC1,返回锁定筹码-50,否则返回0,STICK,画蓝色,线宽为3[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1HORZgzIem8uf0Ygt0ouhRA

看了该指标的人还看了:
行情副图指标    做底指标    超级火箭推进指标
游龙剑指标    重上五线指标    波段机会指标

使用道具 举报

回复