指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 趋势 操盘控盘 压力支撑 
TIM截图20181115103616.jpg

TIM截图20181115103628.jpg

[lywrap=通达信主图指标公式][lycode=tdx,true]HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
EMA13:=EMA(C,13),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1:EMA(A0,14)COLORBLUE,LINETHICK2;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};
逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};
买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3;
卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;[/lycode][lycode=tdx2,true]HIGHN赋值:10
LOWN赋值:10
HIGHDISPLAY赋值:0
LOWDISPLAY赋值:0
ZGDISPLAY赋值:0
MADISPLAY赋值:0
AA赋值:HIGHN日前的最高价=2*HIGHN+1日内最高价的最高值
QY赋值:若AA则将最近HIGHN+1周期置为1
CC赋值:QY的HIGHN日过滤 AND 最高价=HIGHN+1日内最高价的最高值
当满足条件CC时,在最高价*1.02位置画2号图标
DDD赋值:上次CC距今天数
GDTS赋值:如果CC,返回到最后交易的周期,否则返回0
DINGBU赋值:如果DDD,返回DDD日前的最高价,否则返回最高价
DINGBUTS赋值:如果DDD,返回DDD日前的GDTS,否则返回GDTS
DINGBU1赋值:DDD+1日前的DINGBU
GDCS1赋值:DINGBUTS的最后一日取值设为常数
DINGBUTS1赋值:DDD+1日前的DINGBUTS
GDCS2赋值:DINGBUTS1的最后一日取值设为常数
DINGBU2赋值:DDD+1日前的DINGBU1
MM赋值:如果到最后交易的周期>GDCS2,返回0,否则返回1
输出高点压力:当满足条件到最后交易的周期=GDCS2时,在最高价位置画直线起点,当满足条件到最后交易的周期=GDCS1时,在最高价位置画直线终点,1表示是否延长. 画绿色,线宽为2
当满足条件到最后交易的周期=GDCS2时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在GDCS2-1日前的最高价位置画直线终点,1表示是否延长.,COLOR0055FF,POINTDOT
当满足条件到最后交易的周期=GDCS1时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在GDCS1-1日前的最高价位置画直线终点,1表示是否延长.,画黄色,POINTDOT
AA1赋值:LOWN日前的最低价=2*LOWN+1日内最低价的最低值
QY1赋值:若AA1则将最近LOWN+1周期置为1
CC1赋值:QY1的LOWN日过滤 AND 最低价=LOWN+1日内最低价的最低值
当满足条件CC1时,在最低价*0.98位置画1号图标
DD1赋值:上次CC1距今天数
DDTS赋值:如果CC1,返回到最后交易的周期,否则返回0
YDB赋值:如果DD1,返回DD1日前的最低价,否则返回最低价
DDTS1赋值:如果DD1,返回DD1日前的DDTS,否则返回DDTS
DDCS1赋值:DDTS1的最后一日取值设为常数
ZDB赋值:DD1+1日前的YDB
DDTS2赋值:DD1+1日前的DDTS1
DDCS2赋值:DDTS2的最后一日取值设为常数
输出低点支撑:当满足条件到最后交易的周期=DDCS2时,在最低价位置画直线起点,当满足条件到最后交易的周期=DDCS1时,在最低价位置画直线终点,1表示是否延长. 画红色,线宽为2
ZGSTAR赋值:(高点压力+低点支撑)/2
ZGEND赋值:(高点压力+低点支撑)/2的最后一日取值设为常数
STARDAY赋值:如果DDCS2<GDCS2,返回DDCS2,否则返回GDCS2
输出中轨:当满足条件到最后交易的周期=STARDAY时,在ZGSTAR位置画直线起点,当满足条件是否最后一个周期时,在ZGEND位置画直线终点,1表示是否延长.,COLORFF55BB,线宽为2
当满足条件到最后交易的周期=DDCS1时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在DDCS1-1日前的最低价位置画直线终点,1表示是否延长.,画洋红色,POINTDOT,
当满足条件到最后交易的周期=DDCS2时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在DDCS2-1日前的最低价位置画直线终点,1表示是否延长.,画青色,POINTDOT
EMA13赋值:收盘价的13日指数移动平均,画白色
EMA21赋值:收盘价的21日指数移动平均,画黄色
EMA34赋值:收盘价的34日指数移动平均,COLORFF00FF
EMA60赋值:收盘价的60日简单移动平均,COLORFFCC66
VAR2赋值:(2*收盘价+最高价+最低价)/4
VAR3赋值:如果年份>=2099ANDMONTH>2,返回0,否则返回1
VAR4赋值:5日内最低价的最低值
VAR5赋值:4日内最高价的最高值
散户赋值:(VAR2-VAR4)/(VAR5-VAR4)*100的4日指数移动平均*VAR3
庄家赋值:0.667*1日前的散户+0.333*散户的2日指数移动平均*VAR3
当满足条件散户上穿庄家AND散户<30时,在最低价-0.05位置书写文字,画淡红色
当满足条件庄家上穿散户AND散户>70时,在最高价+0.05位置书写文字,画绿色
当满足条件散户上穿庄家AND散户<30时,在最低价-0.05位置画1号图标
当满足条件庄家上穿散户AND散户>70时,在最高价+0.05位置画2号图标
VAR9赋值:收盘价-5日前的收盘价
VARA赋值:VAR9的5日指数移动平均的5日指数移动平均/VAR9的绝对值的5日指数移动平均的5日指数移动平均
VARC赋值:VAR9的20日指数移动平均的20日指数移动平均/VAR9的绝对值的20日指数移动平均的20日指数移动平均
卖出赋值:如果VARA>0ANDCROSS(VARC,VARA),返回90,否则返回100
当满足条件卖出<0时,在最高价+0.05位置画2号图标
买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
输出B1:如果买线上穿卖线,返回最低价-0.02,否则返回无效数,CROSSDOT,线宽为3,画洋红色
输出S1:如果80上穿RSI*30,返回最高价+0.02,否则返回无效数,CROSSDOT,线宽为3,画黄色
VC赋值:((收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100+(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100+(收盘价-收盘价的32日简单移动平均)/收盘价的32日简单移动平均*100)/3
S2赋值:如果VC>20ANDFILTER(VC<1日前的VC,5),返回最高价+0.02,否则返回无效数,CIRCLEDOT,线宽为3,画绿色
A0赋值:(最低价+最高价+收盘价*2)/4
输出A1:A0的14日指数移动平均画蓝色,线宽为2
A2赋值:A0的25日指数移动平均画淡蓝色,线宽为2
A1X赋值:(A1-1日前的A1)/1日前的A1*100,NODRAW
A2X赋值:(A2-1日前的A2)/1日前的A2*100,NODRAW
输出看多:如果A1X>=0ANDBARSLAST(A1X上穿0)>0,返回上次A1X上穿0距今天数日前的(收盘价+开盘价)/2,否则返回无效数,画洋红色
输出逃顶:如果A1X<0ANDBARSLAST(0上穿A1X)>0,返回上次0上穿A1X距今天数日前的(收盘价+开盘价)/2,否则返回无效数,画青色,
输出买入持股:如果A1X>=0,返回A1,否则返回无效数画红色,线宽为3
输出卖出空仓:如果A1X<0ANDA2X<0,返回A1,否则返回无效数画绿色,线宽为3
当满足条件A1X上穿0时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR9933FF
当满足条件A1X上穿0时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000CC
当满足条件A1X上穿0时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0033FF
当满足条件0上穿A1X时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR66CC33[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1kL1X6EUOt5pcFP64OvN_bw

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复