指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
TIM截图20181108113609.png

TIM截图20181108113621.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N:=2;
M:=3;
趋势线:SMA(EMA(((C+L)/2-LLV(L,21))/(HHV((H+C)/2,21)-LLV(L,21))*100,3),7,1)-(13),LINETHICK2,COLORF0F000;
判断:=(SMA(((C+L)/2-LLV(L,21))/(HHV((H+C)/2,21)-LLV(L,21))*100,2,1)-8);
强势区:判断>趋势线,COLOR9800FF;
STICKLINE(强势区,30,40,4,2),COLOR9800FF;
弱势区:判断<趋势线,COLORYELLOW;
STICKLINE(弱势区,30,40,4,2),COLORYELLOW;
STICKLINE(FILTER(CROSS(判断,趋势线)=1 OR 判断>REF(判断,1),10) AND 判断<25 ,趋势线,趋势线+10,9,1),COLORRED;
STICKLINE(FILTER(判断,5),趋势线+5,趋势线+15,9,1),COLOR00FF00;
DRAWICON(FILTER(趋势线>=REF(趋势线,1)AND 趋势线<0,15),0,1);
VAR2:=1;
VAR3:=REF(HIGH,1)*1.1;
VAR4:=HIGH*1.1;
VAR5:=(VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
VAR6:=REF(LOW,1)*0.9;
VAR7:=LOW*0.9;
VAR8:=(VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
VAR9:=EMA(VAR8,30);
VARA:=EMA(VAR5,30);
VARB:=VARA-2;
VARC:=IF(CLOSE<=VAR9,VARB,VARA);
VARD:=MA(CLOSE,80)-MA(CLOSE,10)/17;
出手: STICKLINE(VARC-VARB=0 AND VAR2 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),50,0,5,0),COLORCC9966;
赢: DRAWTEXT(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),4),55,'低点'),COLORRED;
VARE:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
卖出线: SMA(SMA(VARE,3,1),3,1),COLORFF6633;
买入线: 3*SMA(VARE,3,1)-2*卖出线,COLORRED;
DRAWICON(CROSS(90,买入线),90,2);
黄金点: STICKLINE(SMA(VARE,3,1)>卖出线,SMA(VARE,3,1),卖出线,4,0),COLOR1133FF  ;[/lycode][lycode=tdx2,true]N赋值:2
M赋值:3
输出趋势线:((收盘价+最低价)/2-21日内最低价的最低值)/(21日内(最高价+收盘价)/2的最高值-21日内最低价的最低值)*100的3日指数移动平均的7日[1日权重]移动平均-(13),线宽为2,COLORF0F000
判断赋值:(((收盘价+最低价)/2-21日内最低价的最低值)/(21日内(最高价+收盘价)/2的最高值-21日内最低价的最低值)*100的2日[1日权重]移动平均-8)
输出强势区:判断>趋势线,COLOR9800FF
当满足条件强势区时,在30和40位置之间画柱状线,宽度为4,2不为0则画空心柱.,COLOR9800FF
输出弱势区:判断<趋势线,画黄色
当满足条件弱势区时,在30和40位置之间画柱状线,宽度为4,2不为0则画空心柱.,画黄色
当满足条件判断上穿趋势线=1OR判断>1日前的判断的10日过滤AND判断<25时,在趋势线和趋势线+10位置之间画柱状线,宽度为9,1不为0则画空心柱.,画红色
当满足条件判断的5日过滤时,在趋势线+5和趋势线+15位置之间画柱状线,宽度为9,1不为0则画空心柱.,COLOR00FF00
当满足条件趋势线>=1日前的趋势线AND趋势线<0的15日过滤时,在0位置画1号图标
VAR2赋值:1
VAR3赋值:1日前的最高价*1.1
VAR4赋值:最高价*1.1
VAR5赋值:(VAR4*成交量(手)+VAR3*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR6赋值:1日前的最低价*0.9
VAR7赋值:最低价*0.9
VAR8赋值:(VAR7*成交量(手)+VAR6*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR9赋值:VAR8的30日指数移动平均
VARA赋值:VAR5的30日指数移动平均
VARB赋值:VARA-2
VARC赋值:如果收盘价<=VAR9,返回VARB,否则返回VARA
VARD赋值:收盘价的80日简单移动平均-收盘价的10日简单移动平均/17
输出出手: 当满足条件VARC-VARB=0ANDVAR2ANDCROSS((收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均)/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-的?日简单移动平均时,在EF(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均,1))/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,M))和50位置之间画柱状线,宽度为0,5不为0则画空心柱.,COLORCC9966
输出赢: 当满足条件VARC-VARB=0ANDCROSS((收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均)/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-的?日简单移动平均的?日过滤时,在EF(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均,1))/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,M)),4)位置书写文字,画红色
VARE赋值:(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100
输出卖出线: VARE的3日[1日权重]移动平均的3日[1日权重]移动平均,COLORFF6633
输出买入线: 3*VARE的3日[1日权重]移动平均-2*卖出线,画红色
当满足条件90上穿买入线时,在90位置画2号图标
输出黄金点: 当满足条件VARE的3日[1日权重]移动平均>卖出线时,在VARE的3日[1日权重]移动平均和卖出线位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR1133FF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1j0q8lZ3Jn1V5NNXPtzSW4g

看了该指标的人还看了:
横扫天下指标    周线测底指标    波段密码指标
青龙白虎指标    高抛低吸指标    龙行凤影指标,很漂亮

使用道具 举报

回复