指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 操盘控盘 
TIM截图20181108113049.png

TIM截图20181108113100.png

[lywrap=通达信主图指标公式][lycode=tdx,true]上线:=SMA(C,6.5,1);
下线:=SMA(C,13.5,1);
上线1:=SMA(C,3,1);
下线1:=SMA(C,8,1);
{STICKLINE(上线>下线 , 上线,下线 ,0.1, 0),COLORRED,LINETHICK1;
STICKLINE(下线>上线,上线,下线,0.1,0),COLORYELLOW,LINETHICK1;}
DRAWTEXT( CROSS(上线,下线),LOW *0.98,'.全仓买'),COLOR00FF00;
DRAWTEXT(CROSS(下线1,上线1),H*1.02,'.清仓'),COLORYELLOW;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,60),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) , HIGH*1.02,'减仓') ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
VAR1:=LLV(A7,21);
VAR2:=HHV(A7,21);
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND
COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW*0.98,'.买进') ,COLOR0099FF;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.98,'.买进') ,COLORYELLOW;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,'.抄底'),COLORYELLOW;
STICKLINE( MA(CLOSE,8)>MA(CLOSE,30),MA(CLOSE,8),MA(CLOSE,30),8,0),COLOR000088;
STICKLINE( MA(CLOSE,8)<MA(CLOSE,30),MA(CLOSE,8),MA(CLOSE,30),8,0),COLOR008800;
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE,LINETHICK2;
MA8:MA(CLOSE,8),COLORFF9966,LINETHICK2;
MA30:MA(CLOSE,30),COLORGREEN,LINETHICK2;[/lycode][lycode=tdx2,true]上线赋值:收盘价的6.5日[1日权重]移动平均
下线赋值:收盘价的13.5日[1日权重]移动平均
上线1赋值:收盘价的3日[1日权重]移动平均
下线1赋值:收盘价的8日[1日权重]移动平均
当满足条件上线上穿下线时,在最低价*0.98位置书写文字,COLOR00FF00
当满足条件下线1上穿上线1时,在最高价*1.02位置书写文字,画黄色
BBI赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4
UPR赋值:BBI+3*BBI的13日估算标准差,线宽为2
DWN赋值:BBI-3*BBI的13日估算标准差
安全赋值:收盘价的60日简单移动平均,线宽为2
LC赋值:1日前的收盘价
RSI赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿RSI时,在最高价*1.02位置书写文字 ,COLORFF9966,线宽为2
A7赋值:(2*收盘价+最高价+最低价)/4
输出操作:A7的5日简单移动平均,线宽为2
操作1赋值:A7的5日简单移动平均*1.03,线宽为2
操作2赋值:A7的5日简单移动平均*0.97,线宽为2
VAR1赋值:21日内A7的最低值
VAR2赋值:21日内A7的最高值
SK赋值:(A7-VAR1)/(VAR2-VAR1)*100的7日指数移动平均
SD赋值:0.667*1日前的SK+0.333*SK的5日指数移动平均
当满足条件如果统计8日中满足收盘价<1日前的收盘价的天数/8>6/10ANDVOL>=1.5*成交量(手)的5日简单移动平均ANDCOUNT(SK>=SD,3)ANDREF(最低价,1)=120日内最低价的最低值,返回1,否则返回0时,在最低价*0.98位置书写文字 ,COLOR0099FF
当满足条件如果统计13日中满足收盘价<1日前的收盘价的天数/13>6/10ANDCOUNT(SK>SD,6)ANDREF(最低价,5)=120日内最低价的最低值ANDREF(收盘价>=开盘价,4)ANDREF(收阳线,3)ANDREF(收阳线,2)ANDREF(开盘价>CLOS,返回?,否则返回?时,在,1)ANDOPEN>1日前的收盘价,1,0)位置书写文字 ,画黄色
D赋值:收盘价的80日简单移动平均-收盘价的10日简单移动平均/3
当满足条件如果收盘价<DANDVOL/240>成交量(手)的5日简单移动平均/240ANDCLOSE>1日前的收盘价*1.08ANDCLOSE<收盘价的13日简单移动平均*1.3,返回1,否则返回0时,在最低价*0.98位置书写文字,画黄色
当满足条件收盘价的8日简单移动平均>收盘价的30日简单移动平均时,在收盘价的8日简单移动平均和收盘价的30日简单移动平均位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR000088
当满足条件收盘价的8日简单移动平均<收盘价的30日简单移动平均时,在收盘价的8日简单移动平均和收盘价的30日简单移动平均位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR008800
K线
输出MA5:收盘价的5日简单移动平均,画白色,线宽为2
输出MA8:收盘价的8日简单移动平均,COLORFF9966,线宽为2
输出MA30:收盘价的30日简单移动平均,画绿色,线宽为2[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1pPCFYzDydCMy4VzGqT79Dg

看了该指标的人还看了:
趋势波段买卖指标    大肥羊指标    上升之星指标
财富临门指标    大肥羊指标    挖金子指标

使用道具 举报

回复