指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
TIM截图20181108103904.png

TIM截图20181108103916.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N:2;M:=3;
VAR2:=1;
VAR3:=REF(HIGH,1)*1.1;
VAR4:=HIGH*1.1;
VAR5:=(VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
VAR6:=REF(LOW,1)*0.9;
VAR7:=LOW*0.9;
VAR8:=(VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
VAR9:=EMA(VAR8,30);
VARA:=EMA(VAR5,30);
VARB:=VARA-2;
VARC:=IF(CLOSE<=VAR9,VARB,VARA);
VARD:=MA(CLOSE,80)-MA(CLOSE,10)/17;
出手: STICKLINE(VARC-VARB=0 AND VAR2 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),50,0,5,0),COLORCC9966;
赢: DRAWTEXT(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),4),55,'买入'),COLORBLUE , ;
VARE:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
卖出线: SMA(SMA(VARE,3,1),3,1),COLORYELLOW  , ;
买入线: 3*SMA(VARE,3,1)-2*卖出线,COLORRED , ;
DRAWICON(CROSS(90,买入线),90,2);
顶: STICKLINE(CROSS(90,买入线),15,0,5,0),COLORGREEN ,;
黄金点: STICKLINE(SMA(VARE,3,1)>卖出线,SMA(VARE,3,1),卖出线,4,0),COLOR1133FF;
长买: FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)
-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)
*100, MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))
/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),4) ;
短买: CROSS(买入线,卖出线);
DRAWTEXT(短买,卖出线,'★'),COLORRED;[/lycode][lycode=tdx2,true]输出N:2
M赋值:3
VAR2赋值:1
VAR3赋值:1日前的最高价*1.1
VAR4赋值:最高价*1.1
VAR5赋值:(VAR4*成交量(手)+VAR3*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR6赋值:1日前的最低价*0.9
VAR7赋值:最低价*0.9
VAR8赋值:(VAR7*成交量(手)+VAR6*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR9赋值:VAR8的30日指数移动平均
VARA赋值:VAR5的30日指数移动平均
VARB赋值:VARA-2
VARC赋值:如果收盘价<=VAR9,返回VARB,否则返回VARA
VARD赋值:收盘价的80日简单移动平均-收盘价的10日简单移动平均/17
输出出手: 当满足条件VARC-VARB=0ANDVAR2ANDCROSS((收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均)/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-的?日简单移动平均时,在EF(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均,1))/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,M))和50位置之间画柱状线,宽度为0,5不为0则画空心柱.,COLORCC9966
输出赢: 当满足条件VARC-VARB=0ANDCROSS((收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均)/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-的?日简单移动平均的?日过滤时,在EF(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均,1))/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,M)),4)位置书写文字,画蓝色 ,
VARE赋值:(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100
输出卖出线: VARE的3日[1日权重]移动平均的3日[1日权重]移动平均,画黄色  ,
输出买入线: 3*VARE的3日[1日权重]移动平均-2*卖出线,画红色 ,
当满足条件90上穿买入线时,在90位置画2号图标
输出顶: 当满足条件90上穿买入线时,在15和0位置之间画柱状线,宽度为5,0不为0则画空心柱.,画绿色 ,
输出黄金点: 当满足条件VARE的3日[1日权重]移动平均>卖出线时,在VARE的3日[1日权重]移动平均和卖出线位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR1133FF
输出长买: VARC-VARB=0ANDCROSS((收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均)/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,(收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均-?日前的指数移动平均的?日简单移动平均的收盘价的N日指数移动平均的N日指数移动平均,N),1))/1日前的收盘价的N日指数移动平均的N日指数移动平均的N日指数移动平均*100,M))日过滤
输出短买: 买入线上穿卖出线
当满足条件短买时,在卖出线位置书写文字,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1yGfVS99qpNl1OvOgh0cWmA

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复