指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 画线 操盘控盘 压力支撑 
TIM截图20181031102335.png

TIM截图20181031102426.png

[lywrap=通达信主图指标公式][lycode=tdx,true]动力线:MA(C,5),LINETHICK2,COLOR00CCFF;工作线:MA(C,10),COLORFF66FF,LINETHICK1;
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;

短期操盘:=工作线<REF(工作线,1);
决策线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),COLOR0168FF,LINETHICK2;
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ:=(上开+上高+上低)/3;
MA05:=MA(C,5);
MA10:=MA(C,10);
T1:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1));
MM:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST(CURRBARSCOUNT>MM+T1 AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST(CURRBARSCOUNT>MM+T2 AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3));
攻击线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH,1),COLOR00FFFF,LINETHICK1;
DRAWTEXT(ISLASTBAR, T3HIGH, '攻击线')LINETHICK1,COLOR00FFFF;A0:=(L+H+C*2)/4;

逃逸:EMA(A0,14)COLORRED,LINETHICK0;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK0;
逃逸X:=(逃逸-REF(逃逸,1))/REF(逃逸,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
出击:IF(逃逸X>=0 AND BARSLAST(CROSS(逃逸X,0))>0,REF((C+O)/2,BARSLAST(CROSS(逃逸X,0))),DRAWNULL),COLORMAGENTA,LINETHICK1;
IF(短期操盘,工作线,DRAWNULL),COLORBLUE,LINETHICK1;
MIDD:=MA(CYS,20);
CC:=MIDD+0.85*STD(CYS,10);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK1;
箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK1;
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORGREEN;
DRAWICON(CROSS(RSI,11) ,L*0.99,3);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR3:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR4:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR5:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
VAR9:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
VAR10:=EMA(MA(C,13),13);
VAR11:=FILTER((LLV(VAR9,2)=LLV(VAR9,7) AND COUNT(VAR9<0,2) AND CROSS(VAR9,MA(VAR9,2)))=1,5);
VAR12:=FILTER((HHV(VAR9,2)=HHV(VAR9,7) AND COUNT(VAR9>50,2) AND CROSS(MA(VAR9,2),VAR9))=1,1);
VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);
VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR4;
买3:=(VAR14 OR VAR15) AND VAR2;
买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);

{涨停}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
{跌停}
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
{蓝}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{绿}
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;
{灰}
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;

EMA3:=EMA(C,3);
VAR81:=1;
VAR82:=((((2*CLOSE)+HIGH)+LOW) / 4);
低金叉进:=20,COLORYELLOW,LINETHICK2;
高死叉出:=90,COLORGREEN,LINETHICK3;
VAR84:=LLV(LOW,5);
VAR85:=HHV(HIGH,4);
C1:=(EMA((((VAR82-VAR84)/(VAR85-VAR84))*100),4)*VAR81),COLORFF00FF,LINETHICK2;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR81),COLORFFFFFF,LINETHICK2;
条件:=CROSS(C1,C2) AND C1<40;
条件0:=CROSS(C2,C1) AND C1>90;
TJ1:=CROSS(C1,C2);
TJ2:=CROSS(C2,C1);
TJ3:=CROSS(C1,C2) AND REF(C1,1)<20;
TJ4:=CROSS(C2,C1) AND REF(C1,1)>80;

STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;
STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLORRED;

AH:=HHV(HIGH,200);
AL:=LLV(LOW,200);
B0:=(AH-AL)/40;
LC:=REF(CLOSE,1);
VAR28:=SMA(MAX(CLOSE-LC,0),5.5,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0 AND EMA(CLOSE,12)/LOW>1.15,5),LOW,'买'),COLORFF00FF;
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA:=SMA(VARF,3,1);
SS:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (AA>79);
V7:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V7>=1,O,C,1,0),COLORYELLOW;
LC1:=REF(CLOSE,1);
RSI1:=((SMA(MAX((CLOSE - LC1),0),3,1) / SMA(ABS((CLOSE - LC1)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);

AA1:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA1),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B11:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
MA20:=MA(C,20);
MA90:=MA(C,90);
决策点:IF(决策线<REF(决策线,1),决策线,DRAWNULL),COLORFF6128,LINETHICK2;

F0:=BARSLAST(CROSS(MA(C,5),MA(C,90)));
F1:=F0 AND BARSLAST(CROSS(MA(C,20),MA(C,90)));
F2:=F1 AND CROSS(MA(C,5),MA(C,20)) AND MA(C,20)>MA(C,90);
M:=OPEN;
M1:=MA(C,1);
M2:=REF(M1,1);
M3:=REF(M2,1);

波动回调提示图:=MA(CLOSE,10000);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);

VAR31:=LLV(LOW,55);
AB:=CROSS(AK1,AK);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);

NA:=CROSS(DIF,DEA);
空:=EMA(C,5);
均衡:=EMA(空,5),COLORWHITE;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,20)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);

STICKLINE(SEL,OPEN,CLOSE,1,0),COLOR9966FF;

STICKLINE(BU,OPEN,CLOSE,1.2,0),COLORYELLOW;
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
VARK:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);  VARG:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VARN:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR30:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR41:=REF(VAR30,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR32:=REF(VAR41,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR33:=REF(VAR32,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR34:=REF(VAR33,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR35:=REF(VAR34,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR36:=REF(VAR35,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR37:=REF(VAR36,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR38:=REF(VAR37,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR39:=REF(VARK OR VARG OR VARN OR VAR30 OR VAR41 OR VAR32 OR VAR33 OR
VAR34 OR VAR35 OR VAR36 OR VAR37 OR VAR38,1) AND VAR1;

STICKLINE(VAR39,OPEN,CLOSE,1,0),COLORYELLOW;
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW,'变盘'),COLORRED;

AAAA:=FILTER(CLOSE>REF(HHV(HIGH,100),1)
AND REF(C,1)<REF(HHV(HIGH,100),1),5)
AND EXIST(EVERY(C>EMA(C,120),30),100)AND C/EMA(C,100)<1.5;
DRAWICON(AAAA,LOW,9);多:EMA(C,3),COLORYELLOW;
VAR111:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
VAR222:=8;
CCC:=CROSS(VAR111,VAR222);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破盘整:=W4 AND COUNT(W4,5)=1;
DRAWICON(突破盘整,L-0.10,9);HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;

AAA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AAA,HIGHN+1);
CCCC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDD:=BARSLAST(CCCC);
GDTS:=IF(CCCC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;
AAA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AAA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);

DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;
A1:=REF(H,8)=HHV(H,2*8+1);
BB1:=FILTER(A1,8);
CCC1:=BACKSET(BB1,8+1);
D1:=FILTER(CCC1,8);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORLIGREEN;

A22:=REF(L,8)=LLV(L,2*8+1);
B22:=FILTER(A22,8);
C22:=BACKSET(B22,8+1);
D2:=FILTER(C22,8);{低点}

MMM:=INTPART(3*8/5);
A12:=REF(H,MMM)=HHV(H,2*MMM+1);
B12:=FILTER(A12,MMM);
C12:=BACKSET(B12,MMM+1);
D12:=FILTER(C12,MMM);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORRED;[/lycode][lycode=tdx2,true]输出动力线:收盘价的5日简单移动平均,线宽为2,COLOR00CCFF
输出工作线:收盘价的10日简单移动平均,COLORFF66FF,线宽为1
YTSL赋值:(3*收盘价+最低价+开盘价+最高价)/6
短期操盘赋值:工作线<1日前的工作线
输出决策线:((收盘价的21日线性回归斜率*20)+收盘价)的42日指数移动平均,COLOR0168FF,线宽为2
上开赋值:开盘价
上收赋值:收盘价
上高赋值:最高价
上低赋值:最低价
JJ赋值:(上开+上高+上低)/3
MA05赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
T1赋值:10日内最低价距今天数的最后一日取值设为常数
T1HIGH赋值:T1日前的最高价的最后一日取值设为常数
MM赋值:到最后交易的周期的最后一日取值设为常数
T2赋值:上次到最后交易的周期>MM+T1ANDH>T1HIGH距今天数的最后一日取值设为常数
T2HIGH赋值:T2日前的最高价的最后一日取值设为常数
T3赋值:上次到最后交易的周期>MM+T2ANDHIGH>T2HIGH距今天数的最后一日取值设为常数
T3HIGH赋值:T3日前的最高价的最后一日取值设为常数
输出攻击线:当满足条件到最后交易的周期=T3+1时,在T3HIGH位置画直线起点,当满足条件是否最后一个周期时,在T3HIGH位置画直线终点,1表示是否延长.,COLOR00FFFF,线宽为1
当满足条件是否最后一个周期时,在T3HIGH位置书写文字线宽为1,COLOR00FFFF
A0赋值:(最低价+最高价+收盘价*2)/4
输出逃逸:A0的14日指数移动平均画红色,线宽为0
A2赋值:A0的25日指数移动平均画淡蓝色,线宽为0
逃逸X赋值:(逃逸-1日前的逃逸)/1日前的逃逸*100,NODRAW
A2X赋值:(A2-1日前的A2)/1日前的A2*100,NODRAW
输出出击:如果逃逸X>=0ANDBARSLAST(逃逸X上穿0)>0,返回上次逃逸X上穿0距今天数日前的(收盘价+开盘价)/2,否则返回无效数,画洋红色,线宽为1
如果短期操盘,返回工作线,否则返回无效数,画蓝色,线宽为1
MIDD赋值:市场盈亏的20日简单移动平均
CC赋值:MIDD+0.85*市场盈亏的10日估算标准差
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
金叉赋值:J上穿D
死叉赋值:D上穿J
输出箱顶:1日前的30日内上收的最高值的2日简单移动平均,COLOR0000FF,线宽为1
输出箱底:1日前的30日内上收的最低值的2日简单移动平均,COLOR00FF00,线宽为1
五日乖离率赋值:(收盘价-MA05)/MA05*100
BB05赋值:(MA05/1日前的MA05-1)*100的反正切*180/3.1416
速度5赋值:(MA05-1日前的MA05)/1日前的MA05的3日指数移动平均*100的3日[1日权重]移动平均
加速度5赋值:(速度5-1日前的速度5)的3日指数移动平均,NODRAW
如果BB05>30ANDMA05>1日前的MA05,返回MA05,否则返回无效数,线宽为2,画红色
BB10赋值:(MA10/1日前的MA10-1)*100的反正切*180/3.1416
如果BB05<0ANDMA05<1日前的MA05,返回MA05,否则返回无效数,线宽为2,画绿色
当满足条件RSI上穿11时,在最低价*0.99位置画3号图标
VAR1赋值:收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价
VAR2赋值:收盘价=4日内收盘价的最高值 AND 1日前的收盘价=4日内收盘价的最低值
VAR3赋值:收盘价=4日内收盘价的最低值 AND (1日前的收盘价<2日前的收盘价 OR 1日前的收盘价<3日前的收盘价) OR 1日前的收盘价=4日内收盘价的最低值 AND 收盘价<2日前的收盘价 OR 2日前的收盘价=4日内收盘价的最低值 AND 1日前的收盘价=4日内收盘价的最高值 AND 收盘价<1日前的收盘价 OR 3日前的收盘价=4日内收盘价的最低值 AND 收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VAR4赋值:1日前的收盘价=4日内收盘价的最低值 AND 收盘价>=2日前的收盘价 OR 2日前的收盘价=4日内收盘价的最低值 AND 1日前的收盘价<=3日前的收盘价 AND 2日前的收盘价<4日前的收盘价 AND 收盘价>=1日前的收盘价
VAR5赋值:1日前的收盘价=4日内收盘价的最高值 AND 收盘价<2日前的收盘价 OR (2日前的收盘价=4日内收盘价的最高值 AND 1日前的收盘价>3日前的收盘价 OR 3日前的收盘价=4日内收盘价的最高值 AND 1日前的收盘价>2日前的收盘价) AND 2日前的收盘价>=4日前的收盘价 AND 收盘价<1日前的收盘价
VAR9赋值:100*收盘价-1日前的收盘价的6日指数移动平均的6日指数移动平均/收盘价-1日前的收盘价的绝对值的6日指数移动平均的6日指数移动平均
VAR10赋值:收盘价的13日简单移动平均的13日指数移动平均
VAR11赋值:(2日内VAR9的最低值=7日内VAR9的最低值ANDCOUNT(VAR9<0,2)ANDCROSS(VAR9,VAR9的2日简单移动平均))=1的5日过滤
VAR12赋值:(2日内VAR9的最高值=7日内VAR9的最高值ANDCOUNT(VAR9>50,2)ANDCROSS(VAR9的2日简单移动平均,VAR9))=1的1日过滤
VAR13赋值:(收盘价-1日前的收盘价)/1日前的收盘价的5日指数移动平均*100的3日[1日权重]移动平均*10
VAR14赋值:((VAR13上穿0ORCROSS(收盘价,VAR10))ANDVAR11)=1的3日过滤
VAR15赋值:收盘价的18日简单移动平均>=3日前的收盘价的18日简单移动平均 AND 收盘价上穿收盘价的18日简单移动平均
买1赋值:(VAR14 OR VAR15) AND VAR11
买2赋值:(VAR14 OR VAR15) AND VAR4
买3赋值:(VAR14 OR VAR15) AND VAR2
买4赋值:(VAR2 AND VAR11) OR (VAR4 AND VAR11)
当满足条件收盘价>1日前的收盘价*1.0985ANDCLOSE=最高价时,在收盘价和开盘价位置之间画柱状线,宽度为4,-1不为0则画空心柱.,COLOR00FFFF
当满足条件收盘价<1日前的收盘价*0.9015ANDCLOSE=最低价时,在收盘价和开盘价位置之间画柱状线,宽度为4,-1不为0则画空心柱.,画绿色
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF7700
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLORFF9900
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFFBB00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画青色
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000099
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR0000CC
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORCC66FF
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR009900
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR00BB00
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR00DD00
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00FF00
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR999999
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLORBBBBBB
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORDDDDDD
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFFFFF
EMA3赋值:收盘价的3日指数移动平均
VAR81赋值:1
VAR82赋值:((((2*收盘价)+最高价)+最低价) / 4)
低金叉进赋值:20,画黄色,线宽为2
高死叉出赋值:90,画绿色,线宽为3
VAR84赋值:5日内最低价的最低值
VAR85赋值:4日内最高价的最高值
C1赋值:((((VAR82-VAR84)/(VAR85-VAR84))*100)的4日指数移动平均*VAR81),COLORFF00FF,线宽为2
C2赋值:(((0.667*1日前的C1)+(0.333*C1))的2日指数移动平均*VAR81),COLORFFFFFF,线宽为2
条件赋值:C1上穿C2 AND C1<40
条件0赋值:C2上穿C1 AND C1>90
TJ1赋值:C1上穿C2
TJ2赋值:C2上穿C1
TJ3赋值:C1上穿C2 AND 1日前的C1<20
TJ4赋值:C2上穿C1 AND 1日前的C1>80
当满足条件金叉时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画黄色
当满足条件死叉时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画红色
AH赋值:200日内最高价的最高值
AL赋值:200日内最低价的最低值
B0赋值:(AH-AL)/40
LC赋值:1日前的收盘价
VAR28赋值:收盘价-LC和0的较大值的5.5日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
当满足条件收盘价的60日指数移动平均-收盘价的12日指数移动平均>0ANDEMA(收盘价,12)/最低价>1.15的5日过滤时,在最低价位置书写文字,COLORFF00FF
VARA赋值:((成交额(元))/(成交量(手)))/(100)
VARB赋值:((3)*(最高价)+最低价+开盘价+(2)*(收盘价))/(7)
VARC赋值:((成交额(元)的7日累和)/(VARA))/(100)
VARD赋值:以(成交量(手))/(VARC)为权重VARB的动态移动平均
VARE赋值:((收盘价-VARD)/(VARD))*(100)
VARF赋值:((收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值))*(100)
VARJ赋值:VARE的20日简单移动平均+VARE的20日估算标准差
BIAS18赋值:((收盘价-收盘价的18日简单移动平均)/(收盘价的18日简单移动平均))*(100)
AA赋值:VARF的3日[1日权重]移动平均
SS赋值:(1日前的BIAS18>=5) AND VARJ上穿VARE AND (AA>79)
V7赋值:如果到最后交易的周期=1,返回成交量(手)*240/当前离开盘分钟数/1日前的成交量(手)-1,否则返回成交量(手)/1日前的成交量(手)-1
当满足条件V7>=1时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
LC1赋值:1日前的收盘价
RSI1赋值:(((收盘价-LC1)和0的较大值的3日[1日权重]移动平均 / (收盘价-LC1)的绝对值的3日[1日权重]移动平均) * 100)
FF赋值:收盘价的3日指数移动平均
MA15赋值:收盘价的21日指数移动平均
AA1赋值:(20日内最高价的最高值 - (2 * 真实波幅))
BB赋值:收盘价上穿1日前的55日内最高价的最高值
SSS赋值:收盘价的13日简单移动平均和AA1的较小值上穿收盘价
BBB赋值:上次BB距今天数
SSSB赋值:上次SSS距今天数
B11赋值:((BBB = 0) AND (1日前的SSSB < 1日前的BBB))
VAR2S赋值:(2*收盘价+最高价+最低价)/4
VAR3S赋值:如果年份>=2099ANDMONTH>2,返回0,否则返回1
VAR4S赋值:5日内最低价的最低值
VAR5S赋值:4日内最高价的最高值
散户赋值:(VAR2S-VAR4S)/(VAR5S-VAR4S)*100的4日指数移动平均*VAR3S
庄家赋值:0.667*1日前的散户+0.333*散户的2日指数移动平均*VAR3S
MA20赋值:收盘价的20日简单移动平均
MA90赋值:收盘价的90日简单移动平均
输出决策点:如果决策线<1日前的决策线,返回决策线,否则返回无效数,COLORFF6128,线宽为2
F0赋值:上次收盘价的5日简单移动平均上穿收盘价的90日简单移动平均距今天数
F1赋值:F0 AND 上次收盘价的20日简单移动平均上穿收盘价的90日简单移动平均距今天数
F2赋值:F1 AND 收盘价的5日简单移动平均上穿收盘价的20日简单移动平均 AND 收盘价的20日简单移动平均>收盘价的90日简单移动平均
M赋值:开盘价
M1赋值:收盘价的1日简单移动平均
M2赋值:1日前的M1
M3赋值:1日前的M2
波动回调提示图赋值:收盘价的10000日简单移动平均
Y赋值:收盘价的10日指数移动平均
LL赋值:2日前的收盘价
AK1赋值:(((收盘价-VAR1)/(VAR2-VAR1))*100)的5日指数移动平均
AK赋值:(((收盘价-VAR1)/(VAR2-VAR1))*50)的13日指数移动平均
VAR31赋值:55日内最低价的最低值
AB赋值:AK1上穿AK
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
NA赋值:DIF上穿DEA
空赋值:收盘价的5日指数移动平均
均衡赋值:空的5日指数移动平均,画白色
买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的20日线性回归斜率*20+收盘价的42日指数移动平均
BU赋值:买线上穿卖线
SEL赋值:卖线上穿买线
当满足条件SEL时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR9966FF
当满足条件BU时,在开盘价和收盘价位置之间画柱状线,宽度为1.2,0不为0则画空心柱.,画黄色
B1赋值:((BBB = 0) AND (1日前的SSSB < 1日前的BBB))
B1B赋值:上次B1距今天数
B2赋值:((((布林极限 = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (统计SSSB日中满足布林极限的天数 < 3))
B2B赋值:上次B2距今天数
B3赋值:((((布林极限 = 1) AND (B2B < B1B)) AND (统计SSSB日中满足布林极限的天数 < 4)) AND (统计SSSB日中满足布林极限的天数 > 2))
VARK赋值:收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VARG赋值:1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARN赋值:1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR30赋值:1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR41赋值:1日前的VAR30 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR32赋值:1日前的VAR41 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR33赋值:1日前的VAR32 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR34赋值:1日前的VAR33 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR35赋值:1日前的VAR34 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR36赋值:1日前的VAR35 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR37赋值:1日前的VAR36 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR38赋值:1日前的VAR37 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR39赋值:1日前的VARKORVARGORVARNORVAR30ORVAR41ORVAR32ORVAR33ORVAR34ORVAR35ORVAR36ORVAR37ORVAR38 AND VAR1
当满足条件VAR39时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
DX赋值:100*动量线的6日指数移动平均的6日指数移动平均/动量线的绝对值的6日指数移动平均的6日指数移动平均
买赋值:2日内DX的最低值=7日内DX的最低值 AND 统计2日中满足DX<0的天数 AND DX上穿DX的2日简单移动平均
当满足条件买=1的5日过滤时,在最低价位置书写文字,画红色
AAAA赋值:收盘价>1日前的100日内最高价的最高值ANDREF(收盘价,1)<1日前的100日内最高价的最高值的5日过滤AND 最近100日存在最近30日一直存在收盘价>收盘价的120日指数移动平均AND 收盘价/收盘价的100日指数移动平均<1.5
当满足条件AAAA时,在最低价位置画9号图标
输出多:收盘价的3日指数移动平均,画黄色
VAR111赋值:4*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均-3*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均的3.2日[1日权重]移动平均
VAR222赋值:8
CCC赋值:VAR111上穿VAR222
W1赋值:收盘价=20日内收盘价的最高值
W2赋值:上次W1距今天数
W3赋值:如果W2>0,返回W2日前的收盘价,否则返回W2日前的收盘价
W4赋值:收盘价上穿1日前的W3
突破盘整赋值:W4 AND 统计5日中满足W4的天数=1
当满足条件突破盘整时,在最低价-0.10位置画9号图标
HIGHN赋值:10
LOWN赋值:10
HIGHDISPLAY赋值:0
LOWDISPLAY赋值:0
ZGDISPLAY赋值:0
MADISPLAY赋值:0
AAA赋值:HIGHN日前的最高价=2*HIGHN+1日内最高价的最高值
QY赋值:若AAA则将最近HIGHN+1周期置为1
CCCC赋值:QY的HIGHN日过滤 AND 最高价=HIGHN+1日内最高价的最高值
DDD赋值:上次CCCC距今天数
GDTS赋值:如果CCCC,返回到最后交易的周期,否则返回0
DINGBU赋值:如果DDD,返回DDD日前的最高价,否则返回最高价
DINGBUTS赋值:如果DDD,返回DDD日前的GDTS,否则返回GDTS
DINGBU1赋值:DDD+1日前的DINGBU
GDCS1赋值:DINGBUTS的最后一日取值设为常数
DINGBUTS1赋值:DDD+1日前的DINGBUTS
GDCS2赋值:DINGBUTS1的最后一日取值设为常数
输出高点压力:当满足条件到最后交易的周期=GDCS2时,在最高价位置画直线起点,当满足条件到最后交易的周期=GDCS1时,在最高价位置画直线终点,1表示是否延长. 画绿色,线宽为2
AAA1赋值:LOWN日前的最低价=2*LOWN+1日内最低价的最低值
QY1赋值:若AAA1则将最近LOWN+1周期置为1
CC1赋值:QY1的LOWN日过滤 AND 最低价=LOWN+1日内最低价的最低值
DD1赋值:上次CC1距今天数
DDTS赋值:如果CC1,返回到最后交易的周期,否则返回0
YDB赋值:如果DD1,返回DD1日前的最低价,否则返回最低价
DDTS1赋值:如果DD1,返回DD1日前的DDTS,否则返回DDTS
DDCS1赋值:DDTS1的最后一日取值设为常数
ZDB赋值:DD1+1日前的YDB
DDTS2赋值:DD1+1日前的DDTS1
DDCS2赋值:DDTS2的最后一日取值设为常数
输出低点支撑:当满足条件到最后交易的周期=DDCS2时,在最低价位置画直线起点,当满足条件到最后交易的周期=DDCS1时,在最低价位置画直线终点,1表示是否延长. 画红色,线宽为2
A1赋值:8日前的最高价=2*8+1日内最高价的最高值
BB1赋值:A1的8日过滤
CCC1赋值:若BB1则将最近8+1周期置为1
D1赋值:CCC1的8日过滤
R11赋值:若是否最后一个周期则将最近上次D1距今天数+1周期置为1
S11赋值:R11>1日前的R11
当满足条件D1时,在最高价位置画直线起点,当满足条件S11时,在最高价位置画直线终点,1表示是否延长.,画淡绿色
A22赋值:8日前的最低价=2*8+1日内最低价的最低值
B22赋值:A22的8日过滤
C22赋值:若B22则将最近8+1周期置为1
D2赋值:C22的8日过滤
MMM赋值:3*8/5的整数部分
A12赋值:MMM日前的最高价=2*MMM+1日内最高价的最高值
B12赋值:A12的MMM日过滤
C12赋值:若B12则将最近MMM+1周期置为1
D12赋值:C12的MMM日过滤
R112赋值:若是否最后一个周期则将最近上次D12距今天数+1周期置为1
S112赋值:R112>1日前的R112
当满足条件D12时,在最高价位置画直线起点,当满足条件S112时,在最高价位置画直线终点,1表示是否延长.,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1RRQwtxleXrvtJNek7AisZg

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复