请选择 进入手机版|继续访问电脑版

撑压布林指标 通达信 主图 BOLL指标 无未来函数 操盘控盘 压力支撑

[复制链接]

admin  管理员

发表于 6 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: BOLL指标 无未来函数 操盘控盘 压力支撑 
撑压布林指标 通达信 主图 BOLL指标 无未来函数 操盘控盘 压力支撑 炒股叉第11381张

撑压布林指标 通达信 主图 BOLL指标 无未来函数 操盘控盘 压力支撑 炒股叉第11382张

[lywrap=通达信主图指标公式][lycode=tdx,true]P:=3;
N:=POW(2,P);
FF:=CONST(REF(C,1));
AA:=IF((FF < 100),FF,(FF / 100));
A:=INTPART(((N * (LOG(AA) / LOG(2))) + 1));
Y1:=(A/N);
Y2:=((A+1 ) / N);
Y3:=((A+2 ) / N);
Z1:=((A-1) / N);{第一个支撑}
Z2:=((A-2) / N);
Z3:=((A-3) / N);
ZC1:=IF((FF > 100),(POW(2,Z1) * 100),POW(2,Z1));
ZC2:=IF((FF > 100),(POW(2,Z2) * 100),POW(2,Z2));
ZC3:=IF((FF > 100),(POW(2,Z3) * 100),POW(2,Z3));
YL1:=IF((FF > 100),(POW(2,Y1) * 100),POW(2,Y1));
YL2:=IF((FF > 100),(POW(2,Y2) * 100),POW(2,Y2));
YL3:=IF((FF > 100),(POW(2,Y3) * 100),POW(2,Y3));
支撑一:IF(CURRBARSCOUNT<=50,ZC1,DRAWNULL),COLOR00F24F;
支撑二:IF(CURRBARSCOUNT<=50,ZC2,DRAWNULL),COLORWHITE,POINTDOT,LINETHICK4;
{支撑三:IF(CURRBARSCOUNT<=50,ZC3,DRAWNULL),COLORWHITE,POINTDOT;}
压力一:IF(CURRBARSCOUNT<=50,YL1,DRAWNULL),COLOR05DDFC;
压力二:IF(CURRBARSCOUNT<=50,YL2,DRAWNULL),COLORWHITE,POINTDOT,LINETHICK4;
{压力三:IF(CURRBARSCOUNT<=50,YL3,DRAWNULL),COLORWHITE,POINTDOT;}
均价线:=AMOUNT/V/100;
C2:=REF(C,1);
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2  AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线  AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线  AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
STICKLINE(PP2 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
STICKLINE(PP AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
STICKLINE(PP3 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
A8:=SMA(L,4,3) ;
STICKLINE(A8 AND REF(PP,1) AND HH ,A8*0.9999,A8*0.9979,5,0);
DRAWICON(A8 AND REF(PP,1) AND HH,L*0.98,1);
STICKLINE(A8 AND REF(PP3,1) AND HH ,A8*0.9999,A8*0.9979,5,0);
DRAWICON(A8 AND REF(PP3,1) AND HH,L*0.98,1);
HD:=COUNT(涨停,21)>=1;
A1:=SMA(H,4,3);
STICKLINE(A1 AND HD ,A1,A1*1.001,0.3,0);
ZT:=C/REF(C,1)>1.097;
DRAWTEXT(ZT,L*0.98,'涨停'),COLORGRAY;
VARZT:=BARSLAST(C/REF(C,1)>1.097);
STICKLINE(VARZT=2,L*0.97,L*0.98,3.5,0),COLOR0000FF;
DRAWTEXT(VARZT=2,L*0.95,'3'),COLORYELLOW;
STICKLINE(VARZT=4,H*1.03,H*1.02,3.5,0),COLOR9966FF;
DRAWTEXT(VARZT=4,H*1.06,'5'),COLORYELLOW;
STICKLINE(VARZT=7,L*0.97,L*0.98,3.5,0),COLOR00FFFF;
DRAWTEXT(VARZT=7,L*0.95,'8'),COLORYELLOW;
STICKLINE(VARZT=12,H*1.03,H*1.02,3.5,0),COLORFF33FF;
DRAWTEXT(VARZT=12,H*1.06,'13'),COLORYELLOW;
MA9.98:=MA(CLOSE,9.98);
{UPPER:MA9.98+3*STD(CLOSE,9.98),,COLORFF9900;
LOWER:MA9.98-3*STD(CLOSE,9.98),,COLORYELLOW;}
STICKLINE(CLOSE>=OPEN AND CLOSE>=MA9.98,OPEN,CLOSE,2,0),COLOR000077;
STICKLINE(CLOSE>=OPEN AND CLOSE>=MA9.98,H,L,0,0),COLOR000077;
STICKLINE(OPEN>CLOSE AND CLOSE>=MA9.98,OPEN,CLOSE,2,0),COLOR777700;
STICKLINE(OPEN>CLOSE AND CLOSE>=MA9.98,H,L,0,0),COLOR777700;
STICKLINE(CROSS(CLOSE,MA9.98),CLOSE,OPEN,0.5,0),COLOR0080FF;
AAW:MA9.98,COLORFFAA00;
IF(AAW>REF(AAW,1),MA9.98,DRAWNULL),COLORRED;
天60:MA(CLOSE,60),LINETHICK2,COLORE6E8FA;
攻防价位:(REF((H-L)*0.618+L,1)),NODRAW,COLORYELLOW;
STICKLINE(ISLASTBAR,攻防价位-0.01,攻防价位,6,0),COLORYELLOW;
C幼马:=CROSS(C,MA(C,25));
DRAWTEXT(C幼马 ,L,'*潜'),COLORYELLOW;
C操盘线:=CROSS(C,EMA(C,144));
DRAWTEXT(C操盘线,L,'*CP'),COLORF0F000;
九号线99:MA(CLOSE,99),COLORGREEN,LINETHICK2;
MA7:=EMA(CLOSE,7),COLORRED,LINETHICK2;
MID:=MA(CLOSE,20),COLORYELLOW,LINETHICK2;
{UPR:MID+2*STD(CLOSE,20),COLORRED,DOTLINE;
LOR:=MID-2*STD(CLOSE,20),COLORGREEN,DOTLINE;
STICKLINE(ISLASTBAR,HHV(C,5),HHV(C,5),218,1)COLORBLUE;
STICKLINE(ISLASTBAR,HHV(C,5)*0.97,HHV(C,5)*0.97,218,1)COLORRED;}
AAAA:=BARSLAST(CROSS(EMA(C,8),EMA(C,3)) AND C>MA(C,25));

DRAWTEXT(C操盘线,L,'*CP'),COLORF0F000;
小秘密:=CROSS(BB,AAAA);
DRAWTEXT(小秘密,L-0.15,'跟进'),COLORF00FF0;

MA1:=MA(CLOSE,5);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
TJ1:=BARSLAST(CROSS(DIF,DEA));
TJ2:=REF(H,TJ1);
{IF(TJ1<30,TJ2,DRAWNULL),COLORGREEN,LINETHICK1;
IF(CROSS(DIF,DEA),H*1.005,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK;}
STICKLINE(CROSS(DIF,DEA),H*1.0005,H*0.9995,100,0),COLORBLUE;
MA2:=MA(CLOSE,9),LINETHICK2;
MA3:=MA(CLOSE,14),LINETHICK2;
条件:=CROSS(MA2,INDEXC) AND MA3>REF(MA3,1) AND MA1<REF(MA1,1);
DRAWTEXT(条件,H*1.015,'↙大跌开始');[/lycode][lycode=tdx2,true]P赋值:3
N赋值:2的P乘幂
FF赋值:1日前的收盘价的最后一日取值设为常数
AA赋值:如果(FF<100),返回FF,否则返回(FF/100)
A赋值:((N*(AA的对数/2的对数))+1)的整数部分
Y1赋值:(A/N)
Y2赋值:((A+1 ) / N)
Y3赋值:((A+2 ) / N)
Z1赋值:((A-1) / N)
Z2赋值:((A-2) / N)
Z3赋值:((A-3) / N)
ZC1赋值:如果(FF>100),返回(2的Z1乘幂*100),否则返回2的Z1乘幂
ZC2赋值:如果(FF>100),返回(2的Z2乘幂*100),否则返回2的Z2乘幂
ZC3赋值:如果(FF>100),返回(2的Z3乘幂*100),否则返回2的Z3乘幂
YL1赋值:如果(FF>100),返回(2的Y1乘幂*100),否则返回2的Y1乘幂
YL2赋值:如果(FF>100),返回(2的Y2乘幂*100),否则返回2的Y2乘幂
YL3赋值:如果(FF>100),返回(2的Y3乘幂*100),否则返回2的Y3乘幂
输出支撑一:如果到最后交易的周期<=50,返回ZC1,否则返回无效数,COLOR00F24F
输出支撑二:如果到最后交易的周期<=50,返回ZC2,否则返回无效数,画白色,POINTDOT,线宽为4
输出压力一:如果到最后交易的周期<=50,返回YL1,否则返回无效数,COLOR05DDFC
输出压力二:如果到最后交易的周期<=50,返回YL2,否则返回无效数,画白色,POINTDOT,线宽为4
均价线赋值:成交额(元)/成交量(手)/100
C2赋值:1日前的收盘价
涨停赋值:如果1日前的收盘价*1.1-收盘价<0.01,返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为4,0不为0则画空心柱.,画红色
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色
支撑线赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4
LC赋值:1日前的收盘价
操作线赋值:收盘价-LC和0的较大值的2日[1日权重]移动平均/收盘价-LC的绝对值的2日[1日权重]移动平均*100
趋势线赋值:收盘价-LC和0的较大值的14日[1日权重]移动平均/收盘价-LC的绝对值的14日[1日权重]移动平均*100
震仓线赋值:45
震仓线2赋值:50
逃命线赋值:80
抄底线赋值:20
绝底线赋值:5
PP2赋值:操作线<震仓线2  AND 1日前的操作线>震仓线2
PP赋值:操作线<震仓线  AND 1日前的操作线>震仓线
PP3赋值:操作线<抄底线  AND 1日前的操作线>抄底线
HH赋值:统计13日中满足涨停的天数>=1
当满足条件PP2ANDHH时,在开盘价和收盘价位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,画蓝色
当满足条件PPANDHH时,在开盘价和收盘价位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,画蓝色
当满足条件PP3ANDHH时,在开盘价和收盘价位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,画蓝色
A8赋值:最低价的4日[3日权重]移动平均
当满足条件A8ANDREF(PP,1)ANDHH时,在A8*0.9999和A8*0.9979位置之间画柱状线,宽度为5,0不为0则画空心柱.
当满足条件A8ANDREF(PP,1)ANDHH时,在最低价*0.98位置画1号图标
当满足条件A8ANDREF(PP3,1)ANDHH时,在A8*0.9999和A8*0.9979位置之间画柱状线,宽度为5,0不为0则画空心柱.
当满足条件A8ANDREF(PP3,1)ANDHH时,在最低价*0.98位置画1号图标
HD赋值:统计21日中满足涨停的天数>=1
A1赋值:最高价的4日[3日权重]移动平均
当满足条件A1ANDHD时,在A1和A1*1.001位置之间画柱状线,宽度为0.3,0不为0则画空心柱.
ZT赋值:收盘价/1日前的收盘价>1.097
当满足条件ZT时,在最低价*0.98位置书写文字,画深灰色
VARZT赋值:上次收盘价/1日前的收盘价>1.097距今天数
当满足条件VARZT=2时,在最低价*0.97和最低价*0.98位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR0000FF
当满足条件VARZT=2时,在最低价*0.95位置书写文字,画黄色
当满足条件VARZT=4时,在最高价*1.03和最高价*1.02位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR9966FF
当满足条件VARZT=4时,在最高价*1.06位置书写文字,画黄色
当满足条件VARZT=7时,在最低价*0.97和最低价*0.98位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR00FFFF
当满足条件VARZT=7时,在最低价*0.95位置书写文字,画黄色
当满足条件VARZT=12时,在最高价*1.03和最高价*1.02位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLORFF33FF
当满足条件VARZT=12时,在最高价*1.06位置书写文字,画黄色
98赋值:[变量名错误]收盘价的9.98日简单移动平均
当满足条件收盘价>=OPENANDCLOSE>=MA9.98时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000077
当满足条件收盘价>=OPENANDCLOSE>=MA9.98时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR000077
当满足条件开盘价>CLOSEANDCLOSE>=MA9.98时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR777700
当满足条件开盘价>CLOSEANDCLOSE>=MA9.98时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR777700
当满足条件收盘价上穿MA9.98时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0080FF
输出AAW:MA9.98,COLORFFAA00
如果AAW>1日前的AAW,返回MA9.98,否则返回无效数,画红色
输出天60:收盘价的60日简单移动平均,线宽为2,COLORE6E8FA
输出攻防价位:(1日前的(最高价-最低价)*0.618+最低价),NODRAW,画黄色
当满足条件是否最后一个周期时,在攻防价位-0.01和攻防价位位置之间画柱状线,宽度为6,0不为0则画空心柱.,画黄色
C幼马赋值:收盘价上穿收盘价的25日简单移动平均
当满足条件C幼马时,在最低价位置书写文字,画黄色
C操盘线赋值:收盘价上穿收盘价的144日指数移动平均
当满足条件C操盘线时,在最低价位置书写文字,COLORF0F000
输出九号线99:收盘价的99日简单移动平均,画绿色,线宽为2
MA7赋值:收盘价的7日指数移动平均,画红色,线宽为2
MID赋值:收盘价的20日简单移动平均,画黄色,线宽为2
AAAA赋值:上次收盘价的8日指数移动平均上穿收盘价的3日指数移动平均ANDC>收盘价的25日简单移动平均距今天数
当满足条件C操盘线时,在最低价位置书写文字,COLORF0F000
小秘密赋值:布林极限上穿AAAA
当满足条件小秘密时,在最低价-0.15位置书写文字,COLORF00FF0
MA1赋值:收盘价的5日简单移动平均
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
TJ1赋值:上次DIF上穿DEA距今天数
TJ2赋值:TJ1日前的最高价
当满足条件DIF上穿DEA时,在最高价*1.0005和最高价*0.9995位置之间画柱状线,宽度为100,0不为0则画空心柱.,画蓝色
MA2赋值:收盘价的9日简单移动平均,线宽为2
MA3赋值:收盘价的14日简单移动平均,线宽为2
条件赋值:MA2上穿大盘的收盘价 AND MA3>1日前的MA3 AND MA1<1日前的MA1
当满足条件条件时,在最高价*1.015位置书写文字[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/13uahzyVq0mYUxwPO7f66vQ

看了该指标的人还看了:
买卖提示指标    堪称一绝指标
缠论108课公式最终版本    高价金钻指标寻龙诀

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表