请选择 进入手机版|继续访问电脑版

五彩乘与开方指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 6 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
五彩乘与开方指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第11375张

五彩乘与开方指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第11376张

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=9;
M:=21;
今日保护价:(REF(C,1)+REF(C,2)+O)/3,NODRAW;
GD1:=HHV(HIGH,N);
DD1:=LLV(LOW,N);
XJ1:=GD1*DD1;
KF1:=SQRT(XJ1),COLORGREEN,LINETHICK3;
GD2:=HHV(HIGH,M);
DD2:=LLV(LOW,M);
XJ2:=GD2*DD2;
KF2:=SQRT(XJ2),COLORFFFF00,LINETHICK3;
QSX1:KF1,COLOR00FFFF,LINETHICK3;
QSX2:KF2,COLORFFFF00,LINETHICK3;
DRAWBAND(QSX1,RGB(208,50,90),QSX2,RGB(110,130,160));
AA:=QSX1>=QSX2 AND C>=QSX1;
BB:=QSX1>=QSX2 AND (C>=QSX2 AND C<QSX1);
DD:=QSX1>=QSX2 AND C<QSX2;
EE:=QSX1<QSX2 AND C>=QSX1;
FF:=QSX1<QSX2 AND C<QSX1;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,H,L,0,0),COLORFF00FF;
STICKLINE(DD,H,L,0,0),COLOR66CCFF;
STICKLINE(EE,H,L,0,0),COLORFFFF00;
STICKLINE(FF,H,L,0,0),COLORAFD788;
STICKLINE(AA,CLOSE,OPEN,3.2,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.6,0),COLOR0000AA;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.8,0),COLOR0000DD;
STICKLINE(AA,CLOSE,OPEN,1.3,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,3.2,0),COLOR990099;
STICKLINE(BB,CLOSE,OPEN,2.6,0),COLORAA00AA;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORBB00BB;
STICKLINE(BB,CLOSE,OPEN,1.8,0),COLORDD00DD;
STICKLINE(BB,CLOSE,OPEN,1.3,0),COLOREE00EE;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORFF00FF;
STICKLINE(DD,C,O,3.4,0),COLOR225588;
STICKLINE(DD,C,O,3.0,0),COLOR3377AA;
STICKLINE(DD,C,O,2.4,0),COLOR3388BB;
STICKLINE(DD,C,O,1.6,0),COLOR44AADD;
STICKLINE(DD,C,O,1.0,0),COLOR55BBEE;
STICKLINE(DD,C,O,0.6,0),COLOR66CCFF;
STICKLINE(EE,C,O,3.4,0),COLOR888800;
STICKLINE(EE,C,O,3.0,0),COLOR999900;
STICKLINE(EE,C,O,2.4,0),COLORAAAA00;
STICKLINE(EE,C,O,1.6,0),COLORCCCC00;
STICKLINE(EE,C,O,1.0,0),COLORDDDD00;
STICKLINE(EE,C,O,0.5,0),COLORFFFF00;
STICKLINE(FF,CLOSE,OPEN,3.4,0),COLOR367517;
STICKLINE(FF,CLOSE,OPEN,2.6,0),COLOR489620;
STICKLINE(FF,CLOSE,OPEN,2.2,0),COLOR50A625;
STICKLINE(FF,CLOSE,OPEN,1.8,0),COLOR5BBD2B;
STICKLINE(FF,CLOSE,OPEN,1.3,0),COLOR83C75D;
STICKLINE(FF,CLOSE,OPEN,0.5,0),COLORAFD788;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
CCIA:=EMA(EMA(EMA(CCI,2),2),2);
CCIB:=EMA(EMA(EMA(CCI,3),2),2);
X:=(CROSS(CCIA,CCIB) OR (CCIA>=CCIB))
AND CCIA>=-101 AND CCIA>=REF(CCIA,1)
AND REF(CCIA,1)<-101 ;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
K1:= EMA(EMA(EMA(K,2),2),2);
D1:= EMA(EMA(EMA(D,2),2),2);
J1:= EMA(EMA(EMA(J,2),2),2);
Y:= J1>REF(J1,1) ;
YJ:=X AND Y  ;
DRAWICON(YJ,(LOW * 0.98),13);
DRAWTEXT(YJ,(LOW * 0.97),'买'),COLORYELLOW;
LC5:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC5,0),6,1)/SMA(ABS(CLOSE-LC5),6,1)*100;
R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(B/2+40)*1.1;
DA:=SMA(CCC,3,1);
DRAWICON(CROSS(DA,RSI5),H*1.04,15);
DRAWTEXT(CROSS(DA,RSI5),H*1.05,'↙短逃');
DRAWICON(CROSS(80,RSI5),H*1.07,14);
DRAWTEXT(CROSS(80,RSI5),H*1.09,'↙短逃');
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
周15:=FILTER(CROSS(80,RSI1) AND RSI1<REF(RSI1,1),8);
DRAWICON(周15,H*1.12,35);
DRAWTEXT(CROSS(80,RSI5),H*1.11,'↙逃顶');[/lycode][lycode=tdx2,true]N赋值:9
M赋值:21
输出今日保护价:(1日前的收盘价+2日前的收盘价+开盘价)/3,NODRAW
GD1赋值:N日内最高价的最高值
DD1赋值:N日内最低价的最低值
XJ1赋值:GD1*DD1
KF1赋值:XJ1的开方,画绿色,线宽为3
GD2赋值:M日内最高价的最高值
DD2赋值:M日内最低价的最低值
XJ2赋值:GD2*DD2
KF2赋值:XJ2的开方,COLORFFFF00,线宽为3
输出QSX1:KF1,COLOR00FFFF,线宽为3
输出QSX2:KF2,COLORFFFF00,线宽为3
画带状线
AA赋值:QSX1>=QSX2 AND 收盘价>=QSX1
BB赋值:QSX1>=QSX2 AND (收盘价>=QSX2 AND 收盘价<QSX1)
DD赋值:QSX1>=QSX2 AND 收盘价<QSX2
EE赋值:QSX1<QSX2 AND 收盘价>=QSX1
FF赋值:QSX1<QSX2 AND 收盘价<QSX1
当满足条件AA时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件BB时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF00FF
当满足条件DD时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR66CCFF
当满足条件EE时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFFF00
当满足条件FF时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORAFD788
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLOR000099
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLOR0000AA
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR0000CC
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR0000DD
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR0000FF
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORCC66FF
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLOR990099
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLORAA00AA
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLORBB00BB
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLORDD00DD
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOREE00EE
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFF00FF
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为3.4,0不为0则画空心柱.,COLOR225588
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为3.0,0不为0则画空心柱.,COLOR3377AA
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为2.4,0不为0则画空心柱.,COLOR3388BB
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为1.6,0不为0则画空心柱.,COLOR44AADD
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLOR55BBEE
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为0.6,0不为0则画空心柱.,COLOR66CCFF
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为3.4,0不为0则画空心柱.,COLOR888800
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为3.0,0不为0则画空心柱.,COLOR999900
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为2.4,0不为0则画空心柱.,COLORAAAA00
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为1.6,0不为0则画空心柱.,COLORCCCC00
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLORDDDD00
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFFF00
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为3.4,0不为0则画空心柱.,COLOR367517
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLOR489620
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR50A625
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR5BBD2B
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR83C75D
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORAFD788
TYP赋值:(最高价+最低价+收盘价)/3
CCI赋值:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差)
CCIA赋值:CCI的2日指数移动平均的2日指数移动平均的2日指数移动平均
CCIB赋值:CCI的3日指数移动平均的2日指数移动平均的2日指数移动平均
X赋值:(CCIA上穿CCIB OR (CCIA>=CCIB))AND CCIA>=-101 AND CCIA>=1日前的CCIAAND 1日前的CCIA<-101
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
K1赋值: K的2日指数移动平均的2日指数移动平均的2日指数移动平均
D1赋值: D的2日指数移动平均的2日指数移动平均的2日指数移动平均
J1赋值: J的2日指数移动平均的2日指数移动平均的2日指数移动平均
Y赋值: J1>1日前的J1
YJ赋值:X AND Y  
当满足条件YJ时,在(最低价*0.98)位置画13号图标
当满足条件YJ时,在(最低价*0.97)位置书写文字,画黄色
LC5赋值:1日前的收盘价
RSI5赋值:收盘价-LC5和0的较大值的6日[1日权重]移动平均/收盘价-LC5的绝对值的6日[1日权重]移动平均*100
R赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
A赋值:R的3日[1日权重]移动平均
B赋值:A的3日[1日权重]移动平均
CCC赋值:(B/2+40)*1.1
DA赋值:CCC的3日[1日权重]移动平均
当满足条件DA上穿RSI5时,在最高价*1.04位置画15号图标
当满足条件DA上穿RSI5时,在最高价*1.05位置书写文字
当满足条件80上穿RSI5时,在最高价*1.07位置画14号图标
当满足条件80上穿RSI5时,在最高价*1.09位置书写文字
LC赋值:1日前的收盘价
RSI1赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
周15赋值:80上穿RSI1ANDRSI1<1日前的RSI1的8日过滤
当满足条件周15时,在最高价*1.12位置画35号图标
当满足条件80上穿RSI5时,在最高价*1.11位置书写文字[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1ammh_upKN8dAr0xQiEt5SQ

看了该指标的人还看了:
减仓逃顶指标    买卖点指标
持股待涨指标    趋势通道指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表