请选择 进入手机版|继续访问电脑版

K线重心指标 通达信 主图 无未来函数 操盘控盘

[复制链接]

admin  管理员

发表于 6 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 无未来函数 操盘控盘 
K线重心指标 通达信 主图 无未来函数 操盘控盘 炒股叉第11371张

K线重心指标 通达信 主图 无未来函数 操盘控盘 炒股叉第11372张

[lywrap=通达信主图指标公式][lycode=tdx,true]K线重心:AMOUNT/VOL/100,COLORYELLOW,LINETHICK2;
收盘:C,COLORRED;
最低:L,COLORWHITE;
最高:H,COLORC6C600;
VB1:=INDEXO;
VB2:=K线重心*1.1;
VB3:=IF(VB1=0,VB2,REF(K线重心,1)*1.1);
VB4:=(VB2+VB3)/2;
VB5:=K线重心*0.9;
VB6:=IF(VB1=0,VB5,REF(K线重心,1)*0.9);
VB7:=(VB5+VB6)/2;
VB8:=EMA(VB4,13);
VB9:=EMA(VB7,13);
K线重心通道上:FORCAST(VB8,13),COLORMAGENTA,LINETHICK2;
K线重心通道下:FORCAST(VB9,13),COLORGREEN,LINETHICK2;
长度:=IF((O = REF(C,1)),(C-O),(IF((O > REF(C,1)) AND (C>O),C-REF(C,1),(IF((O > REF(C,1)) AND (C < REF(C,1)) ,(O - C),(IF((O > REF(C,1)) AND (C > REF(C,1)) ,O - REF(C,1),(IF((O < REF(C,1)) AND (C < O),(C - REF(C,1)),(IF((O < REF(C,1)) AND (C < REF(C,1)) AND (C > O),(O - REF(C,1)),(IF((O < REF(C,1)) AND (C > REF(C,1)),(C-O),((C - REF(C,1))))))))))))))));
重心:=REF(C,1)+长度/2;
STICKLINE(重心>0,重心+0.01,重心-0.01,2,0),COLORFF0080;
选股:=CROSS(C,K线重心) AND 最高>REF(最高,1);
DRAWICON(选股,L*0.98,1);[/lycode][lycode=tdx2,true]输出K线重心:成交额(元)/成交量(手)/100,画黄色,线宽为2
输出收盘:收盘价,画红色
输出最低:最低价,画白色
输出最高:最高价,COLORC6C600
VB1赋值:大盘的开盘价
VB2赋值:K线重心*1.1
VB3赋值:如果VB1=0,返回VB2,否则返回1日前的K线重心*1.1
VB4赋值:(VB2+VB3)/2
VB5赋值:K线重心*0.9
VB6赋值:如果VB1=0,返回VB5,否则返回1日前的K线重心*0.9
VB7赋值:(VB5+VB6)/2
VB8赋值:VB4的13日指数移动平均
VB9赋值:VB7的13日指数移动平均
输出K线重心通道上:VB8的13日线性回归预测值,画洋红色,线宽为2
输出K线重心通道下:VB9的13日线性回归预测值,画绿色,线宽为2
长度赋值:如果(开盘价=1日前的收盘价),返回(收盘价-开盘价),否则返回(如果(开盘价>1日前的收盘价)AND(收阳线),返回收盘价-1日前的收盘价,否则返回(如果(开盘价>1日前的收盘价)AND(收盘价<1日前的收盘价),返回(开盘价-收盘价),否则返回(如果(开盘价>1日前的收盘价)AND(收盘价>1日前的收盘价),返回开盘价-1日前的收盘价,否则返回(如果(开盘价<1日前的收盘价)AND(收阴线),返回(收盘价-1日前的收盘价),否则返回(如果?,返回?,否则返回?
重心赋值:1日前的收盘价+长度/2
当满足条件重心>0时,在重心+0.01和重心-0.01位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFF0080
选股赋值:收盘价上穿K线重心 AND 最高>1日前的最高
当满足条件选股时,在最低价*0.98位置画1号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1mDg5cJwLLfWo6ALbWPjRtg

看了该指标的人还看了:
准确买卖指标    成交量判断趋势指标
底部警戒指标    金钱摸鬼指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表