请选择 进入手机版|继续访问电脑版

趋势通道指标 通达信 主图 波段 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 6 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 操盘控盘 
趋势通道指标 通达信 主图 波段 短线 买卖点 操盘控盘 炒股叉第11369张

趋势通道指标 通达信 主图 波段 短线 买卖点 操盘控盘 炒股叉第11370张

[lywrap=通达信主图指标公式][lycode=tdx,true]AA:=1;
MID:EMA(CLOSE,17)*AA,LINETHICK1,COLORFFFFFF;
UPPER:MID+2*STD(CLOSE,17),LINETHICK2,COLORYELLOW;
LOWER:MID-2*STD(CLOSE,17),LINETHICK2,COLORLIRED;
UPPERO:MID+3*STD(CLOSE,17),LINETHICK1,COLORCYAN;
LOWERO:MID-3*STD(CLOSE,17),LINETHICK1,COLORMAGENTA;
LOCK:=IF(TIME<1160101,1,0);
VARA:=MA(CLOSE,20);
VAR1:IF(VARA>REF(VARA,2),VARA,IF(VARA<REF(VARA,2),VARA,VARA)),COLOR00FF00;
IF(VARA>REF(VARA,2),VARA,DRAWNULL),LINETHICK2,COLORFF00FF;
IF(VARA=REF(VARA,2),VARA,DRAWNULL),LINETHICK2,COLORFF0000;
IF(VARA<REF(VARA,2),VARA,DRAWNULL),LINETHICK2,COLOR00FF00;
买入:IF(VARA>REF(VARA,2) AND REF(VARA<=REF(VARA,2),1),1,0),NODRAW,COLORAAAAAA;
{DRAWICON(CROSS(LOW,LOWERO),LOWERO*0.96,'红宝石');
DRAWICON(CROSS(HIGH,UPPERO),HIGH,'绿宝石');}
TY:=CLOSE;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
A:=REF(CLOSE,BARSLAST(HD)); B:=REF(CLOSE,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(T1,A,A),COLORFF00FF,POINTDOT;
STICKLINE(T1,A,A,1.5,0),COLORFF00FF;

波谷:IF(T2,B,B),COLOR80FF00,POINTDOT;
STICKLINE(T2,B,B,1.5,0),COLOR80FF00;


买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,26)*15+C,45);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWBMP(BU,L*0.998,'B');
DRAWBMP(SEL,H*1.018,'S');

STICKLINE(ISLASTBAR,HHV(C,5),HHV(C,5),218,1)COLORLIMAGENTA,LINETHICK2;
STICKLINE(ISLASTBAR,HHV(C,5)*0.95,HHV(C,5)*0.95,218,1)COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,HHV(C,5)*0.95,'止损价位'),COLORWHITE;


日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),COLORYELLOW;
二0.618:REFDATE(H2,DATE),COLORMAGENTA;
三0.500:REFDATE(H3,DATE),COLORWHITE;
四0.382:REFDATE(H4,DATE),COLORGREEN;
五0.191:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED;[/lycode][lycode=tdx2,true]AA赋值:1
输出MID:收盘价的17日指数移动平均*AA,线宽为1,COLORFFFFFF
输出UPPER:MID+2*收盘价的17日估算标准差,线宽为2,画黄色
输出LOWER:MID-2*收盘价的17日估算标准差,线宽为2,画淡红色
输出UPPERO:MID+3*收盘价的17日估算标准差,线宽为1,画青色
输出LOWERO:MID-3*收盘价的17日估算标准差,线宽为1,画洋红色
LOCK赋值:如果时间(时分)<1160101,返回1,否则返回0
VARA赋值:收盘价的20日简单移动平均
输出VAR1:如果VARA>2日前的VARA,返回VARA,否则返回如果VARA<2日前的VARA,返回VARA,否则返回VARA,COLOR00FF00
如果VARA>2日前的VARA,返回VARA,否则返回无效数,线宽为2,COLORFF00FF
如果VARA=2日前的VARA,返回VARA,否则返回无效数,线宽为2,COLORFF0000
如果VARA<2日前的VARA,返回VARA,否则返回无效数,线宽为2,COLOR00FF00
输出买入:如果VARA>2日前的VARAANDREF(VARA<=2日前的VARA,1),返回1,否则返回0,NODRAW,COLORAAAAAA
TY赋值:收盘价
A1赋值:10日前的TY=2*10+1日内TY的最高值
B1赋值:A1的10日过滤
C1赋值:若B1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:A2的10日过滤
C2赋值:若B2则将最近10+1周期置为1
LD赋值:C2的10日过滤
A赋值:上次HD距今天数日前的收盘价
B赋值:上次LD距今天数日前的收盘价
T1赋值:上次HD距今天数<上次LD距今天数 AND 取反
T2赋值:上次HD距今天数>上次LD距今天数 AND 取反
输出波峰:如果T1,返回A,否则返回A,COLORFF00FF,POINTDOT
当满足条件T1时,在A和A位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF00FF
输出波谷:如果T2,返回B,否则返回B,COLOR80FF00,POINTDOT
当满足条件T2时,在B和B位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR80FF00
买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的26日线性回归斜率*15+收盘价的45日指数移动平均
BU赋值:买线上穿卖线
SEL赋值:卖线上穿买线
画图片
画图片
当满足条件是否最后一个周期时,在5日内收盘价的最高值和5日内收盘价的最高值位置之间画柱状线,宽度为218,1不为0则画空心柱.画淡洋红色,线宽为2
当满足条件是否最后一个周期时,在5日内收盘价的最高值*0.95和5日内收盘价的最高值*0.95位置之间画柱状线,宽度为218,1不为0则画空心柱.画红色,线宽为2
当满足条件是否最后一个周期时,在5日内收盘价的最高值*0.95位置书写文字,画白色
日赋值:150
昨前赋值:3
高1赋值:昨前日前的日日内最高价的最高值
低1赋值:昨前日前的日日内最低价的最低值
H1赋值:高1-(高1-低1)*0.191
H2赋值:高1-(高1-低1)*0.382
H3赋值:高1-(高1-低1)*0.5
H4赋值:高1-(高1-低1)*0.618
H5赋值:高1-(高1-低1)*0.809
输出顶:日期日高1,画红色
输出一0.809[输出名错误]:日期日H1,画黄色
输出二0.618[输出名错误]:日期日H2,画洋红色
输出三0.500[输出名错误]:日期日H3,画白色
输出四0.382[输出名错误]:日期日H4,画绿色
输出五0.191[输出名错误]:日期日H5,画黄色
输出低:日期日低1,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1SNsIIbqQK-C56UglP2_blQ

看了该指标的人还看了:
看色操作指标    牛气冲天指标
横扫天下指标    分析家操盘线指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表