请选择 进入手机版|继续访问电脑版

趋势合成指标 通达信 副图 波段 短线 买卖点 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 6 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 趋势 操盘控盘 
趋势合成指标 通达信 副图 波段 短线 买卖点 趋势 操盘控盘 炒股叉第11363张

趋势合成指标 通达信 副图 波段 短线 买卖点 趋势 操盘控盘 炒股叉第11364张

[lywrap=通达信副图指标公式][lycode=tdx,true]STICKLINE(C,0,90,6,0),COLOR002500;
获利盘:WINNER(C)*100,COLORFF88FF,NODRAW;
趋势:3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),,COLORFFFFFF,NODRAW;
ZZ:=趋势>REF(趋势,1);
{资金动能}
DIFF:=EMA(C,3)-EMA(C,8);
DEA:=EMA(DIFF,5);
MACD:=2*(DIFF-DEA);
动能:=((EMA(C,3)-EMA(C,8)))*100;
CCI:="CCI";
K:="KD.K";
RSI:="RSI";
BIAS:="BIAS";

A1:=(CCI+250)/5;
A2:=K*1.15;
A3:=RSI*1.25;
A4:=BIAS*7.14;
A5:=(动能+100)*0.5;
趋势合成:(趋势+获利盘+A1+A2+A3+A4+A5)/7,COLOR00AAFF,NODRAW;

Z1:=SMA(趋势合成,10,1);
Z2:=SMA(Z1,3,1);
Z3:=SMA(趋势合成,5,3);
DRAWBAND(Z1,RGB(225,0,0),Z2,RGB(0,122,255));
DRAWBAND(趋势合成,RGB(225,111,0),Z3,RGB(0,122,0));
{量价异动}
K1:=DVOL/1000000;
K2:=DCLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06,;
量异动:=K1>REF(V1,1)*1.6&&ZZ,;
停牌:=DYNAINFO(17)>0;
M1:=SUM(价异动,2)>0 AND 停牌;
M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
量价共振:FILTER(M1&&M2,3)*66,COLOR9000FF;

8,COLOR777777;
减仓:IF(CROSS(Z3,趋势合成) AND REF(趋势合成,1)>=70,75,80),COLORFFBB00;
沽空:IF(CROSS(Z3,趋势合成) AND REF(趋势合成,1)>=78,77,85),COLOR00FF00;
低吸:IF(FILTER(CROSS(趋势合成,Z3) AND REF(趋势,1)<=12 AND RSI>REF(RSI,1),3),18,0),COLOR00FFFF;

{背离}
LC:=REF(C,1);
RSI1:=(SMA(MAX((C-LC),0),3,1)/SMA(ABS((C-LC)),3,1))*100;
顶背:=CROSS(88,RSI1);
DRAWTEXT(顶背,趋势合成*1.2,'←顶背'),COLORFFFFFF;

XG:低吸=18,COLOR00CCFF,NODRAW;
年选股:SUM(XG,250),NODRAW,COLORFFFFFF;
四日3%:HHV(H,3)>REF(C,3)*1.03 AND REF(CROSS(XG,0.8),2),NODRAW,COLOR0000FF;
年成功:SUM(四日3%,250),NODRAW;
成功率:(年成功/年选股)*100,NODRAW,COLOR0000FF;
达标:IF(四日3%=1,-1,DRAWNULL),CIRCLEDOT COLOR0077FF,LINETHICK3;[/lycode][lycode=tdx2,true]当满足条件收盘价时,在0和90位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLOR002500
输出获利盘:以收盘价计算的获利盘比例*100,COLORFF88FF,NODRAW
输出趋势:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均,,COLORFFFFFF,NODRAW
ZZ赋值:趋势>1日前的趋势
DIFF赋值:收盘价的3日指数移动平均-收盘价的8日指数移动平均
DEA赋值:DIFF的5日指数移动平均
MACD赋值:2*(DIFF-DEA)
动能赋值:((收盘价的3日指数移动平均-收盘价的8日指数移动平均))*100
CCI赋值:"CCI"
K赋值:"随机指标KD的K"
RSI赋值:"RSI"
BIAS赋值:"BIAS"
A1赋值:(CCI+250)/5
A2赋值:K*1.15
A3赋值:RSI*1.25
A4赋值:BIAS*7.14
A5赋值:(动能+100)*0.5
输出趋势合成:(趋势+获利盘+A1+A2+A3+A4+A5)/7,COLOR00AAFF,NODRAW
Z1赋值:趋势合成的10日[1日权重]移动平均
Z2赋值:Z1的3日[1日权重]移动平均
Z3赋值:趋势合成的5日[3日权重]移动平均
画带状线
画带状线
K1赋值:不定周期成交量/1000000
K2赋值:不定周期收盘价
V1赋值:K1的5日指数移动平均
V2赋值:K2的5日指数移动平均
价异动赋值:K2>1日前的V2*1.06,
量异动赋值:K1>1日前的V1*1.6并且ZZ,
停牌赋值:量比>0
M1赋值:价异动的2日累和>0 AND 停牌
M2赋值:量异动的2日累和>0 AND 1日前的趋势<89
输出量价共振:M1并且M2的3日过滤*66,COLOR9000FF
8,COLOR777777
输出减仓:如果Z3上穿趋势合成ANDREF(趋势合成,1)>=70,返回75,否则返回80,COLORFFBB00
输出沽空:如果Z3上穿趋势合成ANDREF(趋势合成,1)>=78,返回77,否则返回85,COLOR00FF00
输出低吸:如果趋势合成上穿Z3ANDREF(趋势,1)<=12ANDRSI>1日前的RSI的3日过滤,返回18,否则返回0,COLOR00FFFF
LC赋值:1日前的收盘价
RSI1赋值:((收盘价-LC)和0的较大值的3日[1日权重]移动平均/(收盘价-LC)的绝对值的3日[1日权重]移动平均)*100
顶背赋值:88上穿RSI1
当满足条件顶背时,在趋势合成*1.2位置书写文字,COLORFFFFFF
输出XG:低吸=18,COLOR00CCFF,NODRAW
输出年选股:XG的250日累和,NODRAW,COLORFFFFFF
输出四日3%:3日内最高价的最高值>3日前的收盘价*1.03 AND 2日前的XG上穿0.8,NODRAW,COLOR0000FF
输出年成功:四日3%的250日累和,NODRAW
输出成功率:(年成功/年选股)*100,NODRAW,COLOR0000FF
输出达标:如果四日3%=1,返回-1,否则返回无效数,CIRCLEDOT COLOR0077FF,线宽为3[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1sMmGBfP1uuh1z4x5XHY98Q

看了该指标的人还看了:
牛逼买入指标    必胜客指标
五虎上将出征指标    牛起步指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表