请选择 进入手机版|继续访问电脑版

军团神剑指标 通达信 主图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-12-4 08:00:19 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
军团神剑指标 通达信 主图 波段 短线 买卖点 炒股叉第11319张

军团神剑指标 通达信 主图 波段 短线 买卖点 炒股叉第11320张

[lywrap=通达信主图指标公式][lycode=tdx,true]MA3:MA(CLOSE,3),COLOR9000F5;
MA18:MA(CLOSE,18),COLOR0099FF,LINETHICK2;
{融胜通道}
M10:=EMA(C,10);
融胜:=M10,COLORRED,LINETHICK2;
FF:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,FF);
高抛:(1+14/100)*DD,DOTLINE,COLORGREEN;
压力:(1+7/100)*DD,DOTLINE,COLORFFFF00;
支撑:(1-7/100)*DD,DOTLINE,COLORBLUE;
低吸:(1-14/100)*DD,DOTLINE,COLORRED;
中轨:(压力+支撑)/2,DOTLINE,COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,高抛,'高抛'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,压力,'压力'),COLORFFFF00;
DRAWTEXT(CURRBARSCOUNT=1,中轨,'中轨'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'支撑'),COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=1,低吸,'低吸'),COLORRED;
IF(MA3>=REF(MA3,1) AND MA3>支撑,MA3,DRAWNULL),COLORRED,LINETHICK4;
{【平均成本】}
平均成本:((COST(18)+COST(8))/2+COST(13))/2,COLORYELLOW,LINETHICK2;{本句含有未来函数COST,自己决定去留本句吧}
{【追+加+抛+出货】}
A:=(REF(EMA(CLOSE,5),1));
B:=CROSS(EMA(CLOSE,5),EMA(SLOPE(CLOSE,21)*20+CLOSE,42));
DRAWTEXT(B,LOW*0.995,'追'),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWTEXT(CROSS(J,D),LOW*0.98,'加'),COLOR00FFFF,LINETHICK2;
VAR29:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR2A:=SMA(VAR29,5,1);
VAR2B:=SMA(VAR2A,10,1);
VAR2C:=CROSS(VAR2B,VAR2A);
VAR2D:=VAR2B>80 OR VAR2A>80;
VAR2E:=VAR2C AND VAR2D;
VAR33:=HIGH;
VAR34:=LOW;
逃顶:=STICKLINE(VAR2E,VAR33,VAR34,4,0);
DRAWTEXT(CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),HIGH*1.01,'抛'),COLORGREEN;
X6:=REF(CLOSE,1);
X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);DRAWTEXT(X9,HIGH*1.03,'出货'),COLOR9000F5;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,3.15,0),COLOR337777;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,2.45,0),COLOR339999;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.75,0),COLOR33BBBB;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.05,0),COLOR33DDDD;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,0.35,0),COLOR33FFFF;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*0.99,'地量买点'),COLOR33FFFF;
DRAWTEXT(CROSS(88,RSI),(HIGH*1.01),'R背'),COLOR00FF00;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5);
VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,3.15,0),COLOR770077;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,2.45,0),COLOR990099;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.75,0),COLORBB00BB;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.05,0),COLORDD00DD;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,0.35,0),COLORFF00FF;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L*0.99,'吸'),COLORFF00FF;[/lycode][lycode=tdx2,true]输出MA3:收盘价的3日简单移动平均,COLOR9000F5
输出MA18:收盘价的18日简单移动平均,COLOR0099FF,线宽为2
M10赋值:收盘价的10日指数移动平均
融胜赋值:M10,画红色,线宽为2
FF赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
DD赋值:以FF为权重收盘价的动态移动平均
输出高抛:(1+14/100)*DD,DOTLINE,画绿色
输出压力:(1+7/100)*DD,DOTLINE,COLORFFFF00
输出支撑:(1-7/100)*DD,DOTLINE,画蓝色
输出低吸:(1-14/100)*DD,DOTLINE,画红色
输出中轨:(压力+支撑)/2,DOTLINE,画洋红色
当满足条件到最后交易的周期=1时,在高抛位置书写文字,画绿色
当满足条件到最后交易的周期=1时,在压力位置书写文字,COLORFFFF00
当满足条件到最后交易的周期=1时,在中轨位置书写文字,画洋红色
当满足条件到最后交易的周期=1时,在支撑位置书写文字,画蓝色
当满足条件到最后交易的周期=1时,在低吸位置书写文字,画红色
如果MA3>=1日前的MA3ANDMA3>支撑,返回MA3,否则返回无效数,画红色,线宽为4
输出平均成本:((获利盘为18%的成本分布+获利盘为8%的成本分布)/2+获利盘为13%的成本分布)/2,画黄色,线宽为2
A赋值:(1日前的收盘价的5日指数移动平均)
B赋值:收盘价的5日指数移动平均上穿收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
当满足条件B时,在最低价*0.995位置书写文字,COLORFFFF00,线宽为2
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
当满足条件J上穿D时,在最低价*0.98位置书写文字,COLOR00FFFF,线宽为2
VAR29赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VAR2A赋值:VAR29的5日[1日权重]移动平均
VAR2B赋值:VAR2A的10日[1日权重]移动平均
VAR2C赋值:VAR2B上穿VAR2A
VAR2D赋值:VAR2B>80 OR VAR2A>80
VAR2E赋值:VAR2C AND VAR2D
VAR33赋值:最高价
VAR34赋值:最低价
逃顶赋值:当满足条件VAR2E时,在VAR33和VAR34位置之间画柱状线,宽度为4,0不为0则画空心柱.
当满足条件(1日前的最高价+1日前的最低价)/2上穿收盘价的20日简单移动平均+2*收盘价的20日估算标准差时,在最高价*1.01位置书写文字,画绿色
X6赋值:1日前的收盘价
X7赋值:收盘价-X6和0的较大值的7日[1日权重]移动平均/收盘价-X6的绝对值的7日[1日权重]移动平均*100
X8赋值:79上穿X7
X9赋值:X8的4日过滤
当满足条件X9时,在最高价*1.03位置书写文字,COLOR9000F5
当满足条件0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0时,在最低价和开盘价位置之间画柱状线,宽度为3.15,0不为0则画空心柱.,COLOR337777
当满足条件0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0时,在最低价和开盘价位置之间画柱状线,宽度为2.45,0不为0则画空心柱.,COLOR339999
当满足条件0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0时,在最低价和开盘价位置之间画柱状线,宽度为1.75,0不为0则画空心柱.,COLOR33BBBB
当满足条件0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0时,在最低价和开盘价位置之间画柱状线,宽度为1.05,0不为0则画空心柱.,COLOR33DDDD
当满足条件0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0时,在最低价和开盘价位置之间画柱状线,宽度为0.35,0不为0则画空心柱.,COLOR33FFFF
当满足条件0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0时,在最低价*0.99位置书写文字,COLOR33FFFF
当满足条件88上穿RSI时,在(最高价*1.01)位置书写文字,COLOR00FF00
VAR2S赋值:(2*收盘价+最高价+最低价)/4
VAR3S赋值:如果年份>=2099ANDMONTH>2,返回0,否则返回1
VAR4S赋值:5日内最低价的最低值
VAR5S赋值:4日内最高价的最高值
散户赋值:(VAR2S-VAR4S)/(VAR5S-VAR4S)*100的4日指数移动平均*VAR3S
庄家赋值:0.667*1日前的散户+0.333*散户的2日指数移动平均*VAR3S
当满足条件散户上穿庄家AND散户<30时,在最低价和开盘价位置之间画柱状线,宽度为3.15,0不为0则画空心柱.,COLOR770077
当满足条件散户上穿庄家AND散户<30时,在最低价和开盘价位置之间画柱状线,宽度为2.45,0不为0则画空心柱.,COLOR990099
当满足条件散户上穿庄家AND散户<30时,在最低价和开盘价位置之间画柱状线,宽度为1.75,0不为0则画空心柱.,COLORBB00BB
当满足条件散户上穿庄家AND散户<30时,在最低价和开盘价位置之间画柱状线,宽度为1.05,0不为0则画空心柱.,COLORDD00DD
当满足条件散户上穿庄家AND散户<30时,在最低价和开盘价位置之间画柱状线,宽度为0.35,0不为0则画空心柱.,COLORFF00FF
当满足条件散户上穿庄家AND散户<30时,在最低价*0.99位置书写文字,COLORFF00FF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1g36EkLjYkOiUxZGqhUEwUQ

看了该指标的人还看了:
必胜客指标    主力进场指标
短线王+短线无敌+底部吸筹    福将牵牛优化指标 金钻选股

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表