请选择 进入手机版|继续访问电脑版

K线买卖趋势指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 2018-12-3 08:00:15 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 操盘控盘 
K线买卖趋势指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 操盘控盘 炒股叉第11306张


K线买卖趋势指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 操盘控盘 炒股叉第11305张

[lywrap=通达信主图指标公式][lycode=tdx,true]{二九宽带}
上18H:WMA(SMA(HHV(HIGH,18),9/2,1),3),COLOR00FF00,DOTLINE;
下18L:WMA(SMA(LLV(LOW,18),9/2,1),3),COLOR009900,DOTLINE;
通道:(上18H+下18L)/2,COLOR0598FF,DOTLINE;
DRAWBAND(上18H,RGB(60,0,60),通道,RGB(60,0,60));
DRAWBAND(通道,RGB(0,60,0),下18L,RGB(0,60,0));
WMA(SMA(HHV(HIGH,18),9/2,1),3),COLOR00FF00,DOTLINE;
WMA(SMA(LLV(LOW,18),9/2,1),3),COLOR009900,DOTLINE;
(上18H+下18L)/2,COLOR0598FF,DOTLINE;

{ACZC}
AC:=(C+REF(C,1)-HHV(H,2)-LLV(L,2));
MX:=MAX(AC,MAX(ABS(AC-HHV(H,2)),ABS(AC-LLV(L,2))));
WX4:WMA(MX,4),COLORFF4567;
ZC:=(2.5*C+H+L+O*0.5)/5;
ZC4:WMA(ZC,4),COLOR00FF00,LINETHICK2;
IF(ZC4>REF(ZC4,1),ZC4,DRAWNULL),COLORRED,LINETHICK3;
{MACD}
DIF:=EMA(CLOSE,7) - EMA(CLOSE,13);
DEA:=EMA(DIF,3);
DRAWTEXT(CROSS(DIF,DEA),L*0.99,'DIF'),COLOR0077FF,LINETHICK1;
DRAWTEXT(CROSS(DEA,DIF),H*1.02,'DEA'),COLOR00FF00,LINETHICK1;
{高抛}
SJ:=WMA((ZC-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H+0.1,'←高抛'),COLOR00FFFF,LINETHICK2;

{趋势涨K线}
AA:=(WX4-ZC4)<=0 ;
BB:=(WX4-ZC4)>0;
CC:=(ZC4-REF(ZC4,1))>0 AND (REF(ZC4,1)-REF(ZC4,2))>0;
{趋势跌K线}
STICKLINE(BB ,HIGH ,LOW,0,0 ),COLORGREEN;
STICKLINE(BB ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(BB ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(BB ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(BB ,CLOSE ,OPEN,0,0) ,COLOR00FF00;

STICKLINE(AA OR CC ,HIGH ,LOW,0,0 ),COLOR0000FF;
STICKLINE(AA OR CC ,CLOSE,OPEN,3,0) ,COLOR0000DD;
STICKLINE(AA OR CC ,CLOSE,OPEN,2,0) ,COLOR0000EE;
STICKLINE(AA OR CC ,CLOSE,OPEN,1,0) ,COLOR0000FF;
STICKLINE(AA OR CC ,CLOSE,OPEN,0,0) ,COLOR0000FF;

{原本涨跌}
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),H,H*1.001,2,0),COLORRED;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),L,L*0.999,2,0),COLORCYAN;[/lycode][lycode=tdx2,true]输出上18H:18日内最高价的最高值的9/2日[1日权重]移动平均的3日加权移动平均,COLOR00FF00,DOTLINE
输出下18L:18日内最低价的最低值的9/2日[1日权重]移动平均的3日加权移动平均,COLOR009900,DOTLINE
输出通道:(上18H+下18L)/2,COLOR0598FF,DOTLINE
画带状线
画带状线
18日内最高价的最高值的9/2日[1日权重]移动平均的3日加权移动平均,COLOR00FF00,DOTLINE
18日内最低价的最低值的9/2日[1日权重]移动平均的3日加权移动平均,COLOR009900,DOTLINE
(上18H+下18L)/2,COLOR0598FF,DOTLINE
AC赋值:(收盘价+1日前的收盘价-2日内最高价的最高值-2日内最低价的最低值)
MX赋值:AC和AC-2日内最高价的最高值的绝对值和AC-2日内最低价的最低值的绝对值的较大值的较大值
输出WX4:MX的4日加权移动平均,COLORFF4567
ZC赋值:(2.5*收盘价+最高价+最低价+开盘价*0.5)/5
输出ZC4:ZC的4日加权移动平均,COLOR00FF00,线宽为2
如果ZC4>1日前的ZC4,返回ZC4,否则返回无效数,画红色,线宽为3
DIF赋值:收盘价的7日指数移动平均 - 收盘价的13日指数移动平均
DEA赋值:DIF的3日指数移动平均
当满足条件DIF上穿DEA时,在最低价*0.99位置书写文字,COLOR0077FF,线宽为1
当满足条件DEA上穿DIF时,在最高价*1.02位置书写文字,COLOR00FF00,线宽为1
SJ赋值:(ZC-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的2日加权移动平均
ZJ赋值:0.618*1日前的SJ+0.382*SJ的2日加权移动平均
当满足条件ZJ上穿SJANDSJ>70时,在最高价+0.1位置书写文字,COLOR00FFFF,线宽为2
AA赋值:(WX4-ZC4)<=0
BB赋值:(WX4-ZC4)>0
CC赋值:(ZC4-1日前的ZC4)>0 AND (1日前的ZC4-2日前的ZC4)>0
当满足条件BB时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画绿色
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00DD00
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00EE00
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱. ,COLOR00FF00
当满足条件AAORCC时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000FF
当满足条件AAORCC时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱. ,COLOR0000DD
当满足条件AAORCC时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱. ,COLOR0000EE
当满足条件AAORCC时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱. ,COLOR0000FF
当满足条件AAORCC时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱. ,COLOR0000FF
当满足条件收盘价>OPENORCLOSE=OPENANDCLOSE>1日前的收盘价时,在最高价和最高价*1.001位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件收盘价<OPENORCLOSE=OPENANDCLOSE<=1日前的收盘价时,在最低价和最低价*0.999位置之间画柱状线,宽度为2,0不为0则画空心柱.,画青色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1CvNHka4S0h0xp9pFymMosA

看了该指标的人还看了:
一股当先指标    均衡加仓买线指标
云端波段主图+云端爆点预警选股    主力进场指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表