指标公式
软件: 通达信 
公式类型: 主图 副图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
TIM截图20181025095122.png

TIM截图20181025095132.png

操盘手:
[lywrap=通达信主图指标公式][lycode=tdx,true]N:=6;
M:=30;
MA5:MA(C,N),COLORWHITE;
MA18:=MA(CLOSE,18);
MA13:MA(C,M),COLORGREEN,LINETHICK2;
VAR1:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR2:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);
{红}
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),COLOR0000FF;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{蓝}
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLORFF9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.5,0),COLORFFCC00;
{粉}
STICKLINE(VAR1,C,(O+C)/2,3,0),COLORFF11FF;
STICKLINE(VAR1,C,(O+C)/2,0.5,0),COLORFFDDFF;
{灰}
STICKLINE(VAR2,C,(O+C)/2,3,0),COLOR999999;
STICKLINE(VAR2,C,(O+C)/2,0.5,0),COLORFFBBFF;
{绿}
STICKLINE(VAR3,O,(O+C)/2,3,0),COLOR00BB00;
STICKLINE(VAR3,O,(O+C)/2,0.5,0),COLOR00FF00;
卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'卖'),COLORGREEN;
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'买'),COLORRED;
加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
DRAWTEXT(FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3),LOW-0.03,'加'),COLORWHITE;

跟:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(跟,LOW*0.96,'跟'),COLORCC66FF;[/lycode][lycode=tdx2,true]N赋值:6
M赋值:30
输出MA5:收盘价的N日简单移动平均,画白色
MA18赋值:收盘价的18日简单移动平均
输出MA13:收盘价的M日简单移动平均,画绿色,线宽为2
VAR1赋值:收盘价=4日内收盘价的最高值 AND 1日前的收盘价=4日内收盘价的最低值
VAR2赋值:收盘价=4日内收盘价的最低值 AND (1日前的收盘价<2日前的收盘价 OR 1日前的收盘价<3日前的收盘价) OR 1日前的收盘价=4日内收盘价的最低值 AND 收盘价<2日前的收盘价 OR 2日前的收盘价=4日内收盘价的最低值 AND 1日前的收盘价=4日内收盘价的最高值 AND 收盘价<1日前的收盘价 OR 3日前的收盘价=4日内收盘价的最低值 AND 收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VAR3赋值:1日前的收盘价=4日内收盘价的最低值 AND 收盘价>=2日前的收盘价 OR 2日前的收盘价=4日内收盘价的最低值 AND 1日前的收盘价<=3日前的收盘价 AND 2日前的收盘价<4日前的收盘价 AND 收盘价>=1日前的收盘价
A赋值:(3*收盘价+最低价+开盘价+最高价)/6
VAR4赋值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/210
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
CB赋值:VAR4的13日指数移动平均
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORCC66FF
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF9900
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFCC00
当满足条件VAR1时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF11FF
当满足条件VAR1时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFDDFF
当满足条件VAR2时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR999999
当满足条件VAR2时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFBBFF
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00BB00
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00FF00
卖赋值:2日内DX的最高值=7日内DX的最高值 AND 统计2日中满足DX>50的天数 AND DX的2日简单移动平均上穿DX
当满足条件卖=1的1日过滤时,在最高价*1.02位置书写文字,画绿色
买赋值:2日内DX的最低值=7日内DX的最低值 AND 统计2日中满足DX<0的天数 AND DX上穿DX的2日简单移动平均
当满足条件买=1的5日过滤时,在最低价-0.03位置书写文字,画红色
加仓赋值:(收盘价-1日前的收盘价)/1日前的收盘价的5日指数移动平均*100的3日[1日权重]移动平均*10
当满足条件(加仓上穿0ORCROSS(收盘价,CB))AND买=1的3日过滤时,在最低价-0.03位置书写文字,画白色
跟赋值:MA18>=3日前的MA18 AND 收盘价上穿MA18
当满足条件跟时,在最低价*0.96位置书写文字,COLORCC66FF[/lycode][/lywrap]

个股操盘:
[lywrap=通达信副图指标公式][lycode=tdx,true]Z:=MA(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
波段进场:IF(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2),80,50);
反弹进场:IF(REF(VAR4,1)<5 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND VAR3<-0.3,80,50);
超跌进场:IF(CROSS(VAR4,5) AND VAR3<-0.4,80,50);
STICKLINE(C>=MA(C,10),VAR4,REF(VAR4,1),4,0),COLORRED;
STICKLINE(C<MA(C,10),VAR4,REF(VAR4,1),4,0),COLORGREEN;[/lycode][lycode=tdx2,true]Z赋值:收盘价的120日简单移动平均
VAR3赋值:(收盘价的5日简单移动平均-Z)/Z
VAR4赋值:(收盘价-10日内最低价的最低值)/(10日内最高价的最高值-10日内最低价的最低值)*100的3日简单移动平均
输出波段进场:如果收盘价>ZANDREF(VAR4,1)<30ANDVAR4>1日前的VAR4ANDREF(VAR4,1)<2日前的VAR4,返回80,否则返回50
输出反弹进场:如果1日前的VAR4<5ANDVAR4>1日前的VAR4ANDREF(VAR4,1)<2日前的VAR4ANDVAR3<-0.3,返回80,否则返回50
输出超跌进场:如果VAR4上穿5ANDVAR3<-0.4,返回80,否则返回50
当满足条件收盘价>=收盘价的10日简单移动平均时,在VAR4和1日前的VAR4位置之间画柱状线,宽度为4,0不为0则画空心柱.,画红色
当满足条件收盘价<收盘价的10日简单移动平均时,在VAR4和1日前的VAR4位置之间画柱状线,宽度为4,0不为0则画空心柱.,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1OD0v9tJ0INBzA-0S9cVgJQ

看了该指标的人还看了:
主力买卖指标    底部拉升指标    股海拾贝指标
敢死队操作线指标    抄底趋势线指标    短线黑马指标

使用道具 举报

回复