请选择 进入手机版|继续访问电脑版

度假主图指标 通达信 主图 波段 无未来函数 短线 操盘控盘

[复制链接]

admin  管理员

发表于 2018-12-3 08:00:15 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 操盘控盘 
度假主图指标 通达信 主图 波段 无未来函数 短线 操盘控盘 炒股叉第11299张

度假主图指标 通达信 主图 波段 无未来函数 短线 操盘控盘 炒股叉第11300张

[lywrap=通达信主图指标公式][lycode=tdx,true]A0:=(L+H+C*2)/4;
现价:C,NODRAW,COLORFF3399;
MA1:MA(CLOSE,60),COLOR0066FF,LINETHICK2;
工作:=EMA(A0,14)COLORYELLOW,LINETHICK3;
度假:=EMA(A0,25)COLORYELLOW,LINETHICK3;
A1X:=(工作-REF(工作,1))/REF(工作,1)*100;
A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
G:=BARSLAST(CROSS(A1X,0));
止损线:REF(A0,G),COLOR66FF00,LINETHICK1;
A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
A6:=EMA(A5,9);
A7:=(A5<-0.1 AND A5>A6);
CS:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;
DRAWICON(CROSS(A2,EMA(A2,5)) AND (A4-EMA(A2,5))>40 AND A7,LLV(L,21)*1.02,1);
STICKLINE(C>REF(C,1)*1.09,C,O,2,0)COLORRED,LINETHICK2;
STICKLINE(C<REF(C,1)*0.901,C,O,2,0)COLORGREEN,LINETHICK1;
J:IF(A2X>=0,度假,DRAWNULL),COLOR7F00FF,LINETHICK2;
S:IF(A1X>=0,工作,DRAWNULL),COLORFF80FF,LINETHICK1;
操作线:IF(A1X>=0,止损线,DRAWNULL),LINETHICK2,COLOR4D4DFF;
Z:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,DRAWNULL),COLORCYAN,POINTDOT;
顺:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,DRAWNULL),COLORCYAN,POINTDOT;
逼空线:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,DRAWNULL),COLORYELLOW,CIRCLEDOT;
Q:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,DRAWNULL),COLORCYAN,POINTDOT;
势:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,DRAWNULL),COLORCYAN,POINTDOT;
P:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.6,REF(A0,BARSLAST(CROSS(A1X,0)))*1.6,DRAWNULL),COLORCYAN,POINTDOT;
W:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.7,REF(A0,BARSLAST(CROSS(A1X,0)))*1.7,DRAWNULL),COLORCYAN,POINTDOT;
出:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.8,REF(A0,BARSLAST(CROSS(A1X,0)))*1.8,DRAWNULL),COLORCYAN,POINTDOT;
局:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.9,REF(A0,BARSLAST(CROSS(A1X,0)))*1.9,DRAWNULL),COLORCYAN,POINTDOT;
上轨: IF(1.1>SMA(CLOSE,2,1)/SMA(CLOSE,13,2)>1.05,SMA(HIGH,21,5)*1.05,SMA(HIGH,21,2)*1.05),COLOR4D4DFF,CIRCLEDOT;
下轨: SMA(LOW,21,2)*0.95,CIRCLEDOT,COLORFF6600;
SQS: IF(MA(VOL,3)>MA(VOL,5)>MA(VOL,9),SMA(CLOSE,3,1),SMA(CLOSE,5,1)),COLORFF99FF,LINETHICK3;[/lycode][lycode=tdx2,true]A0赋值:(最低价+最高价+收盘价*2)/4
输出现价:收盘价,NODRAW,COLORFF3399
输出MA1:收盘价的60日简单移动平均,COLOR0066FF,线宽为2
工作赋值:A0的14日指数移动平均画黄色,线宽为3
度假赋值:A0的25日指数移动平均画黄色,线宽为3
A1X赋值:(工作-1日前的工作)/1日前的工作*100
A2X赋值:(度假-1日前的度假)/1日前的度假*100
G赋值:上次A1X上穿0距今天数
输出止损线:G日前的A0,COLOR66FF00,线宽为1
A2赋值:3*(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的5日指数移动平均-2*(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的5日指数移动平均
A4赋值:(34日内最高价的最高值-收盘价)/(34日内最高价的最高值-34日内最低价的最低值)*100
A5赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
A6赋值:A5的9日指数移动平均
A7赋值:(A5<-0.1 AND A5>A6)
输出CS:如果A7,返回21日内最低价的最低值,否则返回无效数画红色,CIRCLEDOT
当满足条件A2上穿A2的5日指数移动平均AND(A4-A2的5日指数移动平均)>40ANDA7时,在21日内最低价的最低值*1.02位置画1号图标
当满足条件收盘价>1日前的收盘价*1.09时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.画红色,线宽为2
当满足条件收盘价<1日前的收盘价*0.901时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.画绿色,线宽为1
输出J:如果A2X>=0,返回度假,否则返回无效数,COLOR7F00FF,线宽为2
输出S:如果A1X>=0,返回工作,否则返回无效数,COLORFF80FF,线宽为1
输出操作线:如果A1X>=0,返回止损线,否则返回无效数,线宽为2,COLOR4D4DFF
输出Z:如果最高价>=上次A1X上穿0距今天数日前的A0*1.1,返回上次A1X上穿0距今天数日前的A0*1.1,否则返回无效数,画青色,POINTDOT
输出顺:如果最高价>=上次A1X上穿0距今天数日前的A0*1.2,返回上次A1X上穿0距今天数日前的A0*1.2,否则返回无效数,画青色,POINTDOT
输出逼空线:如果最高价>=上次A1X上穿0距今天数日前的A0*1.3,返回上次A1X上穿0距今天数日前的A0*1.3,否则返回无效数,画黄色,CIRCLEDOT
输出Q:如果最高价>=上次A1X上穿0距今天数日前的A0*1.4,返回上次A1X上穿0距今天数日前的A0*1.4,否则返回无效数,画青色,POINTDOT
输出势:如果最高价>=上次A1X上穿0距今天数日前的A0*1.5,返回上次A1X上穿0距今天数日前的A0*1.5,否则返回无效数,画青色,POINTDOT
输出P:如果最高价>=上次A1X上穿0距今天数日前的A0*1.6,返回上次A1X上穿0距今天数日前的A0*1.6,否则返回无效数,画青色,POINTDOT
输出W:如果最高价>=上次A1X上穿0距今天数日前的A0*1.7,返回上次A1X上穿0距今天数日前的A0*1.7,否则返回无效数,画青色,POINTDOT
输出出:如果最高价>=上次A1X上穿0距今天数日前的A0*1.8,返回上次A1X上穿0距今天数日前的A0*1.8,否则返回无效数,画青色,POINTDOT
输出局:如果最高价>=上次A1X上穿0距今天数日前的A0*1.9,返回上次A1X上穿0距今天数日前的A0*1.9,否则返回无效数,画青色,POINTDOT
输出上轨: 如果1.1>收盘价的2日[1日权重]移动平均/收盘价的13日[2日权重]移动平均>1.05,返回最高价的21日[5日权重]移动平均*1.05,否则返回最高价的21日[2日权重]移动平均*1.05,COLOR4D4DFF,CIRCLEDOT
输出下轨: 最低价的21日[2日权重]移动平均*0.95,CIRCLEDOT,COLORFF6600
输出SQS: 如果成交量(手)的3日简单移动平均>成交量(手)的5日简单移动平均>成交量(手)的9日简单移动平均,返回收盘价的3日[1日权重]移动平均,否则返回收盘价的5日[1日权重]移动平均,COLORFF99FF,线宽为3[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1T--_6I8-DNbqk3lCO5c2QA

看了该指标的人还看了:
超跌阻击指标    波段抄底指标
一清二楚指标    趋势通道指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表