指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
TIM截图20181025093941.png

TIM截图20181025094002.png

[lywrap=通达信副图指标公式][lycode=tdx,true]MA5:=MA(CLOSE,5);
MA15:=MA(CLOSE,15);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
离散量30:100*(MA5-(MA15+MA30)/2)/MA30,COLORYELLOW,LINETHICK1;
离散量60:100*(MA5-(MA15+MA30+MA60)/3)/MA60,COLORCYAN;
粘合K:-2*(离散量30-离散量60),COLORRED,LINETHICK2;
粘合D:=EMA(粘合K,3),COLORYELLOW;
主升:BARSLAST(CROSS(粘合K,粘合D))*(粘合K>粘合D),NODRAW,COLORGREEN;
粘合:=ABS(粘合K)+ABS(离散量60),COLORGREEN;
离差:(粘合K-离散量30)*(离散量30>REF(离散量30,1)),NODRAW;
CC:=粘合K-离散量30;
GZ1:=(ABS(粘合-粘合K)<3 AND 粘合K>粘合D) OR (粘合K>-0.5 AND 粘合K<1 AND 粘合K>粘合D) OR (CC>0 AND CC<2 AND 离散量30>REF(离散量30,1));
STICKLINE(GZ1,0,-1,0.8,1),COLORYELLOW;
关注1:IF(GZ1,1,0),COLORYELLOW,NODRAW;
VAR1:=IF(GZ1=1 AND 粘合K>REF(粘合K,1),1/ABS(粘合-粘合K),0);
GZ2:=IF(VAR1>10,10,IF(VAR1<0.5,0,IF(VAR1<1,1,VAR1)));
STICKLINE(GZ2>0,0,-GZ2,2,0),COLORMAGENTA;
关注2:IF(GZ2>0,1,0),COLORMAGENTA,NODRAW;
VAR3:=REF(离散量30,3)>=REF(离散量30,1) AND REF(离散量30,1)<=离散量30 AND (离散量30-粘合K<2) AND 主升>0;
STICKLINE(VAR3,粘合K+1,粘合K-1,1,0),COLORGREEN;
鸭嘴:IF(VAR3,1,0),COLORGREEN,NODRAW;
三金点:关注1+关注2+鸭嘴,NODRAW;
VAR4:=IF(离散量30<-5 AND REF(离散量30,2)>REF(离散量30,1) AND 离散量30>REF(离散量30,1),1,0);
STICKLINE(VAR4,离散量30+2,离散量30,1,0),COLORYELLOW;
反弹:IF(VAR4,1,0),COLORYELLOW,NODRAW;
0,COLORWHITE;0,COLORWHITE;
STICKLINE(鸭嘴,0,3,6,0),COLORMAGENTA;
STICKLINE(鸭嘴,3,6,4,0),COLORCYAN;
STICKLINE(鸭嘴,6,8,2,0),COLORYELLOW;
DRAWTEXT(鸭嘴,7,'鸭嘴'),COLORGREEN;
STICKLINE(反弹,0,3,6,0),COLORYELLOW;
STICKLINE(反弹,3,6,4,0),COLORCYAN;
STICKLINE(反弹,6,8,2,0),COLORRED;
DRAWTEXT(反弹,7,'反弹'),COLORGREEN;[/lycode][lycode=tdx2,true]MA5赋值:收盘价的5日简单移动平均
MA15赋值:收盘价的15日简单移动平均
MA30赋值:收盘价的30日简单移动平均
MA60赋值:收盘价的60日简单移动平均
输出离散量30:100*(MA5-(MA15+MA30)/2)/MA30,画黄色,线宽为1
输出离散量60:100*(MA5-(MA15+MA30+MA60)/3)/MA60,画青色
输出粘合K:-2*(离散量30-离散量60),画红色,线宽为2
粘合D赋值:粘合K的3日指数移动平均,画黄色
输出主升:上次粘合K上穿粘合D距今天数*(粘合K>粘合D),NODRAW,画绿色
粘合赋值:粘合K的绝对值+离散量60的绝对值,画绿色
输出离差:(粘合K-离散量30)*(离散量30>1日前的离散量30),NODRAW
CC赋值:粘合K-离散量30
GZ1赋值:(粘合-粘合K的绝对值<3 AND 粘合K>粘合D) OR (粘合K>-0.5 AND 粘合K<1 AND 粘合K>粘合D) OR (CC>0 AND CC<2 AND 离散量30>1日前的离散量30)
当满足条件GZ1时,在0和-1位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,画黄色
输出关注1:如果GZ1,返回1,否则返回0,画黄色,NODRAW
VAR1赋值:如果GZ1=1AND粘合K>1日前的粘合K,返回1/粘合-粘合K的绝对值,否则返回0
GZ2赋值:如果VAR1>10,返回10,否则返回如果VAR1<0.5,返回0,否则返回如果VAR1<1,返回1,否则返回VAR1
当满足条件GZ2>0时,在0和-GZ2位置之间画柱状线,宽度为2,0不为0则画空心柱.,画洋红色
输出关注2:如果GZ2>0,返回1,否则返回0,画洋红色,NODRAW
VAR3赋值:3日前的离散量30>=1日前的离散量30 AND 1日前的离散量30<=离散量30 AND (离散量30-粘合K<2) AND 主升>0
当满足条件VAR3时,在粘合K+1和粘合K-1位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
输出鸭嘴:如果VAR3,返回1,否则返回0,画绿色,NODRAW
输出三金点:关注1+关注2+鸭嘴,NODRAW
VAR4赋值:如果离散量30<-5ANDREF(离散量30,2)>1日前的离散量30AND离散量30>1日前的离散量30,返回1,否则返回0
当满足条件VAR4时,在离散量30+2和离散量30位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
输出反弹:如果VAR4,返回1,否则返回0,画黄色,NODRAW
0,画白色
0,画白色
当满足条件鸭嘴时,在0和3位置之间画柱状线,宽度为6,0不为0则画空心柱.,画洋红色
当满足条件鸭嘴时,在3和6位置之间画柱状线,宽度为4,0不为0则画空心柱.,画青色
当满足条件鸭嘴时,在6和8位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件鸭嘴时,在7位置书写文字,画绿色
当满足条件反弹时,在0和3位置之间画柱状线,宽度为6,0不为0则画空心柱.,画黄色
当满足条件反弹时,在3和6位置之间画柱状线,宽度为4,0不为0则画空心柱.,画青色
当满足条件反弹时,在6和8位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件反弹时,在7位置书写文字,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1E2PBdbv9qzA1QpXP5R-TIg

看了该指标的人还看了:
涨势跌势确立指标    三增三阳指标    明明白白指标
超级抄底指标    股海扬帆指标    博奕杀手指标

使用道具 举报

回复