请选择 进入手机版|继续访问电脑版

短线100成功指标 通达信 副图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-12-2 08:00:43 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
短线100成功指标 通达信 副图 波段 短线 买卖点 炒股叉第11287张

短线100成功指标 通达信 副图 波段 短线 买卖点 炒股叉第11288张

[lywrap=通达信副图指标公式][lycode=tdx,true]WL:(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,LINETHICK1,COLOR0000FF;
WL3:=MA(WL,3),COLOR00FFFF;
WLT:MA(WL,89),COLOR00FFFF,LINETHICK1;
DRAWBAND(WL,RGB(200,60,200),WLT,RGB(0,100,50));
遵涨:IF(WL>=WLT,WL,DRAWNULL),COLOR3300FF;
守望:IF(WLT>=WL,WLT,DRAWNULL),COLORFF6000;
纪买:IF(WL>=WLT,WLT,DRAWNULL),COLOR00FFFF;
律跌:IF(WLT>=WL,WL,DRAWNULL),COLOR00FF00;
WLT1:=CROSS(WL,WLT);
WLT11:=CROSS(WL,-10);
WLT2:=FILTER(WLT1,8);
SKY:=10,POINTDOT,COLORFF0000,LINETHICK1;
SEA:=-10,POINTDOT,COLORFF00FF,LINETHICK1;
DRAWICON(WLT2,WLT,23);
DRAWICON(WLT11,SEA,15);
T8:=FILTER(CROSS(WL,WL3) AND WL3<WLT,5);
DRAWICON(T8,WL,25);
WLT3:=COUNT(WL>10,5)>=3;
WLT33:=CROSS(10,WL);
SEL:=WLT3 AND WLT33;
DRAWICON(SEL,10,19);
STICKLINE(WL>10,WL,10,0.001,0),COLOR00FF00;
STICKLINE(WL<-10,WL,-10,0.001,0),COLORFF00FF;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIF底:=LLV(DIF,120);
最底价:=L=LLV(L,120);
距今:=BARSLAST(最底价);
偏离:=IF((距今=0 AND DIF>DIF底),1,0);
DDD:=EXIST(偏离,20) AND SLOPE(DEA,2)>=0;
HRY:=FILTER(DDD,10);
STICKLINE(HRY,-5,-10,3,0),COLOR00FFFF;
DRAWTEXT(HRY,-5,'M背'),COLOR88FFFF;
{YYY:COUNT(偏离,5);}
DIF顶:=HHV(DIF,120);
最高价:=H=HHV(H,120);
距今高:=BARSLAST(最高价);
偏离高:=IF((距今高=0 AND DIF<DIF顶),1,0);
GGG:=EXIST(偏离高,20) AND SLOPE(DEA,2)<0;
HRY1:=FILTER(GGG,10);
STICKLINE(HRY1,10,6.5,7,1),COLORFF8000;
DRAWTEXT(HRY1,6,' M背'),COLORFF8000;
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
KDJ底背:FILTER(IF(B2>0,-1,0),13),COLORFF00FF,NODRAW;
STICKLINE(KDJ底背,-10,-8,3,0),COLORFF00FF;
DRAWTEXT(KDJ底背,-7.5,'K背'),COLORFF00FF;
RSI底背:FILTER(IF(B3>0,-1,0),13),COLORFF8000,NODRAW;
STICKLINE(RSI底背,-10,-7,3,0),COLORFFFFFF;
DRAWTEXT(RSI底背,-6.5,'R背'),COLORFFFFFF;
KDJ顶背:FILTER(IF(D2>0,1,0),13),COLORFFF000,NODRAW;
STICKLINE(KDJ顶背,10,5,2,0),COLORFFFF00;
DRAWTEXT(KDJ顶背,4.5,'K背'),COLORFFFF00;
RSI顶背:FILTER(IF(D3>0,1,0),13),NODRAW;
STICKLINE(RSI顶背,10,8,5,0),COLOR00FF00;
DRAWTEXT(RSI顶背,7.5,'R背'),COLOR00FF80;
T:=IF((BARSCOUNT(C) > 7),(100)*((MA(C,7))/(LLV(MA(C,7),7)) - 1),1);
N:=IF((T > 0.35),6,65);
W:=((-((100)*(HHV(H,N) - C))/(HHV(HIGH,N) - LLV(L,N))));
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;
QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
BB:=MA(SUM(J1-J2,22),3);
修改1:=DYNAINFO(8)*240/FROMOPEN;
修改2:=IF(CLOSE>QJ,修改1,0);
修改3:=IF(CLOSE<QJ,修改1,0);
修改4:=MA(SUM(修改2-修改3,22),3);
累加:=21*修改4+20*REF(BB,1)+19*REF(BB,2)+18*REF(BB,3)+17*REF(BB,4)
+16*REF(BB,5)+15*REF(BB,6)+14*REF(BB,7)+13*REF(BB,8)+12*REF
(BB,9)+11*REF(BB,10)+10*REF(BB,11)+9*REF(BB,12)+8*REF(BB,13)
+7*REF(BB,14)+6*REF(BB,15)+5*REF(BB,16)+4*REF(BB,17)+3*REF
(BB,18)+2*REF(BB,19)+REF(BB,20);
WMA3:=累加/(21+1)/21*2;
CC:=WMA3;VAR3:=(BB-CC);VAR4:=SMA(RV,3,1);
VAR5:=SMA(VAR4,3,1);
KK:=EMA(SMA(RG,3,1),2),COLORFFFFFF;
DD:=SMA(KK,3,1),COLOR00FFFF;
涨停:=CROSS(W,-2) AND CROSS(VAR4,VAR5) AND CROSS(KK,DD);
STICKLINE(涨停,-10,-5,4,0)COLORRED;
DRAWTEXT(REF("KDJ.J",1)<0 AND "KDJ.J">0,-4,'短'),COLORFF88FF;
STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,-10,-4.5,3,0),COLORFF88FF;
AA1:=HHV(H,55);
BB1:=REF(H,13);
TJ1:=AA1=BB1;
XX:=LLV(L,55);
YY:=REF(L,13);
YY1:=REF(L,21);
TJ2:=XX=YY;
TJ3:=XX=YY1;
选股:TJ1 OR TJ2;
DRAWTEXT(TJ2,-6,'离底13'),COLOR00FF00;
STICKLINE(TJ2 ,-10,-6.5,2,1),COLOR00FF00;
DRAWTEXT(TJ3,-7.5,'离底21'),COLOR00FFFF;
STICKLINE(TJ3 ,-10,-8,4,1),COLOR00FFFF;
DRAWTEXT(TJ1,-5.5,'离高13'),COLOR0000FF;
STICKLINE(TJ1 ,-10,-6,2,0),COLOR0000FF;
LV:=MA(C,24);
HR0:=HHV(HIGH,N);
HRY0:=LLV(LOW,N);
HRY110:=HR0*HRY0;
HRY330:=SQRT(HRY110);
NS1:=C>HRY330 AND HRY330 >=REF(HRY330,1) AND C>LV;
STICKLINE(C>0,-10,-11.5,3,0),COLORFF6000;
STICKLINE(WLT2 OR WL>WLT,-10,-11.5,3,0),COLOR00FFFF;
STICKLINE(NS1,-10,-11.5,3,0),COLOR0000FF;
DRAWTEXT(FILTER(NS1,21),-11,'持股'),COLORFFFFFF;
DRAWTEXT(FILTER(WLT2 OR WL>WLT,13),-11,'买入'),COLOR0000FF;[/lycode][lycode=tdx2,true]输出WL:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100,线宽为1,COLOR0000FF
WL3赋值:WL的3日简单移动平均,COLOR00FFFF
输出WLT:WL的89日简单移动平均,COLOR00FFFF,线宽为1
画带状线
输出遵涨:如果WL>=WLT,返回WL,否则返回无效数,COLOR3300FF
输出守望:如果WLT>=WL,返回WLT,否则返回无效数,COLORFF6000
输出纪买:如果WL>=WLT,返回WLT,否则返回无效数,COLOR00FFFF
输出律跌:如果WLT>=WL,返回WL,否则返回无效数,COLOR00FF00
WLT1赋值:WL上穿WLT
WLT11赋值:WL上穿-10
WLT2赋值:WLT1的8日过滤
SKY赋值:10,POINTDOT,COLORFF0000,线宽为1
SEA赋值:-10,POINTDOT,COLORFF00FF,线宽为1
当满足条件WLT2时,在WLT位置画23号图标
当满足条件WLT11时,在SEA位置画15号图标
T8赋值:WL上穿WL3ANDWL3<WLT的5日过滤
当满足条件T8时,在WL位置画25号图标
WLT3赋值:统计5日中满足WL>10的天数>=3
WLT33赋值:10上穿WL
SEL赋值:WLT3 AND WLT33
当满足条件SEL时,在10位置画19号图标
当满足条件WL>10时,在WL和10位置之间画柱状线,宽度为0.001,0不为0则画空心柱.,COLOR00FF00
当满足条件WL<-10时,在WL和-10位置之间画柱状线,宽度为0.001,0不为0则画空心柱.,COLORFF00FF
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:(DIF-DEA)*2,COLORSTICK
DIF底赋值:120日内DIF的最低值
最底价赋值:最低价=120日内最低价的最低值
距今赋值:上次最底价距今天数
偏离赋值:如果(距今=0ANDDIF>DIF底),返回1,否则返回0
DDD赋值:最近20日存在偏离 AND DEA的2日线性回归斜率>=0
HRY赋值:DDD的10日过滤
当满足条件HRY时,在-5和-10位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FFFF
当满足条件HRY时,在-5位置书写文字,COLOR88FFFF
DIF顶赋值:120日内DIF的最高值
最高价赋值:最高价=120日内最高价的最高值
距今高赋值:上次最高价距今天数
偏离高赋值:如果(距今高=0ANDDIF<DIF顶),返回1,否则返回0
GGG赋值:最近20日存在偏离高 AND DEA的2日线性回归斜率<0
HRY1赋值:GGG的10日过滤
当满足条件HRY1时,在10和6.5位置之间画柱状线,宽度为7,1不为0则画空心柱.,COLORFF8000
当满足条件HRY1时,在6位置书写文字,COLORFF8000
A2赋值:上次1日前的"KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)距今天数
B2赋值:A2+1日前的收盘价>收盘价 AND A2+1日前的"KDJ的K"(9,3,3)<"KDJ的K"(9,3,3) AND "KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)
A3赋值:上次1日前的"RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)距今天数
B3赋值:A3+1日前的收盘价>收盘价 AND A3+1日前的"RSI的RSI1"(6,12,24)<"RSI的RSI1"(6,12,24) AND "RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)
C2赋值:上次1日前的"KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)距今天数
D2赋值:C2+1日前的收盘价<收盘价 AND C2+1日前的"KDJ的K"(9,3,3)>"KDJ的K"(9,3,3) AND "KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)
C3赋值:上次1日前的"RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)距今天数
D3赋值:C3+1日前的收盘价<收盘价 AND C3+1日前的"RSI的RSI1"(6,12,24)>"RSI的RSI1"(6,12,24) AND "RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)
输出KDJ底背:如果B2>0,返回-1,否则返回0的13日过滤,COLORFF00FF,NODRAW
当满足条件KDJ底背时,在-10和-8位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
当满足条件KDJ底背时,在-7.5位置书写文字,COLORFF00FF
输出RSI底背:如果B3>0,返回-1,否则返回0的13日过滤,COLORFF8000,NODRAW
当满足条件RSI底背时,在-10和-7位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFFFFF
当满足条件RSI底背时,在-6.5位置书写文字,COLORFFFFFF
输出KDJ顶背:如果D2>0,返回1,否则返回0的13日过滤,COLORFFF000,NODRAW
当满足条件KDJ顶背时,在10和5位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFFF00
当满足条件KDJ顶背时,在4.5位置书写文字,COLORFFFF00
输出RSI顶背:如果D3>0,返回1,否则返回0的13日过滤,NODRAW
当满足条件RSI顶背时,在10和8位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR00FF00
当满足条件RSI顶背时,在7.5位置书写文字,COLOR00FF80
T赋值:如果(收盘价的有效数据周期数>7),返回(100)*((收盘价的7日简单移动平均)/(7日内收盘价的7日简单移动平均的最低值)-1),否则返回1
N赋值:如果(T>0.35),返回6,否则返回65
W赋值:((-((100)*(N日内最高价的最高值 - 收盘价))/(N日内最高价的最高值 - N日内最低价的最低值)))
RV赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
RG赋值:(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100
J0赋值:(最高价+最低价)/2
QJ赋值:J0的3日指数移动平均
J1赋值:如果收盘价>QJ,返回成交量(手),否则返回0
J2赋值:如果收盘价<QJ,返回成交量(手),否则返回0
BB赋值:J1-J2的22日累和的3日简单移动平均
修改1赋值:总量*240/当前离开盘分钟数
修改2赋值:如果收盘价>QJ,返回修改1,否则返回0
修改3赋值:如果收盘价<QJ,返回修改1,否则返回0
修改4赋值:修改2-修改3的22日累和的3日简单移动平均
累加赋值:21*修改4+20*1日前的BB+19*2日前的BB+18*3日前的BB+17*4日前的BB+16*5日前的BB+15*6日前的BB+14*7日前的BB+13*8日前的BB+12*9日前的BB+11*10日前的BB+10*11日前的BB+9*12日前的BB+8*13日前的BB+7*14日前的BB+6*15日前的BB+5*16日前的BB+4*17日前的BB+3*18日前的BB+2*19日前的BB+20日前的BB
WMA3赋值:累加/(21+1)/21*2
CC赋值:WMA3
VAR3赋值:(BB-CC)
VAR4赋值:RV的3日[1日权重]移动平均
VAR5赋值:VAR4的3日[1日权重]移动平均
KK赋值:RG的3日[1日权重]移动平均的2日指数移动平均,COLORFFFFFF
DD赋值:KK的3日[1日权重]移动平均,COLOR00FFFF
涨停赋值:W上穿-2 AND VAR4上穿VAR5 AND KK上穿DD
当满足条件涨停时,在-10和-5位置之间画柱状线,宽度为4,0不为0则画空心柱.画红色
当满足条件1日前的"KDJ的J"<0AND"KDJ的J">0时,在-4位置书写文字,COLORFF88FF
当满足条件1日前的"KDJ的J"<0AND"KDJ的J">0时,在-10和-4.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF88FF
AA1赋值:55日内最高价的最高值
BB1赋值:13日前的最高价
TJ1赋值:AA1=BB1
XX赋值:55日内最低价的最低值
YY赋值:13日前的最低价
YY1赋值:21日前的最低价
TJ2赋值:XX=YY
TJ3赋值:XX=YY1
输出选股:TJ1 OR TJ2
当满足条件TJ2时,在-6位置书写文字,COLOR00FF00
当满足条件TJ2时,在-10和-6.5位置之间画柱状线,宽度为2,1不为0则画空心柱.,COLOR00FF00
当满足条件TJ3时,在-7.5位置书写文字,COLOR00FFFF
当满足条件TJ3时,在-10和-8位置之间画柱状线,宽度为4,1不为0则画空心柱.,COLOR00FFFF
当满足条件TJ1时,在-5.5位置书写文字,COLOR0000FF
当满足条件TJ1时,在-10和-6位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0000FF
LV赋值:收盘价的24日简单移动平均
HR0赋值:N日内最高价的最高值
HRY0赋值:N日内最低价的最低值
HRY110赋值:HR0*HRY0
HRY330赋值:HRY110的开方
NS1赋值:收盘价>HRY330 AND HRY330 >=1日前的HRY330 AND 收盘价>LV
当满足条件收盘价>0时,在-10和-11.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF6000
当满足条件WLT2ORWL>WLT时,在-10和-11.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FFFF
当满足条件NS1时,在-10和-11.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
当满足条件NS1的21日过滤时,在-11位置书写文字,COLORFFFFFF
当满足条件WLT2ORWL>WLT的13日过滤时,在-11位置书写文字,COLOR0000FF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1bEOAk41QXqO_xshrW8m53Q

看了该指标的人还看了:
买卖提示指标    愿赌服输BS指标
极品底超准指标    均衡加仓买线指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表