请选择 进入手机版|继续访问电脑版

张哥布林指标 通达信 主图 BOLL指标 画线 趋势 操盘控盘 压力支撑

[复制链接]

admin  管理员

发表于 2018-12-2 08:00:43 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: BOLL指标 画线 趋势 操盘控盘 压力支撑 
张哥布林指标 通达信 主图 BOLL指标 画线 趋势 操盘控盘 压力支撑 炒股叉第11285张

张哥布林指标 通达信 主图 BOLL指标 画线 趋势 操盘控盘 压力支撑 炒股叉第11286张

[lywrap=通达信主图指标公式][lycode=tdx,true]{顶:PEAK(CLOSE,N1,1)*0.98;
底:TROUGH(CLOSE,N1,1)*1.02;
高:100*(顶-底)/底,NODRAW;}

MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORYELLOW,LINETHICK1;
MA60:MA(C,60),COLORGREEN,LINETHICK2;

N:=20;
BOLL:MA(CLOSE,N),COLORRED,LINETHICK2;
UB:BOLL+2*STD(CLOSE,N),COLORFF00FF;
LB:BOLL-2*STD(CLOSE,N),COLORFF00FF;
C3:=REF(C,1);
涨停:=IF(C>1.093*C3,1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;

DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;

{跳空}
STICKLINE(HIGH<REF(LOW,1),HIGH,REF(LOW,1),2,0) ,COLOR888888;
STICKLINE(LOW>REF(HIGH,1) ,LOW,REF(HIGH,1),5,0),COLOR888888;

TY:=C;
AA1:=REF(TY,10)=HHV(TY,2*10+1); BB1:=FILTER(AA1,10);
C1:=BACKSET(BB1,10+1); HD:=FILTER(C1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(AA2,10);
CC2:=BACKSET(B2,10+1); LD:=FILTER(CC2,10);
前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT,LINETHICK4;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT,LINETHICK4;
C2:=REF(C,1);
大阳线:=IF((C-C2)*100/C2>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0)
OR IF((C-O)*100/O>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阳线,OPEN,CLOSE,-1,0),COLORRED;
STICKLINE(大阳线,H,L,0,1),COLORRED;
大阴线:=IF((C2-C)*100/C2>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0)
OR IF((O-C)*100/O>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;
STICKLINE(大阴线,H,L,0,1),COLORGREEN;
下降压力:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3)
,HHV(HIGH,3),1),COLORYELLOW,LINETHICK2;[/lycode][lycode=tdx2,true]输出MA5:收盘价的5日简单移动平均,画白色
输出MA10:收盘价的10日简单移动平均,画黄色,线宽为1
输出MA60:收盘价的60日简单移动平均,画绿色,线宽为2
N赋值:20
输出BOLL:收盘价的N日简单移动平均,画红色,线宽为2
输出UB:BOLL+2*收盘价的N日估算标准差,COLORFF00FF
输出LB:BOLL-2*收盘价的N日估算标准差,COLORFF00FF
C3赋值:1日前的收盘价
涨停赋值:如果收盘价>1.093*C3,返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
跌停赋值:如果(C3-收盘价)*100/C3>=(10-0.01*100/C3),返回1,否则返回0
当满足条件跌停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
当满足条件1时,在横轴0.00纵轴0位置书写文字COLOR0080FF
当满足条件1时,在横轴0.07纵轴0位置书写文字COLOR0080FF
当满足条件1时,在横轴0.14纵轴0位置书写文字COLOR00FFFF
当满足条件1时,在横轴0.21纵轴0位置书写文字COLOR00FFFF
当满足条件最高价<1日前的最低价时,在最高价和1日前的最低价位置之间画柱状线,宽度为2,0不为0则画空心柱. ,COLOR888888
当满足条件最低价>1日前的最高价时,在最低价和1日前的最高价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR888888
TY赋值:收盘价
AA1赋值:10日前的TY=2*10+1日内TY的最高值
BB1赋值:AA1的10日过滤
C1赋值:若BB1则将最近10+1周期置为1
HD赋值:C1的10日过滤
AA2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:AA2的10日过滤
CC2赋值:若B2则将最近10+1周期置为1
LD赋值:CC2的10日过滤
输出前期高位:上次HD距今天数日前的最高价,COLOR00FF00,POINTDOT,线宽为4
输出前期低位:上次LD距今天数日前的最低价,COLORFF00FF,POINTDOT,线宽为4
C2赋值:1日前的收盘价
大阳线赋值:如果(收盘价-C2)*100/C2>=5,返回1,否则返回0并且如果(收盘价-C2)*100/C2<(10-0.01*100/C2),返回1,否则返回0OR 如果(收盘价-开盘价)*100/开盘价>=5,返回1,否则返回0并且如果(收盘价-C2)*100/C2<(10-0.01*100/C2),返回1,否则返回0
当满足条件大阳线时,在开盘价和收盘价位置之间画柱状线,宽度为-1,0不为0则画空心柱.,画红色
当满足条件大阳线时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
大阴线赋值:如果(C2-收盘价)*100/C2>=5,返回1,否则返回0并且如果(C2-收盘价)*100/C2<(10-0.01*100/C2),返回1,否则返回0OR 如果(开盘价-收盘价)*100/开盘价>=5,返回1,否则返回0并且如果(C2-收盘价)*100/C2<(10-0.01*100/C2),返回1,否则返回0
当满足条件大阴线时,在开盘价和收盘价位置之间画柱状线,宽度为-1,0不为0则画空心柱.,画绿色
当满足条件大阴线时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画绿色
输出下降压力:当满足条件最高价>=10日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=3日内最低价的最低值时,在3日内最高价的最高值位置画直线终点,1表示是否延长.,画黄色,线宽为2[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1BABx5fgb0H6z-VGFkbUYuQ

看了该指标的人还看了:
均衡加仓买线指标    超短线指标
趋势买卖控盘指标    愿赌服输BS指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表