请选择 进入手机版|继续访问电脑版

趋势射线指标 通达信 主图 波段 画线 趋势 操盘控盘 压力支撑

[复制链接]

admin  管理员

发表于 2018-11-13 08:00:13 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 画线 趋势 操盘控盘 压力支撑 
趋势射线指标 通达信 主图 波段 画线 趋势 操盘控盘 压力支撑 炒股叉第10893张

趋势射线指标 通达信 主图 波段 画线 趋势 操盘控盘 压力支撑 炒股叉第10894张

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWLINE(L=LLV(L,3),L,C=HHV(C,3),L,0),COLOR9A90FF;
趋势射线7: DRAWLINE(H=HHV(H,7),H,L=LLV(L,7),L,0),COLOR9AFF89;
射线7X: DRAWLINE(L=LLV(L,7),L,H=HHV(H,7),L,0),COLOR9AFF89;
趋势射线21: DRAWLINE(H=HHV(H,21),H,L=LLV(L,21),L,0),COLORC100FF;
射线21X: DRAWLINE(L=LLV(L,21),L,H=HHV(H,21),L,0),COLORC100FF;
趋势射线35: DRAWLINE(H=HHV(H,35),H,L=LLV(L,35),L,0),COLORC1005B;
射线35X: DRAWLINE(L=LLV(L,35),L,H=HHV(H,35),L,0),COLORC1005B;
趋势射线49: DRAWLINE(H=HHV(H,49),H,L=LLV(L,49),L,0),COLORYELLOW;
射线49X: DRAWLINE(L=LLV(L,49),L,H=HHV(H,49),L,0),COLORYELLOW;
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORBLUE,LINETHICK2;
A2:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORBLUE,LINETHICK2;
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1);S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORRED,LINETHICK2;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1);U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORRED,LINETHICK2;

VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;
支撑:= REF(LOW,BARSLAST(VAR4444));
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;[/lycode][lycode=tdx2,true]当满足条件最低价=3日内最低价的最低值时,在最低价位置画直线起点,当满足条件收盘价=3日内收盘价的最高值时,在最低价位置画直线终点,0表示是否延长.,COLOR9A90FF
输出趋势射线7: 当满足条件最高价=7日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价=7日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.,COLOR9AFF89
输出射线7X: 当满足条件最低价=7日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价=7日内最高价的最高值时,在最低价位置画直线终点,0表示是否延长.,COLOR9AFF89
输出趋势射线21: 当满足条件最高价=21日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价=21日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.,COLORC100FF
输出射线21X: 当满足条件最低价=21日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价=21日内最高价的最高值时,在最低价位置画直线终点,0表示是否延长.,COLORC100FF
输出趋势射线35: 当满足条件最高价=35日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价=35日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.,COLORC1005B
输出射线35X: 当满足条件最低价=35日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价=35日内最高价的最高值时,在最低价位置画直线终点,0表示是否延长.,COLORC1005B
输出趋势射线49: 当满足条件最高价=49日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价=49日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.,画黄色
输出射线49X: 当满足条件最低价=49日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价=49日内最高价的最高值时,在最低价位置画直线终点,0表示是否延长.,画黄色
A1赋值:8日前的最高价=2*8+1日内最高价的最高值
B1赋值:A1的8日过滤
C1赋值:若B1则将最近8+1周期置为1
D1赋值:C1的8日过滤
R11赋值:若是否最后一个周期则将最近上次D1距今天数+1周期置为1
S11赋值:R11>1日前的R11
当满足条件D1时,在最高价位置画直线起点,当满足条件S11时,在最高价位置画直线终点,1表示是否延长.,画蓝色,线宽为2
A2赋值:8日前的最低价=2*8+1日内最低价的最低值
B2赋值:A2的8日过滤
C2赋值:若B2则将最近8+1周期置为1
D2赋值:C2的8日过滤
T11赋值:若是否最后一个周期则将最近上次D2距今天数+1周期置为1
U11赋值:T11>1日前的T11
当满足条件D2时,在最低价位置画直线起点,当满足条件U11时,在最低价位置画直线终点,1表示是否延长.,画蓝色,线宽为2
M赋值:3*8/5的整数部分
A12赋值:M日前的最高价=2*M+1日内最高价的最高值
B12赋值:A12的M日过滤
C12赋值:若B12则将最近M+1周期置为1
D12赋值:C12的M日过滤
R112赋值:若是否最后一个周期则将最近上次D12距今天数+1周期置为1
S112赋值:R112>1日前的R112
当满足条件D12时,在最高价位置画直线起点,当满足条件S112时,在最高价位置画直线终点,1表示是否延长.,画红色,线宽为2
A22赋值:M日前的最低价=2*M+1日内最低价的最低值
B22赋值:A22的M日过滤
C22赋值:若B22则将最近M+1周期置为1
D22赋值:C22的M日过滤
T112赋值:若是否最后一个周期则将最近上次D22距今天数+1周期置为1
U112赋值:T112>1日前的T112
当满足条件D22时,在最低价位置画直线起点,当满足条件U112时,在最低价位置画直线终点,1表示是否延长.,画红色,线宽为2
VAR1111赋值:若2日前的最高价=5日内最高价的最高值则将最近3周期置为1
VAR2222赋值:VAR1111上穿0.9
VAR3333赋值:若2日前的最低价=5日内最低价的最低值则将最近3周期置为1
VAR4444赋值:VAR3333上穿0.9
压力赋值: 上次VAR2222距今天数日前的最高价
当满足条件收盘价时,在上次VAR2222距今天数日前的最高价和上次VAR2222距今天数日前的最高价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,COLOREA91B5,线宽为3
支撑赋值: 上次VAR4444距今天数日前的最低价
当满足条件收盘价时,在上次VAR4444距今天数日前的最低价和上次VAR4444距今天数日前的最低价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,COLOR00B4FF,线宽为3[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1VBlLxg-8nHnEa4JA9jt_2Q

看了该指标的人还看了:
寻龙诀金钻指标    60日价值中枢指标
减仓逃顶指标    五虎上将出征指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表