请选择 进入手机版|继续访问电脑版

金蝴蝶波段底指标 通达信 主图 波段 无未来函数 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-11-12 08:00:10 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
金蝴蝶波段底指标 通达信 主图 波段 无未来函数 短线 买卖点 炒股叉第10853张

金蝴蝶波段底指标 通达信 主图 波段 无未来函数 短线 买卖点 炒股叉第10854张

[lywrap=通达信主图指标公式][lycode=tdx,true]买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,30);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);

DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORLIRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORLIBLUE;
M:=EMA(CLOSE,5);
S:=EMA(M,34),COLORYELLOW,LINETHICK2;
Y:=HHV(MA(HIGH,3),2),COLORGREEN,LINETHICK2;
D:LLV(MA(HIGH,3),1),COLORFF00FF,LINETHICK1;
QA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
QB:=EMA(0.667*REF(QA,1)+0.333*QA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(QA>=QB AND QA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'←买'),COLOR0000FF;
QC:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1))*100;
Q1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
Q2:=REF(Q1,1);
Q3:=(SMA(MAX(Q1-Q2,0),10,1))/(SMA(ABS(Q1-Q2),10,1))*100;
Q4:=FILTER(IF((COUNT(Q3<20,5))>=1 AND (COUNT(Q1=LLV(Q1,10),10))>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
Q5:=FILTER(S>REF(S,1) AND Y<REF(Y,1) AND CLOSE>REF(CLOSE,1),11);
Q6:=REF(CLOSE,1);
Q7:=(SMA(MAX(CLOSE-Q6,0),6,1))/(SMA(ABS(CLOSE-Q6),6,1))*100;

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,55),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
启动:=IF(XL3,0,VAR8*3);
DRAWICON(启动>10&&(XLPL.NOTEXT吸<1 AND REF(XLPL.NOTEXT落,0.5)),L,29);[/lycode][lycode=tdx2,true]买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的21日线性回归斜率*20+收盘价的30日指数移动平均
BU赋值:买线上穿卖线
SEL赋值:卖线上穿买线
当满足条件SEL时,在最高价+0.1位置画2号图标
当满足条件买线>=卖线时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画红色
当满足条件买线>=卖线时,在收盘价和开盘价位置之间画柱状线,宽度为2,1不为0则画空心柱.,画淡红色
当满足条件买线<卖线时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画绿色
当满足条件买线<卖线时,在收盘价和开盘价位置之间画柱状线,宽度为2,1不为0则画空心柱.,画淡蓝色
M赋值:收盘价的5日指数移动平均
S赋值:M的34日指数移动平均,画黄色,线宽为2
Y赋值:2日内最高价的3日简单移动平均的最高值,画绿色,线宽为2
输出D:1日内最高价的3日简单移动平均的最低值,COLORFF00FF,线宽为1
QA赋值:(收盘价-29日前的开盘价)/29日前的开盘价*100
QB赋值:0.667*1日前的QA+0.333*QA的5日指数移动平均
当满足条件如果成交量(手)>=1.3*成交量(手)的5日简单移动平均ANDCOUNT(QA>=QBANDQA<-17,3)ANDREF(最低价,1)=120日内最低价的最低值,返回1,否则返回0时,在最低价位置书写文字,COLOR0000FF
QC赋值:(收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均)/(收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均)*100
Q1赋值:(最高价+最低价+开盘价+2*收盘价)/5
Q2赋值:1日前的Q1
Q3赋值:(Q1-Q2和0的较大值的10日[1日权重]移动平均)/(Q1-Q2的绝对值的10日[1日权重]移动平均)*100
Q4赋值:如果(统计5日中满足Q3<20的天数)>=1AND(统计10日中满足Q1=10日内Q1的最低值的天数)>=1ANDCLOSE>=开盘价*1.038ANDVOL>成交量(手)的5日简单移动平均*1.2,返回1,否则返回0的5日过滤
Q5赋值:S>1日前的SANDY<1日前的YANDCLOSE>1日前的收盘价的11日过滤
Q6赋值:1日前的收盘价
Q7赋值:(收盘价-Q6和0的较大值的6日[1日权重]移动平均)/(收盘价-Q6的绝对值的6日[1日权重]移动平均)*100
VAR2赋值:1日前的最低价
VAR3赋值:最低价-VAR2的绝对值的13日[1日权重]移动平均/最低价-VAR2和0的较大值的13日[1日权重]移动平均*100
VAR4赋值:如果收盘价*1.2,返回VAR3*13,否则返回VAR3/13的13日指数移动平均
VAR5赋值:34日内最低价的最低值
VAR6赋值:34日内VAR4的最高值
VAR7赋值:如果55日内最低价的最低值,返回1,否则返回0
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7
XL1赋值:最低价的2日简单移动平均*0.96
XL2赋值:最低价的26日简单移动平均*0.85
XL3赋值:1日前的XL1<XL2 AND 1日前的XL1<XL1 AND 1日前的XL1<2日前的XL1
启动赋值:如果XL3,返回0,否则返回VAR8*3
当满足条件启动>10并且(吸拉派落的NOTEXT吸<1ANDREF(吸拉派落的NOTEXT落,0.5))时,在最低价位置画29号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1svMwPs5NYf0RRYDbku_4ww

看了该指标的人还看了:
福将牵牛优化指标 金钻选股    高抛低吸指标
五彩周J指标    60日价值中枢指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表