请选择 进入手机版|继续访问电脑版

主力中枢指标 通达信 主图 缠论 波段 操盘控盘

[复制链接]

admin  管理员

发表于 2018-11-9 08:00:00 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 缠论 波段 操盘控盘 
主力中枢指标 通达信 主图 缠论 波段 操盘控盘 炒股叉第10801张

主力中枢指标 通达信 主图 缠论 波段 操盘控盘 炒股叉第10802张

[lywrap=通达信主图指标公式][lycode=tdx,true]N1:=10;{N1:1,100,10;N2:1,100,10;DISP:=1,3,2};
N2:=10;
DISP:=2;
K:=IF(PERIOD=5,1,{日}
IF(PERIOD=6,1,{周}
IF(PERIOD=7,1,{月}
IF(PERIOD=8,1,{多分钟}
IF(PERIOD=9,1,{多日}
IF(PERIOD=10,1,{季}
IF(PERIOD=11,2,{年}
IF(PERIOD=4,1,{60F}
IF(PERIOD=3,1,{30F}
IF(PERIOD=2,1,{15F}
IF(PERIOD=1,1{5F},1{1F})))))))))))/10;
P1:=PEAK(1,K*N1,1);
P2:=PEAK(1,K*N1,2);
WP1:=PEAKBARS(1,K*N1,1);
WP2:=PEAKBARS(1,K*N1,2);
T1:=TROUGH(2,K*N2,1);
T2:=TROUGH(2,K*N2,2);
WT1:=TROUGHBARS(2,K*N2,1);
WT2:=TROUGHBARS(2,K*N2,2);
TJ1:=P1>T1 AND P2>T2 ;
ZD:=MAX(T1,T2);
ZG:=MIN(P1,P2);
LL:=MIN(T1,T2);
HH:=MAX(P1,P2);
TJ2:=FILTER(ZG>ZD,2);
TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
TJ4:=TJ1&&TJ2&&NOT(TJ3);
TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));
TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);
ZSD:=IF(TJ8,ZD,DRAWNULL);
ZSG:=IF(TJ8,ZG,DRAWNULL);
ZSH:=IF(TJ8,HH,DRAWNULL);
ZSL:=IF(TJ8,LL,DRAWNULL);
STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;
STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;
DRAWTEXT(DISP=2,ZSH,'中枢'),COLORWHITE;
中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,COLORLIRED;
中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,COLORLIGREEN;
{中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;
中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;}
趋势高:PLOYLINE(DISP=3,ZIG(1,K*N1)),COLORLIBLUE;
趋势低:PLOYLINE(DISP=3,ZIG(2,K*N2)),COLORLIBLUE;
局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);
局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);
局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);
局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);
缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
距前高天:=BARSLAST(局部高点预选C=1);
距前低天:=BARSLAST(局部低点预选C=-1);
小值周期:=LOWRANGE(L);
大值周期:=TOPRANGE(H);
低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);
高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);
预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);
低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
距前高天A:=BARSLAST(高保留=1);
距前低天A:=BARSLAST(低保留=-1);
预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);
高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);

预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);
低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
距前高天YA:=BARSLAST(高保留X=1);
距前低天YA:=BARSLAST(低保留X=-1);
预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判断,距前低天YA)=1),1,0);
高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);
预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);
低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);
低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;
DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0)COLORLIRED;
DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0)COLORYELLOW;
DD1:=BARSLAST(ABS(极点保留)!=1);
{DRAWTEXT(极点保留=1,局部极点,'卖'),COLORGREEN;
DRAWTEXT(极点保留=-1,局部极点,'买'),COLORRED;}
MA5:MA(CLOSE,5),COLORFF00FF,LINETHICK2;
判:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORWHITE,LINETHICK2;[/lycode][lycode=tdx2,true]N1赋值:10

N2赋值:10
DISP赋值:2
K赋值:如果周期类型=5,返回1,否则返回如果周期类型=6,返回1,否则返回如果周期类型=7,返回1,否则返回如果周期类型=8,返回1,否则返回如果周期类型=9,返回1,否则返回如果周期类型=10,返回1,否则返回如果周期类型=11,返回2,否则返回如果周期类型=4,返回1,否则返回如果周期类型=3,返回1,否则返回如果周期类型=2,返回1,否则返回如果周期类型=1,返回1,否则返回1/10
P1赋值:最高价K*N1%之字转向的前1个波峰值
P2赋值:最高价K*N1%之字转向的前2个波峰值
WP1赋值:最高价K*N1%之字转向的前1个波峰位置
WP2赋值:最高价K*N1%之字转向的前2个波峰位置
T1赋值:最低价K*N2%之字转向的前1个波谷值
T2赋值:最低价K*N2%之字转向的前2个波谷值
WT1赋值:最低价K*N2%之字转向的前1个波谷位置
WT2赋值:最低价K*N2%之字转向的前2个波谷位置
TJ1赋值:P1>T1 AND P2>T2
ZD赋值:T1和T2的较大值
ZG赋值:P1和P2的较小值
LL赋值:T1和T2的较小值
HH赋值:P1和P2的较大值
TJ2赋值:ZG>ZD的2日过滤
TJ3赋值:ZG=上次TJ2距今天数日前的ZG OR ZD=上次TJ2距今天数日前的ZD
TJ4赋值:TJ1并且TJ2并且取反
TJ5赋值:ZD位于1日前的上次TJ4距今天数日前的ZD和1日前的上次TJ4距今天数日前的ZG之间
TJ6赋值:ZG位于1日前的上次TJ4距今天数日前的ZD和1日前的上次TJ4距今天数日前的ZG之间
TJ7赋值:ZG>1日前的上次TJ4距今天数日前的ZG并且ZD<1日前的上次TJ4距今天数日前的ZD
TJ8赋值:TJ4并且取反
ZSD赋值:如果TJ8,返回ZD,否则返回无效数
ZSG赋值:如果TJ8,返回ZG,否则返回无效数
ZSH赋值:如果TJ8,返回HH,否则返回无效数
ZSL赋值:如果TJ8,返回LL,否则返回无效数
当满足条件TJ8时,在ZSH和ZSL位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画洋红色
当满足条件TJ8时,在ZSD和ZSG位置之间画柱状线,宽度为如果DISP=1,返回3,否则返回0,1不为0则画空心柱.,画洋红色
当满足条件DISP=2时,在ZSH位置书写文字,画白色
输出中枢高:当满足条件DISP=2时以上次TJ8距今天数日前的ZSD位置为顶点画折线连接,CIRCLEDOT,画淡红色
输出中枢低:当满足条件DISP=2时以上次TJ8距今天数日前的ZSG位置为顶点画折线连接,CIRCLEDOT,画淡绿色
输出趋势高:当满足条件DISP=3时以最高价K*N1%的之字转向位置为顶点画折线连接,画淡蓝色
输出趋势低:当满足条件DISP=3时以最低价K*N2%的之字转向位置为顶点画折线连接,画淡蓝色
局部低点预选A赋值:若5日内最低价的最低值<1日前的4日内最低价的最低值则将最近4周期置为1
局部低点预选B赋值:若局部低点预选A=0ANDREF(局部低点预选A,1)=1则将最近2周期置为1
局部低点预选C赋值:如果局部低点预选B=1ANDREF(局部低点预选B,1)=0,返回-1,否则返回0
局部高点预选A赋值:若5日内最高价的最高值>1日前的4日内最高价的最高值则将最近4周期置为1
局部高点预选B赋值:若局部高点预选A=0ANDREF(局部高点预选A,1)=1则将最近2周期置为1
局部高点预选C赋值:如果局部高点预选B=1ANDREF(局部高点预选B,1)=0,返回1,否则返回0
缺口判断赋值:如果最低价>1日前的最高价,返回1,否则返回如果最高价<1日前的最低价,返回-1,否则返回0
距前高天赋值:上次局部高点预选C=1距今天数
距前低天赋值:上次局部低点预选C=-1距今天数
小值周期赋值:当前值是近最低价周期的最小值
大值周期赋值:当前值是近最高价周期的最大值
低保留AA赋值:如果局部低点预选C=-1ANDREF(距前高天,1)>1日前的距前低天ANDLLV(最低价,距前高天+1)<1日前的距前高天+1日内最低价的最低值,返回-1,否则返回0
低保留AB赋值:如果局部低点预选C=-1ANDREF(距前高天,1)<=1日前的距前低天AND(距前高天>=4ORLLV(缺口判断,距前高天)=-1ORLLV(最低价,距前低天+2)<1日前的距前低天+1日内最低价的最低值),返回-1,否则返回0
低保留S赋值:如果(低保留AA=-1OR低保留AB=-1)ANDL<距前高天+1日前的最高价,返回-1,否则返回0
预判赋值:如果(距前低天<4ANDHHV(缺口判断,距前低天)不等于1)ORREF(低保留S,距前低天)=0,返回1,否则返回0
判断赋值:如果局部高点预选C=1ANDREF(距前低天,1)<=1日前的距前高天AND预判=1AND大值周期>距前低天+1日前的小值周期AND大值周期>距前低天日前的小值周期AND大值周期>距前溉涨暗拇笾抵芷?返回天),否则返回1
高保留A赋值:如果局部高点预选C=1ANDREF(距前低天,1)>1日前的距前高天ANDHHV(最高价,距前低天+1)>1日前的距前低天+1日内最高价的最高值,返回1,否则返回0
高保留B赋值:如果局部高点预选C=1ANDREF(距前低天,1)<=1日前的距前高天ANDREF(低保留S,距前低天)=-1AND(距前低天>=4ORHHV(缺口判断,距前低天)=1),返回1,否则返回0
高保留赋值:如果(高保留A=1OR高保留B=1OR判断=1)ANDH>距前低天+1日前的最低价,返回1,否则返回0
预判A赋值:如果(距前高天<4ANDHHV(缺口判断,距前高天)不等于1)ORREF(高保留,距前高天)=0,返回1,否则返回0
判断A赋值:如果局部低点预选C=-1ANDREF(距前高天,1)<=1日前的距前低天AND预判A=1AND小值周期>距前高天+1日前的大值周期AND小值周期>距前高天日前的大值周期AND小值周期>距侨涨暗男≈抵芷?返回低天),否则返回-1
低保留A赋值:如果局部低点预选C=-1ANDREF(距前高天,1)>1日前的距前低天ANDLLV(最低价,距前高天+1)<1日前的距前高天+1日内最低价的最低值,返回-1,否则返回0
低保留B赋值:如果局部低点预选C=-1ANDREF(距前高天,1)<=1日前的距前低天AND(距前高天>=4ORLLV(缺口判断,距前高天)=-1OR判断A=-1),返回-1,否则返回0
低保留赋值:如果(低保留A=-1OR低保留B=-1)ANDL<距前高天+1日前的最高价,返回-1,否则返回0
距前高天A赋值:上次高保留=1距今天数
距前低天A赋值:上次低保留=-1距今天数
预判X赋值:如果(距前低天A<4ANDHHV(缺口判断,距前低天A)不等于1)ORREF(低保留,距前低天A)=0,返回1,否则返回0
判断X赋值:如果局部高点预选C=1ANDREF(距前低天A,1)<=1日前的距前高天AAND预判X=1AND大值周期>距前低天A+1日前的小值周期AND大值周期>距前低天A日前的小值周期AND大值周期>?日前的大值周期,返回嗲案咛霢),否则返回1
高保留XA赋值:如果局部高点预选C=1ANDREF(距前低天A,1)>1日前的距前高天AANDHHV(最高价,距前低天A+1)>1日前的距前低天A+1日内最高价的最高值,返回1,否则返回0
高保留XB赋值:如果局部高点预选C=1ANDREF(距前低天A,1)<=1日前的距前高天AANDREF(低保留,距前低天A)=-1AND(距前低天A>=4ORHHV(缺口判断,距前低天A)=1),返回1,否则返回0
高保留X赋值:如果(高保留XA=1OR高保留XB=1OR判断X=1)ANDH>距前低天A+1日前的最低价,返回1,否则返回0
预判XA赋值:如果(距前高天A<4ANDHHV(缺口判断,距前高天A)不等于1)ORREF(高保留XA,距前高天A)=0,返回1,否则返回0
判断XA赋值:如果局部低点预选C=-1ANDREF(距前高天A,1)<=1日前的距前低天AAND预判XA=1AND小值周期>距前高天A+1日前的大值周期AND小值周期>距前高天A日前的大值周期AND小值周期>?日前的小值周?返回,距前低天A),否则返回-1
低保留XA赋值:如果局部低点预选C=-1ANDREF(距前高天A,1)>1日前的距前低天AANDLLV(最低价,距前高天A+1)<1日前的距前高天A+1日内最低价的最低值,返回-1,否则返回0
低保留XB赋值:如果局部低点预选C=-1ANDREF(距前高天A,1)<=1日前的距前低天AAND(距前高天A>=4ORLLV(缺口判断,距前高天A)=-1OR判断XA=-1),返回-1,否则返回0
低保留X赋值:如果(低保留XA=-1OR低保留XB=-1)ANDL<距前高天A+1日前的最高价,返回-1,否则返回0
距前高天YA赋值:上次高保留X=1距今天数
距前低天YA赋值:上次低保留X=-1距今天数
预判YX赋值:如果(距前低天YA<4ANDHHV(缺口判断,距前低天YA)不等于1)ORREF(低保留X,距前低天YA)=0,返回1,否则返回0
判断YX赋值:如果局部高点预选C=1ANDREF(距前低天YA,1)<=1日前的距前高天YAAND预判YX=1AND大值周期>距前低天YA+1日前的小值周期AND大值周期>距前低天YA日前的小值周期AND大值周期>?日前的大值,返回芷?距前高天YA),否则返回1
高保留YXA赋值:如果局部高点预选C=1ANDREF(距前低天YA,1)>1日前的距前高天YAANDHHV(最高价,距前低天YA+1)>1日前的距前低天YA+1日内最高价的最高值,返回1,否则返回0
高保留YXB赋值:如果局部高点预选C=1ANDREF(距前低天YA,1)<=1日前的距前高天YAANDREF(低保留X,距前低天YA)=-1AND(距前低天YA>=4ORHHV(缺口判断,距前低天YA)=1),返回1,否则返回0
高保留YX赋值:如果(高保留YXA=1OR高保留YXB=1OR判断YX=1)ANDH>距前低天YA+1日前的最低价,返回1,否则返回0
预判YXA赋值:如果(距前高天YA<4ANDHHV(缺口判断,距前高天YA)不等于1)ORREF(高保留YXA,距前高天YA)=0,返回1,否则返回0
判断YXA赋值:如果局部低点预选C=-1ANDREF(距前高天YA,1)<=1日前的距前低天YAAND预判YXA=1AND小值周期>距前高天YA+1日前的大值周期AND小值周期>距前高天YA日前的大值周期AND小值周期>?日前的小,返回抵芷?距前低天YA),否则返回-1
低保留YXA赋值:如果局部低点预选C=-1ANDREF(距前高天YA,1)>1日前的距前低天YAANDLLV(最低价,距前高天YA+1)<1日前的距前高天YA+1日内最低价的最低值,返回-1,否则返回0
低保留YXB赋值:如果局部低点预选C=-1ANDREF(距前高天YA,1)<=1日前的距前低天YAAND(距前高天YA>=4ORLLV(缺口判断,距前高天YA)=-1OR判断YXA=-1),返回-1,否则返回0
低保留YX赋值:如果(低保留YXA=-1OR低保留YXB=-1)ANDL<距前高天YA+1日前的最高价,返回-1,否则返回0
AAAD赋值:如果高保留YX=1AND低保留YX=-1ANDH>1日前的距前高天YA+2日前的最高价,返回1,否则返回如果高保留YX=1AND低保留YX=-1ANDL<1日前的距前低天YA+2日前的最低价,返回-1,否则返回0
极点保留赋值:如果AAAD=0,返回高保留YX+低保留YX,否则返回AAAD
输出局部极点:如果极点保留=-1,返回最低价,否则返回如果极点保留=1,返回最高价,否则返回无效数 CIRCLEDOT 画黄色
当满足条件极点保留=-1时,在局部极点位置画直线起点,当满足条件极点保留=1时,在局部极点位置画直线终点,0表示是否延长.画淡红色
当满足条件极点保留=1时,在局部极点位置画直线起点,当满足条件极点保留=-1时,在局部极点位置画直线终点,0表示是否延长.画黄色
DD1赋值:上次极点保留的绝对值不等于1距今天数
输出MA5:收盘价的5日简单移动平均,COLORFF00FF,线宽为2
输出判:如果MA5<1日前的MA5,返回MA5,否则返回无效数,画白色,线宽为2[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1t7FeONPlg6NjIRfwnqt8DQ

看了该指标的人还看了:
抓妖雄鹰指标    超跌抄底阴线选股
自动波浪指标    福将牵牛优化指标 金钻选股

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表