请选择 进入手机版|继续访问电脑版

金刚波段王指标 通达信 主图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-11-9 08:00:00 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
金刚波段王指标 通达信 主图 波段 短线 买卖点 炒股叉第10793张

金刚波段王指标 通达信 主图 波段 短线 买卖点 炒股叉第10794张

[lywrap=通达信主图指标公式][lycode=tdx,true]N1:6;
A1:DRAWLINE(HIGH>=HHV(HIGH,5),HIGH,LOW<=LLV(LOW,5),LOW,0);
B1:DRAWLINE(LOW<=LLV(LOW,5),LOW,HIGH>=HHV(HIGH,5),HIGH,0);
A2:DRAWLINE(HIGH>=HHV(HIGH,13),HIGH,LOW<=LLV(LOW,13),LOW,0);
B2:DRAWLINE(LOW<=LLV(LOW,13),LOW,HIGH>=HHV(HIGH,13),HIGH,0);
A3:DRAWLINE(HIGH>=HHV(HIGH,34),HIGH,LOW<=LLV(LOW,34),LOW,0);
B3:DRAWLINE(LOW<=LLV(LOW,34),LOW,HIGH>=HHV(HIGH,34),HIGH,0);
A4:DRAWLINE(HIGH>=HHV(HIGH,55),HIGH,LOW<=LLV(LOW,55),LOW,0);
B4:DRAWLINE(LOW<=LLV(LOW,55),LOW,HIGH>=HHV(HIGH,55),HIGH,0);
MTM:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);
买1:=IF(LLV(ZLGJ,2)=LLV(ZLGJ,7) AND COUNT(ZLGJ<0,2) AND CROSS(ZLGJ,MA(ZLGJ,2)),1,0);
卖1:=IF(HHV(ZLGJ,2)=HHV(ZLGJ,7) AND COUNT(ZLGJ>50,2) AND CROSS(MA(ZLGJ,2),ZLGJ),1,0);
DRAWICON(FILTER(买1=1,5),LOW*0.99,7),COLORRED;
STICKLINE(FILTER(买1=1,5),C,O,1,0),COLORRED;
DRAWICON(FILTER(卖1=1,1),H*1.01,8),COLOR00FF00;
STICKLINE(FILTER(卖1=1,1),C,O,1,0),COLOR00FF00;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);
DRAWTEXT(注意 AND 卖1<1,HIGH*1.01,'J'),COLOR00FF00,LINETHICK3;
STICKLINE(注意 AND 卖1<1,O,CLOSE,1,0),COLORYELLOW,LINETHICK2;
时间窗口01:=FILTER(IF(HHVBARS(HIGH,5),0,H),5),COLORFFFF00;
DRAWTEXT(时间窗口01,HIGH*0.99,'5');
时间窗口02:=FILTER(IF(LLVBARS(LOW,5),0,L),5),COLOR00FFFF;
DRAWTEXT(时间窗口02,LOW*0.99,'5');
时间窗口1:=FILTER(IF(HHVBARS(HIGH,13),0,1),13),COLOR00FF00;
DRAWTEXT(时间窗口1,HIGH*0.99,'13');
时间窗口2:=FILTER(IF(LLVBARS(LOW,13),0,1),13),COLOR0000FF;
DRAWTEXT(时间窗口2,LOW*0.99,'13');
时间窗口3:=FILTER(IF(HHVBARS(HIGH,34),0,2),34),COLOR55FF55;
DRAWTEXT(时间窗口3,HIGH*0.99,'34');
时间窗口4:=FILTER(IF(LLVBARS(LOW,34),0,2),34),COLOR5555FF;
DRAWTEXT(时间窗口4,LOW*0.99,'34');
时间窗口5:=FILTER(IF(HHVBARS(HIGH,55),0,30),55),COLOR99FF99;
DRAWTEXT(时间窗口5,HIGH*0.99,'55');
时间窗口6:=FILTER(IF(LLVBARS(LOW,55),0,30),55),COLORDD00FF;
DRAWTEXT(时间窗口6,LOW*0.99,'55');
时间窗口7:=FILTER(IF(HHVBARS(HIGH,89),0,40),89),COLORDDFFDD;
DRAWTEXT(时间窗口7,HIGH*0.99,'89');
时间窗口8:=FILTER(IF(LLVBARS(LOW,89),0,40),89),COLOR0055FF;
DRAWTEXT(时间窗口8,LOW*0.99,'89');
时间窗口9:=FILTER(IF(HHVBARS(HIGH,144),0,50),144),COLORDDFF00;
DRAWTEXT(时间窗口9,HIGH*0.99,'144');
时间窗口10:=FILTER(IF(LLVBARS(LOW,144),0,50),144),COLOR9955FF;
DRAWTEXT(时间窗口10,LOW*0.99,'144');
时间窗口11:=FILTER(IF(HHVBARS(HIGH,233),0,60),233),COLORDDFFFF;
DRAWTEXT(时间窗口11,HIGH*0.99,'233');[/lycode][lycode=tdx2,true]输出N1:6
输出A1:当满足条件最高价>=5日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=5日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.
输出B1:当满足条件最低价<=5日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价>=5日内最高价的最高值时,在最高价位置画直线终点,0表示是否延长.
输出A2:当满足条件最高价>=13日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=13日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.
输出B2:当满足条件最低价<=13日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价>=13日内最高价的最高值时,在最高价位置画直线终点,0表示是否延长.
输出A3:当满足条件最高价>=34日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=34日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.
输出B3:当满足条件最低价<=34日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价>=34日内最高价的最高值时,在最高价位置画直线终点,0表示是否延长.
输出A4:当满足条件最高价>=55日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=55日内最低价的最低值时,在最低价位置画直线终点,0表示是否延长.
输出B4:当满足条件最低价<=55日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价>=55日内最高价的最高值时,在最高价位置画直线终点,0表示是否延长.
MTM赋值:收盘价-1日前的收盘价
ZLGJ赋值:100*MTM的N1日指数移动平均的N1日指数移动平均/MTM的绝对值的N1日指数移动平均的N1日指数移动平均
买1赋值:如果2日内ZLGJ的最低值=7日内ZLGJ的最低值ANDCOUNT(ZLGJ<0,2)ANDCROSS(ZLGJ,ZLGJ的2日简单移动平均),返回1,否则返回0
卖1赋值:如果2日内ZLGJ的最高值=7日内ZLGJ的最高值ANDCOUNT(ZLGJ>50,2)ANDCROSS(ZLGJ的2日简单移动平均,ZLGJ),返回1,否则返回0
当满足条件买1=1的5日过滤时,在最低价*0.99位置画7号图标,画红色
当满足条件买1=1的5日过滤时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
当满足条件卖1=1的1日过滤时,在最高价*1.01位置画8号图标,COLOR00FF00
当满足条件卖1=1的1日过滤时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
BDGD赋值:2日内J的最高值=8日内J的最高值 AND J>80
注意赋值:如果1日前的J-0.01上穿JANDREF(BDGD,1),返回1,否则返回0
当满足条件注意AND卖1<1时,在最高价*1.01位置书写文字,COLOR00FF00,线宽为3
当满足条件注意AND卖1<1时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色,线宽为2
时间窗口01赋值:如果5日内最高价距今天数,返回0,否则返回最高价的5日过滤,COLORFFFF00
当满足条件时间窗口01时,在最高价*0.99位置书写文字
时间窗口02赋值:如果5日内最低价距今天数,返回0,否则返回最低价的5日过滤,COLOR00FFFF
当满足条件时间窗口02时,在最低价*0.99位置书写文字
时间窗口1赋值:如果13日内最高价距今天数,返回0,否则返回1的13日过滤,COLOR00FF00
当满足条件时间窗口1时,在最高价*0.99位置书写文字
时间窗口2赋值:如果13日内最低价距今天数,返回0,否则返回1的13日过滤,COLOR0000FF
当满足条件时间窗口2时,在最低价*0.99位置书写文字
时间窗口3赋值:如果34日内最高价距今天数,返回0,否则返回2的34日过滤,COLOR55FF55
当满足条件时间窗口3时,在最高价*0.99位置书写文字
时间窗口4赋值:如果34日内最低价距今天数,返回0,否则返回2的34日过滤,COLOR5555FF
当满足条件时间窗口4时,在最低价*0.99位置书写文字
时间窗口5赋值:如果55日内最高价距今天数,返回0,否则返回30的55日过滤,COLOR99FF99
当满足条件时间窗口5时,在最高价*0.99位置书写文字
时间窗口6赋值:如果55日内最低价距今天数,返回0,否则返回30的55日过滤,COLORDD00FF
当满足条件时间窗口6时,在最低价*0.99位置书写文字
时间窗口7赋值:如果89日内最高价距今天数,返回0,否则返回40的89日过滤,COLORDDFFDD
当满足条件时间窗口7时,在最高价*0.99位置书写文字
时间窗口8赋值:如果89日内最低价距今天数,返回0,否则返回40的89日过滤,COLOR0055FF
当满足条件时间窗口8时,在最低价*0.99位置书写文字
时间窗口9赋值:如果144日内最高价距今天数,返回0,否则返回50的144日过滤,COLORDDFF00
当满足条件时间窗口9时,在最高价*0.99位置书写文字
时间窗口10赋值:如果144日内最低价距今天数,返回0,否则返回50的144日过滤,COLOR9955FF
当满足条件时间窗口10时,在最低价*0.99位置书写文字
时间窗口11赋值:如果233日内最高价距今天数,返回0,否则返回60的233日过滤,COLORDDFFFF
当满足条件时间窗口11时,在最高价*0.99位置书写文字[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1LnRMzcPoDCMAyG5dNGOfsw

看了该指标的人还看了:
春笋集合指标 胜率92.5% 信号少    操盘利器CCI指标
看色操作指标    必胜客指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表