请选择 进入手机版|继续访问电脑版

精品布林指标 通达信 主图 BOLL指标 波段 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-11-9 08:00:00 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: BOLL指标 波段 短线 买卖点 操盘控盘 
精品布林指标 通达信 主图 BOLL指标 波段 短线 买卖点 操盘控盘 炒股叉第10791张

精品布林指标 通达信 主图 BOLL指标 波段 短线 买卖点 操盘控盘 炒股叉第10792张

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=20;
DRAWGBK(CURRBARSCOUNT=1, RGB(110,108,108),RGB(88,30,0),0,'',0);
BOLL:MA(CLOSE,N),COLORGREEN,LINETHICK2;
IF(BOLL>REF(BOLL,1),BOLL,DRAWNULL),COLORRED,LINETHICK2;
UPPER:BOLL+2*STD(CLOSE,N),COLORCYAN;
LOWER:BOLL-2*STD(CLOSE,N),COLOR0088FF;
{量能平台}
N1:=30;
T1:=CONST(HHVBARS(V,N1));
T0:IF(CURRBARSCOUNT<=N1+7,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),LINETHICK3;
IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT;
DRAWTEXT(ISLASTBAR,T0,' 量能平台');
STICKLINE(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95,100,0),COLORWHITE,LINETHICK3;
DRAWNUMBER(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95),LINETHICK3;
止损点:=(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95),LINETHICK3;
DRAWTEXT(ISLASTBAR ,止损点,'               止损点'),LINETHICK3;
{压力一}
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),COLORYELLOW;
MA18:=MA(C,18);
VAR1:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR2:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);
{红}
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),COLOR0000FF;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{蓝}
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLORFF9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.5,0),COLORFFCC00;
{粉}
STICKLINE(VAR1,C,(O+C)/2,3,0),COLORFF11FF;
STICKLINE(VAR1,C,(O+C)/2,0.5,0),COLORFFDDFF;
{灰}
STICKLINE(VAR2,C,(O+C)/2,3,0),COLOR999999;
STICKLINE(VAR2,C,(O+C)/2,0.5,0),COLORFFBBFF;
{绿}
STICKLINE(VAR3,O,(O+C)/2,3,0),COLOR00BB00;
STICKLINE(VAR3,O,(O+C)/2,0.5,0),COLOR00FF00;
卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'卖'),COLORGREEN;
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'买'),COLORRED;
加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
DRAWTEXT(FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3),LOW-0.03,'加'),COLORWHITE;
跟:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(跟,LOW*0.96,'跟'),COLORCC66FF;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));  
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);
VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
今离场价:REF(离场,1),COLOR0000FF,NODRAW;
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:REF(明进场价,1),COLORGREEN,NODRAW;
TJ1:=L< REF(L,1) OR REF(L,1)<REF(L,2);
TJ2:=REF(C,1)<REF(O,1);
TJ3:=C>O;
XG:=TJ1 AND TJ2 AND TJ3;
DRAWTEXT(XG,REF(C,2),'-------------------'),COLORRED;
上涨家数:INDEXADV,COLOR0080FF,NODRAW;
下跌家数:INDEXDEC,COLORGREEN,NODRAW;
自动C:=INDEXC;
自动O:=INDEXO;
自动H:=INDEXH;
自动L:=INDEXL;
大盘低:=CONST(LLV(自动L,120));
大盘高:=CONST(HHV(自动H,120));
大盘差:=大盘高-大盘低;
当前低:=CONST(LLV(L,120));
当前高:=CONST(HHV(H,120));
当前差:=当前高-当前低;
比:=当前差*1.2/大盘差;
变C:=当前低+(自动C-大盘低)*比;
变H:=当前低+(自动H-大盘低)*比;
变L:=当前低+(自动L-大盘低)*比;
变O:=当前低+(自动O-大盘低)*比;
STICKLINE(CURRBARSCOUNT<10 AND 变C<变O,变H,变L,0,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<10 AND 变C>=变O,变H,变L,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<10 AND 变C<变O,变O,变C,2,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<10 AND 变C>=变O,变O,变C,2,0),COLORMAGENTA;
DRAWKLINE(H,O,L,C);
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLORCYAN;
DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLORCYAN;
DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK),COLORWHITE;
;
DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLORCYAN;
DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3)),COLORRED;
;
DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLORWHITE;
DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLORWHITE;
DRAWTEXT_FIX  (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLORWHITE;
DRAWTEXT_FIX  (1,0.43,0.15,0,'收益:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLORWHITE;
VAR111:=ZIG(3,13);
STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;
DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
VAR113:=HHV(HIGH,60);
VAR114:=LLV(LOW,30);
VAR115:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR116:=(VAR113+VAR114+VAR115)/3;
VAR117:=EMA(VAR116,5);
K01:=EMA(VAR117,5)*2, COLORFF00FF;
D01:=EMA(K01,5),  COLORWHITE;
J01:=K01*3-D01*2, COLORYELLOW;
ENTERLONG:=CROSS(K01,D01);
EXITLONG:=CROSS(D01,K01);
B01:=(DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),L*0.98,1))*D01*2/3;
B02:=IF(TROUGHBARS(3,15,1)=1 AND HIGH>LOW+0.01,20,0);
必卖:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN,LINETHICK1;
QQ:=必卖=80;
B03:=((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)));
V1:=EMA(CLOSE,60)-EMA(CLOSE,300);
V2:=EMA(V1,300);
V3:=(CLOSE-(LOW,8))/((HIGH,8)-LLV(LOW,8))*100;
V4:=SMA(V3,2,1),NODRAW;
V5:=SMA(V4,2,1),NODRAW;
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,3);
大涨:=(V7 AND COUNT(V7,3)=1);
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
{}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
利润同比:=STRCAT(' 利润同比: ',CON2STR(FINANCE(43),2));
收入同比:=STRCAT(' 收入同比: ',CON2STR(FINANCE(44),2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率), 利润同比), 收入同比));
{}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
{}
DRAWTEXT_FIX(ISLASTBAR,0.005,0.01,0,财务系数),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,当前业绩),COLORLIMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.115,0,股本市值),COLORYELLOW;[/lycode][lycode=tdx2,true]N赋值:20
填充背景
输出BOLL:收盘价的N日简单移动平均,画绿色,线宽为2
如果BOLL>1日前的BOLL,返回BOLL,否则返回无效数,画红色,线宽为2
输出UPPER:BOLL+2*收盘价的N日估算标准差,画青色
输出LOWER:BOLL-2*收盘价的N日估算标准差,COLOR0088FF
N1赋值:30
T1赋值:N1日内成交量(手)距今天数的最后一日取值设为常数
输出T0:如果到最后交易的周期<=N1+7,返回如果T1=0,返回收盘价,否则返回T1日前的收盘价的最后一日取值设为常数,否则返回无效数,线宽为3
如果到最后交易的周期=T1+1,返回T0,否则返回无效数,CIRCLEDOT
当满足条件是否最后一个周期时,在T0位置书写文字
当满足条件是否最后一个周期时,在5日内收盘价的最高值*0.95-0.01和5日内收盘价的最高值*0.95位置之间画柱状线,宽度为100,0不为0则画空心柱.,画白色,线宽为3
当满足条件是否最后一个周期时,在5日内收盘价的最高值*0.95-0.01位置书写数字,线宽为3
止损点赋值:(是否最后一个周期,5日内收盘价的最高值*0.95-0.01,5日内收盘价的最高值*0.95),线宽为3
当满足条件是否最后一个周期时,在止损点位置书写文字,线宽为3
TY赋值:收盘价
A1赋值:10日前的TY=2*10+1日内TY的最高值
B1赋值:A1的10日过滤
C1赋值:若B1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:A2的10日过滤
C2赋值:若B2则将最近10+1周期置为1
LD赋值:C2的10日过滤
输出前期高位:上次HD距今天数日前的收盘价,COLOR00FF00,POINTDOT
当满足条件收盘价时,在前期高位和前期高位位置之间画柱状线,宽度为8,0不为0则画空心柱.,画黄色
MA18赋值:收盘价的18日简单移动平均
VAR1赋值:收盘价=4日内收盘价的最高值 AND 1日前的收盘价=4日内收盘价的最低值
VAR2赋值:收盘价=4日内收盘价的最低值 AND (1日前的收盘价<2日前的收盘价 OR 1日前的收盘价<3日前的收盘价) OR 1日前的收盘价=4日内收盘价的最低值 AND 收盘价<2日前的收盘价 OR 2日前的收盘价=4日内收盘价的最低值 AND 1日前的收盘价=4日内收盘价的最高值 AND 收盘价<1日前的收盘价 OR 3日前的收盘价=4日内收盘价的最低值 AND 收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VAR3赋值:1日前的收盘价=4日内收盘价的最低值 AND 收盘价>=2日前的收盘价 OR 2日前的收盘价=4日内收盘价的最低值 AND 1日前的收盘价<=3日前的收盘价 AND 2日前的收盘价<4日前的收盘价 AND 收盘价>=1日前的收盘价
A赋值:(3*收盘价+最低价+开盘价+最高价)/6
VAR4赋值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/210
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
CB赋值:VAR4的13日指数移动平均
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORCC66FF
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF9900
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFCC00
当满足条件VAR1时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF11FF
当满足条件VAR1时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFDDFF
当满足条件VAR2时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR999999
当满足条件VAR2时,在收盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFBBFF
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00BB00
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00FF00
卖赋值:2日内DX的最高值=7日内DX的最高值 AND 统计2日中满足DX>50的天数 AND DX的2日简单移动平均上穿DX
当满足条件卖=1的1日过滤时,在最高价*1.02位置书写文字,画绿色
买赋值:2日内DX的最低值=7日内DX的最低值 AND 统计2日中满足DX<0的天数 AND DX上穿DX的2日简单移动平均
当满足条件买=1的5日过滤时,在最低价-0.03位置书写文字,画红色
加仓赋值:(收盘价-1日前的收盘价)/1日前的收盘价的5日指数移动平均*100的3日[1日权重]移动平均*10
当满足条件(加仓上穿0ORCROSS(收盘价,CB))AND买=1的3日过滤时,在最低价-0.03位置书写文字,画白色
跟赋值:MA18>=3日前的MA18 AND 收盘价上穿MA18
当满足条件跟时,在最低价*0.96位置书写文字,COLORCC66FF
JRH赋值:2日内收盘价的最高值
JRL赋值:2日内收盘价的最低值
VAR01赋值:(收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价)
VAR02赋值:(1日前的VAR01 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR03赋值:(1日前的VAR02 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR04赋值:(1日前的VAR03 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR05赋值:(1日前的VAR04 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR06赋值:(1日前的VAR05 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR07赋值:(1日前的VAR06 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR08赋值:(1日前的VAR07 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR09赋值:(1日前的VAR08 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARA赋值:(1日前的VAR09 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARB赋值:(1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARC赋值:(1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARD赋值:(收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价)
VARE赋值:(1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARF赋值:(1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR010赋值:(1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR011赋值:(1日前的VAR010 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR012赋值:(1日前的VAR011 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR013赋值:(1日前的VAR012 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR014赋值:(1日前的VAR013 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR015赋值:(1日前的VAR014 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR016赋值:(1日前的VAR015 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR017赋值:(1日前的VAR016 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR018赋值:(1日前的VAR017 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR019赋值:((1日前的VARDORVAREORVARFORVAR010ORVAR011ORVAR012ORVAR013ORVAR014ORVAR015ORVAR016ORVAR017ORVAR018) AND VAR01)
VAR1A赋值:((1日前的VAR01ORVAR02ORVAR03ORVAR04ORVAR05ORVAR06ORVAR07ORVAR08ORVAR09ORVARAORVARBORVARC) AND VARD)
红色持股赋值:VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW
离场赋值:如果红色持股,返回JRL,否则返回无效数
明离场价赋值:离场,COLORFF99FF,NODRAW
青色观望赋值:VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW
进赋值:如果青色观望,返回JRH,否则返回无效数
输出今离场价:1日前的离场,COLOR0000FF,NODRAW
明进场价赋值:进,COLOR33AACC,NODRAW
输出今进场价:1日前的明进场价,画绿色,NODRAW
TJ1赋值:最低价< 1日前的最低价 OR 1日前的最低价<2日前的最低价
TJ2赋值:1日前的收盘价<1日前的开盘价
TJ3赋值:收阳线
XG赋值:TJ1 AND TJ2 AND TJ3
当满足条件XG时,在2日前的收盘价位置书写文字,画红色
输出上涨家数:大盘的上涨家数,COLOR0080FF,NODRAW
输出下跌家数:大盘的下跌家数,画绿色,NODRAW
自动C赋值:大盘的收盘价
自动O赋值:大盘的开盘价
自动H赋值:大盘的最高价
自动L赋值:大盘的最低价
大盘低赋值:120日内自动L的最低值的最后一日取值设为常数
大盘高赋值:120日内自动H的最高值的最后一日取值设为常数
大盘差赋值:大盘高-大盘低
当前低赋值:120日内最低价的最低值的最后一日取值设为常数
当前高赋值:120日内最高价的最高值的最后一日取值设为常数
当前差赋值:当前高-当前低
比赋值:当前差*1.2/大盘差
变C赋值:当前低+(自动C-大盘低)*比
变H赋值:当前低+(自动H-大盘低)*比
变L赋值:当前低+(自动L-大盘低)*比
变O赋值:当前低+(自动O-大盘低)*比
当满足条件到最后交易的周期<10AND变C<变O时,在变H和变L位置之间画柱状线,宽度为0,0不为0则画空心柱.,画绿色
当满足条件到最后交易的周期<10AND变C>=变O时,在变H和变L位置之间画柱状线,宽度为0,0不为0则画空心柱.,画洋红色
当满足条件到最后交易的周期<10AND变C<变O时,在变O和变C位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
当满足条件到最后交易的周期<10AND变C>=变O时,在变O和变C位置之间画柱状线,宽度为2,0不为0则画空心柱.,画洋红色
K线
当满足条件1时,在横轴0.00纵轴0位置书写文字画青色
当满足条件1时,在横轴0.06纵轴0位置书写文字,画白色
当满足条件1时,在横轴0.14纵轴0位置书写文字画青色
当满足条件1时,在横轴0.20纵轴0位置书写文字,画白色

当满足条件1时,在横轴0.00纵轴0.05位置书写文字画青色
当满足条件1时,在横轴0.06纵轴0.05位置书写文字,画红色

当满足条件1时,在横轴0.00纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.06纵轴0.15位置书写数字,画白色
当满足条件1时,在横轴0.22纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.26纵轴0.15位置书写数字,画白色
当满足条件1时,在横轴0.31纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.38纵轴0.15位置书写数字,画白色
当满足条件1时,在横轴0.43纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.47纵轴0.15位置书写数字,画白色
VAR111赋值:收盘价13%的之字转向
当满足条件(2日前的VAR111<1日前的VAR111)AND(VAR111<1日前的VAR111)时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR66FF00
当满足条件当满足条件(2日前的VAR111<1日前的VAR111)AND(VAR111<1日前的VAR111)时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.时,在横轴0.00纵轴0.11位置书写文字,COLOR00FF00,线宽为1
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:(DIF-DEA)*2
VAR113赋值:60日内最高价的最高值
VAR114赋值:30日内最低价的最低值
VAR115赋值:(收盘价-收盘价的32日简单移动平均)/收盘价的32日简单移动平均*100
VAR116赋值:(VAR113+VAR114+VAR115)/3
VAR117赋值:VAR116的5日指数移动平均
K01赋值:VAR117的5日指数移动平均*2, COLORFF00FF
D01赋值:K01的5日指数移动平均,  画白色
J01赋值:K01*3-D01*2, 画黄色
ENTERLONG赋值:K01上穿D01
EXITLONG赋值:D01上穿K01
B01赋值:(当满足条件(收盘价5%的之字转向>1日前的收盘价5%的之字转向)AND(1日前的收盘价5%的之字转向<=2日前的收盘价5%的之字转向)AND(2日前的收盘价5%的之字转向<=3日前的收盘价5%的之字转向)时,在最低价*0.98位置画1号图标)*D01*2/3
B02赋值:如果收盘价15%之字转向的前1个波谷位置=1ANDHIGH>最低价+0.01,返回20,否则返回0
必卖赋值:如果收盘价15%之字转向的前1个波峰位置=1,返回80,否则返回100,画绿色,线宽为1
QQ赋值:必卖=80
B03赋值:((收盘价5%的之字转向>1日前的收盘价5%的之字转向) AND (1日前的收盘价5%的之字转向<=2日前的收盘价5%的之字转向) AND (2日前的收盘价5%的之字转向<=3日前的收盘价5%的之字转向))
V1赋值:收盘价的60日指数移动平均-收盘价的300日指数移动平均
V2赋值:V1的300日指数移动平均
V3赋值:(收盘价-(最低价,8))/((最高价,8)-8日内最低价的最低值)*100
V4赋值:V3的2日[1日权重]移动平均,NODRAW
V5赋值:V4的2日[1日权重]移动平均,NODRAW
V6赋值:收盘价/3日前的收盘价>=1.1
V7赋值:若V6则将最近3周期置为1
大涨赋值:(V7 AND 统计3日中满足V7的天数=1)
总股本赋值:字符串相加
流通盘赋值:字符串相加
全流通赋值:字符串相加
市值赋值:字符串相加
上市日期赋值:字符串相加
股本市值赋值:字符串相加
市盈率赋值:字符串相加
市销率赋值:字符串相加
市净率赋值:字符串相加
净资收益率赋值:字符串相加
毛利率赋值:字符串相加
净利润率赋值:字符串相加
主营利润率赋值:字符串相加
利润同比赋值:字符串相加
收入同比赋值:字符串相加
当前业绩赋值:字符串相加
X1赋值:(流动资产-流动负债)/总资产*1.2
X2赋值:(未分配利润+资本公积金)/总资产*1.4

X3赋值:营业利润/总资产*3.3
X4赋值:股东权益(净资产)/流动负债*0.6
X5赋值:营业收入/流动负债*0.999
Z值赋值:X1+X2+X3+X4+X5
预警赋值:如果Z值<1.2,返回'重警',否则返回如果Z值>=1.2ANDZ值<2.6,返回'轻警',否则返回'无警'
财务预警赋值:字符串相加
优质资产率赋值:字符串相加

现金负债比赋值:字符串相加

财务系数赋值:字符串相加
当满足条件是否最后一个周期时,在横轴0.005纵轴0.01位置书写文字,画青色
当满足条件是否最后一个周期时,在横轴0.005纵轴0.06位置书写文字,画淡洋红色
当满足条件是否最后一个周期时,在横轴0.005纵轴0.115位置书写文字,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1dBNzX3VvrZOBBE1BSe83eQ

看了该指标的人还看了:
超牛散户发财就跑与超级波段王组合指标    主力吸筹指标
紫黄同现必涨指标    狂龙探底指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表