请选择 进入手机版|继续访问电脑版

600万指标 每一波赚钱 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-11-8 08:00:22 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
买进信号反应绝对灵敏,出信号即可跟进,做波段的第一利器
600万指标 每一波赚钱 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10775张

600万指标 每一波赚钱 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10776张

[lywrap=通达信主图指标公式][lycode=tdx,true]回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);
经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;
MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))) /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}
回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));
上线:=SMA(C,6.5,1);
一号支撑线:SMA(C,14.5,1);
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
上线2:=SMA(C,3.5,1);
DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,55),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'减仓') ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),COLORBLUE,LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
DRAWTEXT( CROSS(上线1,上线) AND 上线1>操作,LOW *0.92,'买进' ),COLORYELLOW;
VAR1:LLV(A7,21);
VAR2:HHV(A7,30);
DRAWTEXT( CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 AND CLOSE>VAR1,LOW *0.98,'见底' ),COLORYELLOW;
YCX:=操作>=REF(操作,1);
H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORYELLOW;
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,COLORYELLOW;
D:=MA(CLOSE,89)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;
RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K:=SMA(RSV,3,1);
D1:=SMA(K,3,1);
J:=3*K-2*D1;
VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
F:=MA(E,3)+0.03;
G:=MA(E,1);
DRAWICON(CROSS(F,G) AND J>65,HIGH*1.02,15),COLORGREEN;
DRAWICON(CROSS(G,F),LOW *0.9,9),COLORYELLOW;
DRAWTEXT(CLOSE>OPEN AND H1<C AND O<L1 AND YCX AND CROSS(上线1,操作) AND LOW>VAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT( CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),COLORYELLOW;

DRAWTEXT(CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT(CLOSE>OPEN AND 操作>上线 AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
DRAWTEXT(CLOSE>OPEN AND CROSS(上线,一号支撑线) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,3.2,0),COLORBB00FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.7,0),COLORFF33FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.1,0), COLORFF66FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,1.5,0),COLORFF99FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;[/lycode][lycode=tdx2,true]回归斜率线A赋值:收盘价的4日线性回归斜率*20+收盘价的42日指数移动平均
经典RL赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
经典K赋值:经典RL的3日[1日权重]移动平均
经典D赋值:经典K的3日[1日权重]移动平均
经典J赋值:3*经典K-2*经典D
MAHL1赋值:100*(((最高价+最低价)/2的3日指数移动平均-30日内(最高价+最低价)/2的5日指数移动平均的最低值-(最高价的20日指数移动平均-最低价的20日指数移动平均)) /(30日内(最高价+最低价)/2的5日指数移动平均的最低值-(最高价的20日指数移动平均-最低价的20日指数移动平均)))
MAHL2赋值:如果收盘价的2日指数移动平均>回归斜率线AANDMAHL1>0,返回收盘价的3日指数移动平均,否则返回30日内(最高价+最低价)/2的5日指数移动平均的最低值
MAHL3赋值:如果收盘价的2日指数移动平均>回归斜率线AANDMAHL1>0,返回30日内(最高价+最低价)/2的5日指数移动平均的最低值,否则返回收盘价的5日指数移动平均
输出回归斜率带:画带状线
上线赋值:收盘价的6.5日[1日权重]移动平均
输出一号支撑线:收盘价的14.5日[1日权重]移动平均
上线1赋值:收盘价的3日[1日权重]移动平均
一号支撑线1赋值:收盘价的8日[1日权重]移动平均
上线2赋值:收盘价的3.5日[1日权重]移动平均
当满足条件一号支撑线1上穿上线1时,在最高价*1.08位置书写文字,COLOR00FF00
BBI赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的25日简单移动平均)/4
UPR赋值:BBI+3*BBI的13日估算标准差,线宽为2
DWN赋值:BBI-3*BBI的13日估算标准差
安全赋值:收盘价的55日简单移动平均,线宽为2
LC赋值:1日前的收盘价
RSI赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿RSIANDCLOSE<上线1时,在最高价*1.04位置书写文字 ,COLORFF9966,线宽为2
A7赋值:(2*收盘价+最高价+最低价)/4
输出操作:A7的5日简单移动平均,画蓝色,线宽为2
操作1赋值:A7的5日简单移动平均*1.03,线宽为2
操作2赋值:A7的5日简单移动平均*0.97,线宽为2
当满足条件上线1上穿上线AND上线1>操作时,在最低价*0.92位置书写文字,画黄色
输出VAR1:21日内A7的最低值
输出VAR2:30日内A7的最高值
当满足条件上线1上穿操作AND上线1<一号支撑线AND上线1<一号支撑线1AND上线1<上线ANDCLOSE>VAR1时,在最低价*0.98位置书写文字,画黄色
YCX赋值:操作>=1日前的操作
H1赋值:上线和一号支撑线1的较大值和一号支撑线的较大值
L1赋值:上线和一号支撑线1的较小值和一号支撑线的较小值
当满足条件上线1上穿一号支撑线1AND上线1>操作时,在最低价*0.98位置书写文字,画黄色
SK赋值:(A7-VAR1)/(VAR2-VAR1)*100的7日指数移动平均
SD赋值:0.667*1日前的SK+0.333*SK的5日指数移动平均
M1赋值:1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975
M2赋值:1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980
M3赋值:1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985
当满足条件如果统计13日中满足收盘价<1日前的收盘价的天数/13>6/10ANDCOUNT(SK>SD,6)ANDREF(最低价,5)=120日内最低价的最低值ANDREF(收盘价>=开盘价,4)ANDREF(收阳线,3)ANDREF(收阳线,2)ANDREF(开盘价>CLOS,返回?,否则返回?时,在,1)ANDOPEN>1日前的收盘价,1,0)位置书写文字 ,画黄色
D赋值:收盘价的89日简单移动平均-收盘价的10日简单移动平均/3
当满足条件如果收盘价<DANDVOL/240>成交量(手)的5日简单移动平均/240ANDCLOSE>1日前的收盘价*1.08ANDCLOSE<收盘价的13日简单移动平均*1.3,返回1,否则返回0时,在最低价*0.88位置书写文字,画棕色
RSV赋值:(收盘价-25日内最低价的最低值)/(25日内最高价的最高值-25日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D1赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D1
VAR3赋值:(2*收盘价+最高价+最低价)/3
VAR4赋值:VAR3的4日指数移动平均的4日指数移动平均的4日指数移动平均
E赋值:(VAR4-1日前的VAR4)/1日前的VAR4*100
F赋值:E的3日简单移动平均+0.03
G赋值:E的1日简单移动平均
当满足条件F上穿GANDJ>65时,在最高价*1.02位置画15号图标,画绿色
当满足条件G上穿F时,在最低价*0.9位置画9号图标,画黄色
当满足条件收盘价>OPENANDH1<CANDO<L1ANDYCXANDCROSS(上线1,操作)ANDLOW>VAR1AND上线1>一号支撑线ANDJ<90时,在最低价*0.9位置书写文字,画红色
当满足条件上线1上穿操作ANDM1ANDM2ANDM3时,在最低价*0.94位置书写文字,画黄色
当满足条件收盘价>OPENAND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCLOSE>收盘价的一号支撑线日简单移动平均AND操作>=操作日前的收盘价ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90时,在最低价*0.9位置书写文字,画红色
当满足条件收盘价>OPENAND操作>上线AND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90时,在最低价*0.86位置书写文字,画红色
当满足条件收盘价>OPENANDCROSS(上线,一号支撑线)ANDLOW>VAR1ANDJ<90时,在最低价*0.86位置书写文字,画红色
当满足条件收盘价>1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件收盘价<OANDC>1日前的收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFCC00
当满足条件收盘价>1日前的收盘价ANDC>开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000055

当满足条件收盘价>1日前的收盘价ANDC>开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR000077

当满足条件收盘价>1日前的收盘价ANDC>开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLOR000099
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000BB
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR0000DD
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR0000FF
当满足条件收盘价=1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLOR999999
当满足条件收盘价=1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画白色
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR555555
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR777777
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLOR999999
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORBBBBBB
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORDDDDDD
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFFFFFF
当满足条件收盘价<1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
当满足条件收盘价<1日前的收盘价ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFCC00
当满足条件收盘价<1日前的收盘价ANDC<开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR990000
当满足条件收盘价<1日前的收盘价ANDC<开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLORCC0000
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLORFF4400
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF8800
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORFFCC00
当满足条件J上穿D1ANDJ<70时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLORBB00FF
当满足条件J上穿D1ANDJ<70时,在收盘价和开盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLORFF33FF
当满足条件J上穿D1ANDJ<70时,在收盘价和开盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱., COLORFF66FF
当满足条件J上穿D1ANDJ<70时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF99FF
当满足条件J上穿D1ANDJ<70时,在收盘价和开盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORFFBBFF
当满足条件J上穿D1ANDJ<70时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFFDDFF[/lycode][/lywrap]
分享地址(已复制到剪切板):下载地址:https://pan.baidu.com/s/1EhXLEUIDNLZPR418K2fBUg

看了该指标的人还看了:
主力进场指标    倾家荡产底部买指标
牛熊分界线指标    堪称一绝指标

举报 使用道具

回复

精彩评论1

忆笑  新手上路

发表于 2018-11-8 16:10:42 | 显示全部楼层

管理真是好人啊

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表