请选择 进入手机版|继续访问电脑版

多空预警指标 通达信 副图 波段 无未来函数 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-11-8 08:00:22 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
多空预警指标 通达信 副图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10771张

多空预警指标 通达信 副图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10772张

[lywrap=通达信副图指标公式][lycode=tdx,true]CHECK1:=-1;
VAR1:=IF(CHECK1<0,(HIGH+LOW+CLOSE)/3,0);
VAR2:=IF(CHECK1<0,(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14)),0);
VAR3:=IF(CHECK1<0,(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70)),0);
VAR4:=IF(CHECK1<0,IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<200,10,0),0);
VAR5:=IF(CHECK1<0,IF(VAR2<=-150 AND VAR2>-200 AND VAR3<=-150 AND VAR3>-200,-10,VAR4),0);
VAR6:=IF(CHECK1<0,(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100,0);
VAR7:=IF(CHECK1<0,100-ABS(VAR6),0);
VAR8:=IF(CHECK1<0,IF(VAR7<90,VAR7,100),0);
PJX:=IF(CHECK1<0,MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20,0);
短期强弱:PJX,COLORYELLOW;
VAR1A:=IF(PJX>0,PJX,0);
VAR1B:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,VAR5))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR8<100;
VAR1D:=VAR1A<48 AND VAR1B<60 AND VAR8<100;
DRAWTEXT(VAR1D AND COUNT(VAR1D,30)=1,80,'短线反弹'),COLORRED;
STICKLINE(VAR1D AND COUNT(VAR1D,30)=1,60,80,5,0),COLORRED;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,80,'短线高点'),COLORFFCC66;
STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,60,80,5,0),COLORFFCC66;
VAR2C:=IF(VAR3>=200 AND VAR2>=150,15,IF(VAR3<=-200 AND VAR2<=-150,-15,0))+30;
VAR2E:=VAR1A<48 AND VAR2C<30 AND VAR8<100;
VAR2F:=VAR1A<48 AND VAR2C>30 AND VAR8<100;
DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,50,'短线反弹2'),COLORRED;
STICKLINE(VAR2E AND COUNT(VAR2E,30)=1,30,50,5,0),COLORRED;
DRAWTEXT(VAR2F AND COUNT(VAR2F,30)=1,50,'短线高点2'),COLORFFCC66;
STICKLINE(VAR2F AND COUNT(VAR2F,30)=1,30,50,5,0),COLORFFCC66;
VAR3D:=IF(VAR3<=200 AND VAR2<=150,-15,IF(VAR3>=-200 AND VAR2>=-150,15,VAR5));
VAR3E:=VAR3D>0 AND VAR8<100;
VAR3F:=VAR1A<48 AND VAR3D<0 AND VAR8<100;
DRAWTEXT(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,'短线反弹3'),COLORRED;
STICKLINE(VAR7<90 AND VAR2+VAR3<=0 AND VAR3F AND COUNT(VAR3F,30)=1,20,0,5,0),COLORRED;
DRAWTEXT(VAR3E AND COUNT(VAR3E,30)=1,20,'短线高点3'),COLORFFCC66;
STICKLINE(VAR3E AND COUNT(VAR3E,30)=1,20,0,5,0),COLORFFCC66;
强势线:60,COLORRED;
VAR9:=IF(VAR7<90,40,30);
分界线:30,COLORFFFFFF;
STICKLINE(FILTER(VAR1B=45,5),-20,-10,5,0),COLORFFFFFF;
DRAWTEXT(FILTER(VAR1B=45,5),0,'强支撑'),COLORFFFFFF;
STICKLINE(FILTER(VAR1B=75,5),75,60,5,0),COLORFFFFFF;
DRAWTEXT(FILTER(VAR1B=75,5),75,'高压'),COLORFFFFFF;
STICKLINE(PJX<=-19,-25,-20,12,0),COLORFF00FF;
STICKLINE(PJX>=70,85,80,12,0),COLORGREEN;
DRAWTEXT(FILTER(VAR5<0,5),30,'★'),COLORRED;
DRAWTEXT(FILTER(VAR5>0,5),30,'★'),COLORFFCC66;
多空预警:0,COLORFFCC66;
IF(VAR9=40 AND VAR2>=0 AND VAR3>=0,多空预警,DRAWNULL),LINETHICK2,COLORGREEN;
IF(VAR9=40 AND VAR2<=0 AND VAR3<=0,多空预警,DRAWNULL),LINETHICK2,COLORRED;[/lycode][lycode=tdx2,true]CHECK1赋值:-1
VAR1赋值:如果CHECK1<0,返回(最高价+最低价+收盘价)/3,否则返回0
VAR2赋值:如果CHECK1<0,返回(VAR1-VAR1的14日简单移动平均)/(0.015*VAR1的14日平均绝对偏差),否则返回0
VAR3赋值:如果CHECK1<0,返回(VAR1-VAR1的70日简单移动平均)/(0.015*VAR1的70日平均绝对偏差),否则返回0
VAR4赋值:如果CHECK1<0,返回如果VAR2>=150ANDVAR2<200ANDVAR3>=150ANDVAR3<200,返回10,否则返回0,否则返回0
VAR5赋值:如果CHECK1<0,返回如果VAR2<=-150ANDVAR2>-200ANDVAR3<=-150ANDVAR3>-200,返回-10,否则返回VAR4,否则返回0
VAR6赋值:如果CHECK1<0,返回(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*100,否则返回0
VAR7赋值:如果CHECK1<0,返回100-VAR6的绝对值,否则返回0
VAR8赋值:如果CHECK1<0,返回如果VAR7<90,返回VAR7,否则返回100,否则返回0
PJX赋值:如果CHECK1<0,返回100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20,否则返回0
输出短期强弱:PJX,画黄色
VAR1A赋值:如果PJX>0,返回PJX,否则返回0
VAR1B赋值:如果VAR3>=200ANDVAR2>=150,返回15,否则返回如果VAR3<=-200ANDVAR2<=-150,返回-15,否则返回VAR5+60
VAR1C赋值:VAR1A>48 AND VAR1B>60 AND VAR8<100
VAR1D赋值:VAR1A<48 AND VAR1B<60 AND VAR8<100
当满足条件VAR1DANDCOUNT(VAR1D,30)=1时,在80位置书写文字,画红色
当满足条件VAR1DANDCOUNT(VAR1D,30)=1时,在60和80位置之间画柱状线,宽度为5,0不为0则画空心柱.,画红色
当满足条件VAR1CANDCOUNT(VAR1C,30)=1时,在80位置书写文字,COLORFFCC66
当满足条件VAR1CANDCOUNT(VAR1C,30)=1时,在60和80位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFFCC66
VAR2C赋值:如果VAR3>=200ANDVAR2>=150,返回15,否则返回如果VAR3<=-200ANDVAR2<=-150,返回-15,否则返回0+30
VAR2E赋值:VAR1A<48 AND VAR2C<30 AND VAR8<100
VAR2F赋值:VAR1A<48 AND VAR2C>30 AND VAR8<100
当满足条件VAR2EANDCOUNT(VAR2E,30)=1时,在50位置书写文字,画红色
当满足条件VAR2EANDCOUNT(VAR2E,30)=1时,在30和50位置之间画柱状线,宽度为5,0不为0则画空心柱.,画红色
当满足条件VAR2FANDCOUNT(VAR2F,30)=1时,在50位置书写文字,COLORFFCC66
当满足条件VAR2FANDCOUNT(VAR2F,30)=1时,在30和50位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFFCC66
VAR3D赋值:如果VAR3<=200ANDVAR2<=150,返回-15,否则返回如果VAR3>=-200ANDVAR2>=-150,返回15,否则返回VAR5
VAR3E赋值:VAR3D>0 AND VAR8<100
VAR3F赋值:VAR1A<48 AND VAR3D<0 AND VAR8<100
当满足条件VAR7<90ANDVAR2+VAR3<=0ANDVAR3FANDCOUNT(VAR3F,30)=1时,在20位置书写文字,画红色
当满足条件VAR7<90ANDVAR2+VAR3<=0ANDVAR3FANDCOUNT(VAR3F,30)=1时,在20和0位置之间画柱状线,宽度为5,0不为0则画空心柱.,画红色
当满足条件VAR3EANDCOUNT(VAR3E,30)=1时,在20位置书写文字,COLORFFCC66
当满足条件VAR3EANDCOUNT(VAR3E,30)=1时,在20和0位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFFCC66
输出强势线:60,画红色
VAR9赋值:如果VAR7<90,返回40,否则返回30
输出分界线:30,COLORFFFFFF
当满足条件VAR1B=45的5日过滤时,在-20和-10位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFFFFFF
当满足条件VAR1B=45的5日过滤时,在0位置书写文字,COLORFFFFFF
当满足条件VAR1B=75的5日过滤时,在75和60位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFFFFFF
当满足条件VAR1B=75的5日过滤时,在75位置书写文字,COLORFFFFFF
当满足条件PJX<=-19时,在-25和-20位置之间画柱状线,宽度为12,0不为0则画空心柱.,COLORFF00FF
当满足条件PJX>=70时,在85和80位置之间画柱状线,宽度为12,0不为0则画空心柱.,画绿色
当满足条件VAR5<0的5日过滤时,在30位置书写文字,画红色
当满足条件VAR5>0的5日过滤时,在30位置书写文字,COLORFFCC66
输出多空预警:0,COLORFFCC66
如果VAR9=40ANDVAR2>=0ANDVAR3>=0,返回多空预警,否则返回无效数,线宽为2,画绿色
如果VAR9=40ANDVAR2<=0ANDVAR3<=0,返回多空预警,否则返回无效数,线宽为2,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1IHfbWSSKme49j6mEXCD2Mg

看了该指标的人还看了:
掘底买点指标    主力成本指标
横扫天下指标    底部警戒指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表