请选择 进入手机版|继续访问电脑版

杀手操盘指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-11-8 08:00:22 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
杀手操盘指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10769张

杀手操盘指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10770张

[lywrap=通达信主图指标公式][lycode=tdx,true]EMA3:EMA(C,3),COLORWHITE,LINETHICK2;
EMA13:EMA(C,13),COLORYELLOW;
EMA21:EMA(C,21),COLORFF00FF;
EMA55:EMA(C,55),COLORGREEN;
AR1:=EMA21>EMA13 AND EMA13>EMA3;
AR2:=BARSLAST((C-EMA3)/EMA3*100<-6);
AR3:=EMA3>=REF(EMA3,2);
AR4:=COUNT(CROSS(C,EMA3),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L-0.09,'红启动'),COLORYELLOW;
{STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;}
{STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;}
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA3-EMA13)+(EMA13-EMA21))/C<0.2;
BR3:=C>EMA21 AND (REF(C,1)<REF(EMA21,1) OR REF(C,2)<REF(EMA21,2) OR REF(C,3)<REF(EMA21,3) OR REF(C,4)<REF(EMA21,4) OR REF
(C,5)<REF(EMA21,5));
BR4:=BR1 AND BR2 AND BR3;
DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'蚂转强'),COLOR00C5FF;
STICKLINE(BR4 AND FILTER(BR4,10),H,L,0.5,1),COLOR00C5FF;
{STICKLINE(BR4 AND FILTER(BR4,10),O,C,6,1),LINETHICK2,COLOR00C5FF;}
CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;
CR2:=V>MA(V,5)*0.6;
CR3:=COUNT(CROSS(EMA3,EMA21),3)=1;
CR4:=ABS(EMA13-EMA21)/EMA21<0.03;
CR5:=EMA21<=EMA55 AND EMA21>=REF(EMA21,1);
CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);
{STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;}
{STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;}
DRAWTEXT(CR6,L-0.09,'侠拉升2'),COLORF00FF0;
DR1:=EMA3>EMA13 AND EMA13<EMA21;
DR2:=BARSLAST(CROSS(C,EMA21) );
DR3:=H=HHV(H,DR2);
DR4:=BARSLAST(DR3);
DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA21 AND BETWEEN((C-EMA21)/EMA21,0,0.02),DR4)=1;
DR6:=C>REF(C,1) ;
DR7:= DR1 AND DR5 AND DR6 ;
DR8:=DR7 AND FILTER(DR7 ,10);
DRAWTEXT(DR8,L-0.09,'黑拉升1'),COLORD6BA63;
{STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;}
STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;
ER:=BARSLAST(REF(CROSS(EMA21,EMA13),1)) AND CROSS(EMA13,EMA21);
DRAWTEXT(ER,L-0.09,'均上攻'),COLOR0099FF;
{STICKLINE(ER,H,L,0.5,1),COLOR0099FF;}
{STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}
FR:=BARSLAST(REF(CROSS(EMA13,EMA3),1)) AND CROSS(EMA3,EMA13);
DRAWTEXT(FR,L-0.09,'梅上升中继'),COLORWHITE;
STICKLINE(FR,H,L,0.5,1),COLORWHITE;
{STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;}
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,3,24),0,5) );
GR2:=EMA3>EMA13 AND EMA13>EMA21 AND EMA3>REF(EMA3,1);
GR3:=COUNT("BIAS.BIAS2"(6,3,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
DRAWTEXT(GR6 AND GR7,H+0.3,'见逃顶'),COLOR00FF00;
STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;
HR2:=EMA3>=REF(EMA3,3) AND EMA13>=REF(EMA13,1) AND EMA21>=REF(EMA21,1) AND CROSS(C,EMA3) AND CROSS(C,EMA13) AND CROSS
(C,EMA21){ AND CROSS(C,EMA55)};
DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,'三进场! '),COLORFFC8FF;
{STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;};
MA1:MA(CLOSE,34),COLORBLUE;

K1:=(C+H+L)/3;
D1:=MA(K1,4);
高:=REF(HHV(H,80),3);
低:=REF(LLV(L,80),3);
顶点:REFDATE(高,DATE),COLORGREEN,LINETHICK3;
低点:REFDATE(低,DATE),COLORRED,LINETHICK2;
AA05:MA(C,5),LINETHICK3,COLOR00CCFF;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK3,COLORRED;
DRAWTEXT(REF(C,1)>D1 AND C<D1 AND D1>REF(D1,1),H*1.02,'卖'),COLORGREEN;
DRAWTEXT(REF(C,1)<D1 AND C>D1 AND D1<REF(D1,1),L*0.98,'买'),COLORRED;[/lycode][lycode=tdx2,true]输出EMA3:收盘价的3日指数移动平均,画白色,线宽为2
输出EMA13:收盘价的13日指数移动平均,画黄色
输出EMA21:收盘价的21日指数移动平均,COLORFF00FF
输出EMA55:收盘价的55日指数移动平均,画绿色
AR1赋值:EMA21>EMA13 AND EMA13>EMA3
AR2赋值:上次(收盘价-EMA3)/EMA3*100<-6距今天数
AR3赋值:EMA3>=2日前的EMA3
AR4赋值:统计AR2日中满足收盘价上穿EMA3的天数=1
AR5赋值:AR1 AND AR2 AND AR3 AND AR4
AR6赋值:AR5 AND AR5的10日过滤
当满足条件AR6时,在最低价-0.09位置书写文字,画黄色
BR1赋值:统计5日中满足(收盘价-1日前的收盘价)/1日前的收盘价*100位于0和5之间的天数=5
BR2赋值:(EMA3-EMA13)+(EMA13-EMA21)的绝对值/收盘价<0.2
BR3赋值:收盘价>EMA21 AND (1日前的收盘价<1日前的EMA21 OR 2日前的收盘价<2日前的EMA21 OR 3日前的收盘价<3日前的EMA21 OR 4日前的收盘价<4日前的EMA21 OR 5日前的收盘价<5日前的EMA21)
BR4赋值:BR1 AND BR2 AND BR3
当满足条件BR4ANDFILTER(BR4,10)时,在最低价-0.09位置书写文字,COLOR00C5FF
当满足条件BR4ANDFILTER(BR4,10)时,在最高价和最低价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,COLOR00C5FF
CR1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>0.5
CR2赋值:成交量(手)>成交量(手)的5日简单移动平均*0.6
CR3赋值:统计3日中满足EMA3上穿EMA21的天数=1
CR4赋值:EMA13-EMA21的绝对值/EMA21<0.03
CR5赋值:EMA21<=EMA55 AND EMA21>=1日前的EMA21
CR6赋值:CR1ANDCR2ANDCR3ANDCR4ANDCR5的2日过滤
当满足条件CR6时,在最低价-0.09位置书写文字,COLORF00FF0
DR1赋值:EMA3>EMA13 AND EMA13<EMA21
DR2赋值:上次收盘价上穿EMA21距今天数
DR3赋值:最高价=DR2日内最高价的最高值
DR4赋值:上次DR3距今天数
DR5赋值:统计DR4日中满足开盘价>CANDC<1日前的收盘价ANDC>EMA21ANDBETWEEN((收盘价-EMA21)/EMA21,0,0.02)的天数=1
DR6赋值:收盘价>1日前的收盘价
DR7赋值: DR1 AND DR5 AND DR6
DR8赋值:DR7 AND DR7的10日过滤
当满足条件DR8时,在最低价-0.09位置书写文字,COLORD6BA63
当满足条件DR8时,在开盘价和收盘价位置之间画柱状线,宽度为6,1不为0则画空心柱.,线宽为2,COLORD6BA63
ER赋值:上次1日前的EMA21上穿EMA13距今天数 AND EMA13上穿EMA21
当满足条件ER时,在最低价-0.09位置书写文字,COLOR0099FF
FR赋值:上次1日前的EMA13上穿EMA3距今天数 AND EMA3上穿EMA13
当满足条件FR时,在最低价-0.09位置书写文字,画白色
当满足条件FR时,在最高价和最低价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,画白色
GR1赋值:上次"乖离率的BIAS2"(6,3,24)位于0和5之间距今天数
GR2赋值:EMA3>EMA13 AND EMA13>EMA21 AND EMA3>1日前的EMA3
GR3赋值:统计GR1日中满足"乖离率的BIAS2"(6,3,24)>10ANDH=GR1日内最高价的最高值的天数
GR4赋值:最高价=GR1日内最高价的最高值
GR5赋值:"平滑异同平均的MACD"(12,26,9)<1日前的"平滑异同平均的MACD"(12,26,9)
GR6赋值:GR2 AND GR3 AND GR4
GR7赋值:GR2 AND GR3 AND GR4 AND GR5
当满足条件GR6ANDGR7时,在最高价+0.3位置书写文字,COLOR00FF00
当满足条件GR6ANDGR7时,在最高价和最高价+0.09位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR00FF00
HR2赋值:EMA3>=3日前的EMA3 AND EMA13>=1日前的EMA13 AND EMA21>=1日前的EMA21 AND 收盘价上穿EMA3 AND 收盘价上穿EMA13 AND 收盘价上穿EMA21
当满足条件HR2ANDFILTER(HR2,10)时,在最低价-0.09位置书写文字,COLORFFC8FF

输出MA1:收盘价的34日简单移动平均,画蓝色
K1赋值:(收盘价+最高价+最低价)/3
D1赋值:K1的4日简单移动平均
高赋值:3日前的80日内最高价的最高值
低赋值:3日前的80日内最低价的最低值
输出顶点:日期日高,画绿色,线宽为3
输出低点:日期日低,画红色,线宽为2
输出AA05:收盘价的5日简单移动平均,线宽为3,COLOR00CCFF
BB05赋值:(AA05/1日前的AA05-1)*100的反正切*180/3.1416
如果BB05>30ANDAA05>1日前的AA05,返回AA05,否则返回无效数,线宽为3,画红色
当满足条件1日前的收盘价>D1ANDC<D1ANDD1>1日前的D1时,在最高价*1.02位置书写文字,画绿色
当满足条件1日前的收盘价<D1ANDC>D1ANDD1<1日前的D1时,在最低价*0.98位置书写文字,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1MIpvQ2V6xAtYzviRdrEY1Q

看了该指标的人还看了:
极度准确指标    看色操作指标
主力通侧底指标    建仓启动指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表