请选择 进入手机版|继续访问电脑版

牛的影子指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-11-5 08:00:16 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
牛的影子指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10711张

牛的影子指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10712张

[lywrap=通达信主图指标公式][lycode=tdx,true]生命线:MA(CLOSE,26),COLORRED,LINETHICK2;
STICKLINE(C>=生命线 AND C>=O,H,L,0,1),COLORRED;
STICKLINE(C>=生命线 AND C>=O,C,O,2.5,0),COLORRED;
DP:=IF(C=INDEXC,0,1);GJ:=AMOUNT/V/100 ;
多头线:EMA(C,1.5),COLOR0000CC;
空头线:EMA(C,5),COLORMAGENTA;
均衡线:EMA(空头线,5),COLORGREEN;
VARF1:=COUNT(CROSS(多头线,均衡线),2)=1;
VARF2:=COUNT(CROSS(空头线,均衡线),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡线*0.98,'★青春若庭☆'),COLORYELLOW;
MTM:=CLOSE-REF(CLOSE,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
DY:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.8,O,C,2.5,0),COLORRED;
STICKLINE(ZDF<-9.8,O,C,2.5,0),COLORBLUE;
白买进:DRAWNULL,NODRAW,COLORWHITE;
黄加仓:DRAWNULL,NODRAW,COLORYELLOW;
蓝跌:DRAWNULL,NODRAW,COLORBLUE;
绿见顶:DRAWNULL,NODRAW,COLORGREEN;
红强势:DRAWNULL,NODRAW,COLORRED;
红蓝调整:DRAWNULL,NODRAW,COLORGRAY;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),1);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),9);
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.984),'↖神刀来了'),COLOR4440FF;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.02),'卖 '),COLORFFFF34;
VARE1:=EMA(C,3);VARE2:=EMA(C,5);VARE3:=EMA(C,10);VAR4:=EMA(C,20);VAR5:=EMA(C,30);VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;VAR7:=(VAR6-REF(VAR6,15))/REF(VAR6,15)*100;
VAR8:=(VAR6-REF(VAR6,15))/REF(VAR6, 15)*100;VAR9:=EMA(VAR7,8);
STICKLINE(VAR7<1*REF(VAR7,1),H,L,0,1),COLORBLUE;
STICKLINE(VAR7<1*REF(VAR7,1),O,C,2.5,1),COLORBLUE;
STICKLINE(VAR7<1*REF(VAR7,1) AND C<O,O,C,2.5,0),COLORBLACK;
STICKLINE(VAR7<1*REF(VAR7,1) AND C<O,O,C,2.3,0),COLORBLUE;
STICKLINE(VAR7>1*REF(VAR7,1),H,L,0,1),COLORRED;
STICKLINE(VAR7>1*REF(VAR7,1),O,C,2.5,1),COLORRED;
STICKLINE(VAR7>1*REF(VAR7,1) AND C<O,O,C,2.5,0),COLOR0000DD;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),H,L,0,1),COLORGREEN;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),O,C,2.5,1),COLORGREEN;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1) AND C<O,O,C,2.5,0),COLORGREEN;
买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
STICKLINE(买进条件,H,L,0,1),COLORWHITE,LINETHICK1;
STICKLINE(买进条件,O,C,2.5,0),COLORWHITE,LINETHICK2;
加码价:=((C-REF(MA(C,18),1))/18+MA(C,18))*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
STICKLINE(加码条件,H,L,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(加码条件,O,C,2.5,0),COLORYELLOW,LINETHICK2;[/lycode][lycode=tdx2,true]输出生命线:收盘价的26日简单移动平均,画红色,线宽为2
当满足条件收盘价>=生命线ANDC>=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
当满足条件收盘价>=生命线ANDC>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画红色
DP赋值:如果收盘价=大盘的收盘价,返回0,否则返回1
GJ赋值:成交额(元)/成交量(手)/100
输出多头线:收盘价的1.5日指数移动平均,COLOR0000CC
输出空头线:收盘价的5日指数移动平均,画洋红色
输出均衡线:空头线的5日指数移动平均,画绿色
VARF1赋值:统计2日中满足多头线上穿均衡线的天数=1
VARF2赋值:统计2日中满足空头线上穿均衡线的天数=1
ZAI赋值:VARF1ANDVARF2的2日过滤
当满足条件ZAI时,在均衡线*0.98位置书写文字,画黄色
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
DY赋值:2日内DX的最高值=7日内DX的最高值 AND 统计2日中满足DX>50的天数 AND DX的2日简单移动平均上穿DX
LC赋值:1日前的收盘价
RSI赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
ZDF赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
当满足条件ZDF>9.8时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画红色
当满足条件ZDF<-9.8时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画蓝色
输出白买进:无效数,NODRAW,画白色
输出黄加仓:无效数,NODRAW,画黄色
输出蓝跌:无效数,NODRAW,画蓝色
输出绿见顶:无效数,NODRAW,画绿色
输出红强势:无效数,NODRAW,画红色
输出红蓝调整:无效数,NODRAW,画深灰色
VAR1赋值:(100 - ((90 * (21日内最高价的最高值 - 收盘价)) / (21日内最高价的最高值 - 21日内最低价的最低值)))
VAR2赋值:(100 - ((90 * (21日内最高价的最高值 - 收盘价)) / (21日内最高价的最高值 - 21日内最低价的最低值)))
VAR3赋值:(100 - ((100*(6日内最高价的最高值-收盘价))/(6日内最高价的最高值-6日内最低价的最低值))的34日简单移动平均)
当满足条件VAR2上穿VAR3的6日简单移动平均时,在(最低价*0.998)位置画1号图标
当满足条件VAR3的6日简单移动平均上穿VAR1时,在(最高价*1.013)位置画9号图标
当满足条件VAR2上穿VAR3的6日简单移动平均时,在(最低价*0.984)位置书写文字,COLOR4440FF
当满足条件VAR3的6日简单移动平均上穿VAR1时,在(最高价*1.02)位置书写文字,COLORFFFF34
VARE1赋值:收盘价的3日指数移动平均
VARE2赋值:收盘价的5日指数移动平均
VARE3赋值:收盘价的10日指数移动平均
VAR4赋值:收盘价的20日指数移动平均
VAR5赋值:收盘价的30日指数移动平均
VAR6赋值:(VAR2+VAR3+VAR4+VAR5)/4
VAR7赋值:(VAR6-15日前的VAR6)/15日前的VAR6*100
VAR8赋值:(VAR6-15日前的VAR6)/15日前的VAR6*100
VAR9赋值:VAR7的8日指数移动平均
当满足条件VAR7<1*1日前的VAR7时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画蓝色
当满足条件VAR7<1*1日前的VAR7时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,1不为0则画空心柱.,画蓝色
当满足条件VAR7<1*1日前的VAR7ANDC<开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画黑色
当满足条件VAR7<1*1日前的VAR7ANDC<开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,画蓝色
当满足条件VAR7>1*1日前的VAR7时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
当满足条件VAR7>1*1日前的VAR7时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,1不为0则画空心柱.,画红色
当满足条件VAR7>1*1日前的VAR7ANDC<开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR0000DD
当满足条件VAR7<1*1日前的VAR7ANDVAR9>1*1日前的VAR9时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画绿色
当满足条件VAR7<1*1日前的VAR7ANDVAR9>1*1日前的VAR9时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,1不为0则画空心柱.,画绿色
当满足条件VAR7<1*1日前的VAR7ANDVAR9>1*1日前的VAR9ANDC<开盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画绿色
买进价赋值:((收盘价-1日前的收盘价的6日简单移动平均)/6+收盘价的6日简单移动平均)*1.004
买进条件赋值:收盘价上穿买进价 AND 买进价>1日前的买进价
当满足条件买进条件时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画白色,线宽为1
当满足条件买进条件时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画白色,线宽为2
加码价赋值:((收盘价-1日前的收盘价的18日简单移动平均)/18+收盘价的18日简单移动平均)*1.004
加码条件赋值:收盘价上穿加码价 AND 加码价>1日前的加码价
当满足条件加码条件时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画黄色,线宽为2
当满足条件加码条件时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画黄色,线宽为2[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/11bPpiscuCpnB3MnRsimKkA

看了该指标的人还看了:
超短线指标    自动波浪指标
决策指标    一柱擎天指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表