指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 操盘控盘 
TIM截图20180926103149.png

TIM截图20180926103159.png

[lywrap=通达信主图指标公式][lycode=tdx,true]M60:=MA(C,5);
M120:=MA(C,20);
DRAWBAND(M60,RGB(90,0,0),M120,RGB(0,90,0));

{牛熊变线}
变线:=EMA(MA(CLOSE,30),5),LINETHICK0;{20 或 30 或 35}

STICKLINE(C>=变线 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=变线 AND C>=O,C,O,2.7,1),COLORRED;

STICKLINE(C>变线 AND C<=O,H,L,0,1),COLORCYAN;
STICKLINE(C>变线 AND C<=O,C,O,3,0),COLORCYAN;
STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORCYAN;
STICKLINE(C<变线 AND C<=O,C,O,3,0),COLORCYAN;

STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORGRAY;
STICKLINE(C<变线 AND C>O,H,L,0,1),COLORGRAY;
STICKLINE(C<变线 AND C>O,C,O,3,1),COLORGRAY;
STICKLINE(C<变线 AND C<=O,C,O,3,1),COLORGRAY;

{分水岭操作线}
PM:MA(C,5),COLORGRAY,LINETHICK1;{可用13}
IF(PM<REF(PM,1),PM,DRAWNULL),COLORGRAY,LINETHICK0;
IF(PM>=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
A:=MA(CLOSE,12)+ABS(MA(CLOSE,12)-REF(MA(CLOSE,12),1));{原公式为17,最终确定为12}
B:=MA(CLOSE,12)+MA(CLOSE,12)-REF(MA(CLOSE,12),1);
分水岭:=IF(MA(CLOSE,12)<B,B,MA(CLOSE,12));
操作线:=分水岭-(EMA(C,3)-分水岭);
AA:=CROSS(分水岭,操作线);
STICKLINE(AA,C,O,3,0),COLOR0000AA;
STICKLINE(AA,C,O,2,0),COLOR0033CC;
STICKLINE(AA,C,O,1,0),COLOR0055EE;
STICKLINE(AA,C,O,0.3,0),COLOR0099FF;
STICKLINE(AA,H,L,0,1),COLOR0099FF;
RR:=CROSS((MA(VOL,5)),(MA(VOL,10))) AND MA(C,2)>=MA(C,4); {AND VOL>=REF(VOL,1)}
STICKLINE(RR,C,O,3,0),COLOR0000AA;
STICKLINE(RR,C,O,2,0),COLOR0033CC;
STICKLINE(RR,C,O,1,0),COLOR0055EE;
STICKLINE(RR,C,O,0.3,0),COLOR0099EE;
STICKLINE(RR,H,L,0,1),COLOR0099FF;
MA5:MA(CLOSE,5),NODRAW;
MA10:MA(CLOSE,10),COLORCC66FF;
MA20:MA(CLOSE,20),COLORFFCC66,LINETHICK2;
DRAWTEXT(CROSS(MA5,MA20),MA5,'牛'),COLORYELLOW,LINETHICK4;
DRAWTEXT(CROSS(MA20,MA5),MA5,'熊'),COLORWHITE,LINETHICK2;[/lycode][lycode=tdx2,true]M60赋值:收盘价的5日简单移动平均
M120赋值:收盘价的20日简单移动平均
画带状线
变线赋值:收盘价的30日简单移动平均的5日指数移动平均,线宽为0
当满足条件收盘价>=变线ANDC>=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件收盘价>=变线ANDC>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.7,1不为0则画空心柱.,画红色
当满足条件收盘价>变线ANDC<=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
当满足条件收盘价>变线ANDC<=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画青色
当满足条件收盘价<变线ANDC<=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
当满足条件收盘价<变线ANDC<=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画青色
当满足条件收盘价<变线ANDC<=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画深灰色
当满足条件收盘价<变线ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画深灰色
当满足条件收盘价<变线ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画深灰色
当满足条件收盘价<变线ANDC<=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画深灰色
输出PM:收盘价的5日简单移动平均,画深灰色,线宽为1
如果PM<1日前的PM,返回PM,否则返回无效数,画深灰色,线宽为0
如果PM>=1日前的PM,返回PM,否则返回无效数,画红色,线宽为2
如果PM=1日前的PM,返回PM,否则返回无效数,画红色,线宽为2
A赋值:收盘价的12日简单移动平均+收盘价的12日简单移动平均-1日前的收盘价的12日简单移动平均的绝对值
B赋值:收盘价的12日简单移动平均+收盘价的12日简单移动平均-1日前的收盘价的12日简单移动平均
分水岭赋值:如果收盘价的12日简单移动平均<B,返回B,否则返回收盘价的12日简单移动平均
操作线赋值:分水岭-(收盘价的3日指数移动平均-分水岭)
AA赋值:分水岭上穿操作线
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000AA
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0033CC
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0055EE
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR0099FF
当满足条件AA时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,COLOR0099FF
RR赋值:(成交量(手)的5日简单移动平均)上穿(成交量(手)的10日简单移动平均) AND 收盘价的2日简单移动平均>=收盘价的4日简单移动平均
当满足条件RR时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000AA
当满足条件RR时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0033CC
当满足条件RR时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0055EE
当满足条件RR时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR0099EE
当满足条件RR时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,COLOR0099FF
输出MA5:收盘价的5日简单移动平均,NODRAW
输出MA10:收盘价的10日简单移动平均,COLORCC66FF
输出MA20:收盘价的20日简单移动平均,COLORFFCC66,线宽为2
当满足条件MA5上穿MA20时,在MA5位置书写文字,画黄色,线宽为4
当满足条件MA20上穿MA5时,在MA5位置书写文字,画白色,线宽为2[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1mYMgJKWeAJcDJtlBEzOsRA

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复